Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Air Conditioning Fault
Post Reply  Down to end
Page 4 of 4 <1234
Flack
Site Sponsor 


Member Since: 06 Sep 2006
Location: Preston Lancashire
Posts: 4779

England 2007 Discovery 3 TDV6 XS Auto Stornoway GreyDiscovery 3

Have they checked out the AAS on the front under the grill to see if that is working there are so many links in this system so I would do what Wiggs has suggested and get your codes read as a starter

Flack Thumbs Up
 
IID Pro All D3 & D4 & RRS
Software Upgrades Available ,Fault Diagnostics Servicing. BAS Authorised Remap Dealer .Cam Belt Fitting Service.Mobile Service Email or PM for more info. 
 
Post #95875325th Jul 2012 11:19 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
baart
 


Member Since: 03 May 2007
Location: WARSAW
Posts: 133

Poland 2011 LR4 5.0 V8 HSE Auto Barolo BlackLR4

They told me they have read and reset all error codes, but will double check and post codes here if any
And what's the AAS stand for please?
 | Il boit pour oublier qu'il vit
Il dort pour oublier qu'il boit
C'est un bien triste
Un bien triste sort |
 
 
Post #95879925th Jul 2012 1:09 pm
View user's profile Send private message View poster's gallery Reply with quote
Flack
Site Sponsor 


Member Since: 06 Sep 2006
Location: Preston Lancashire
Posts: 4779

England 2007 Discovery 3 TDV6 XS Auto Stornoway GreyDiscovery 3

baart wrote:
They told me they have read and reset all error codes, but will double check and post codes here if any
And what's the AAS stand for please?


Ambient air sensor it gives a read out on the dash

Flack Thumbs Up
 
IID Pro All D3 & D4 & RRS
Software Upgrades Available ,Fault Diagnostics Servicing. BAS Authorised Remap Dealer .Cam Belt Fitting Service.Mobile Service Email or PM for more info. 
 
Post #95889525th Jul 2012 5:13 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
baart
 


Member Since: 03 May 2007
Location: WARSAW
Posts: 133

Poland 2011 LR4 5.0 V8 HSE Auto Barolo BlackLR4

thanks, will check
however the guy said all the electrical signals are ok, just the compressor does not start
 | Il boit pour oublier qu'il vit
Il dort pour oublier qu'il boit
C'est un bien triste
Un bien triste sort |
 
 
Post #95903026th Jul 2012 4:45 am
View user's profile Send private message View poster's gallery Reply with quote
Flack
Site Sponsor 


Member Since: 06 Sep 2006
Location: Preston Lancashire
Posts: 4779

England 2007 Discovery 3 TDV6 XS Auto Stornoway GreyDiscovery 3

baart

Operation of the air conditioning system is controlled by the Automatic Temperature Control Module (ATCM). You need to get this module checked out.

Flack Thumbs Up
 
IID Pro All D3 & D4 & RRS
Software Upgrades Available ,Fault Diagnostics Servicing. BAS Authorised Remap Dealer .Cam Belt Fitting Service.Mobile Service Email or PM for more info. 
 
Post #95910126th Jul 2012 9:07 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
baart
 


Member Since: 03 May 2007
Location: WARSAW
Posts: 133

Poland 2011 LR4 5.0 V8 HSE Auto Barolo BlackLR4

OK, thanks
 | Il boit pour oublier qu'il vit
Il dort pour oublier qu'il boit
C'est un bien triste
Un bien triste sort |
 
 
Post #95911926th Jul 2012 9:39 am
View user's profile Send private message View poster's gallery Reply with quote
luciogodoy
 


Member Since: 14 Apr 2008
Location: Winchester - UK
Posts: 348

Brazil 2006 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

Hi all

Took my disco to LR in Slough today to check the aircon; had gassed the aircon at Kwik-fit 3 weeks ago and the aircon wasnt cooling at all.

LR kept the car for the day and told me that I had a leak on the rear pipes just below the passenger seat.

I had previously learned that when your aircon is gassed they will usually add an UV dye, to make troubleshoting easier.

At the end of the day I took the car away today without fixing the issue as LR didn't have the pipe in stock.

As you probably already guessed I went to maplin and purchased an UV light as I wanted to be sure that the £473 they are charging me is worth, so waited until night time and used the UV light, for my amusement I could NOT find any leaks or proof that LR had actually investigated the leak! No marks under the front wheel arch or other points where the dirt was cleaned.

No UV dye to be found anywhere, apart from a small spill next to the valve on the engine bay.

Just from my own piece of mind, if there was a leak, should i have seen the UV dye right?

LR has regassed the system and it is working for now. I even powered the car, aircon on, and no leak!!

Thanks

Lucio
 Disco 3 HSE MY07, D4 heated Steering/W, D4 rear cluster, D4 extended roof rack, D4 grille & air grille, D4 rear bumper, colour coded arches + front bumper, side-steps, Webasto timer/ remote control, De-Tangoed Xenon headlights + HID, LEDs all around, reverse CAM (RR hack) + brightness, DLR LEDs, 3-click indicator, SatNav on the move, EGR's done, front/rear antiroll bar Polybush, gearbox pan/filter + oil mega-flush, front/rear diff oil, new oil pump + water pump, timing belts replaced.  
Post #95935026th Jul 2012 10:01 pm
View user's profile Send private message View poster's gallery Reply with quote
Sandvika
 


Member Since: 17 Apr 2012
Location: Berkshire
Posts: 4

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

steve the magpie wrote:
my d3 air con lost its gas when i checked it out i found that the pipe at the bottom of the condeser. it had worn through on a bit of sponge? was told i could solder it up but i replaced it £89.00 + vat from famouse four at louth was told that it was the most comon fault easy fit to do then regas job done mine is a 54 plate hse diseal check bottom left of air con rad/ condenser with front grill off look for foam sponge rubbing on bend at base of the pipe from condenser thats what naffed mine up Censored


Got my D3 aircon recharged today at Kwik Fit but was not relieved of my cash because it leaks like a sieve. I'd have thought the leak would have been found before recharging the system but evidently not. The leak I could see is at the bottom left hand corner of the radiator - I hope it's like this example and was caused by a jet of refrigerant rather than a rupture of the radiator itself.

  
Post #9616842nd Aug 2012 2:19 pm
View user's profile Send private message View poster's gallery Reply with quote
AlexandreD3
 


Member Since: 29 Jan 2016
Location: Belo Horizonte
Posts: 2

Brazil 2007 Discovery 3 TDV6 HSE Auto Aintree GreenDiscovery 3

Dear Friends, Asking from Brazil. I have a D3TDV6HSE.DIESEL.2007. I have been having a mistirious problem with my Air conditioner. Suddenly cold air stops working despite the front and back fan still working, also it comes an Hot air with engine smell. All of these when the car are moving on position "D". When we stop the car and switch to "P" or "N" the air starts coming cold but not "freezing" as I regulate the knob of the Air temperature to the Blue position. So it has been "random" working and not working I think there is something depending on the outside air conditions. Now it is summer here in Brasil and it is really hot and humid / 30 to 35 c - 90% moisture. Anyway, I have checked fusels and Liquid freeze, found some leakage on tubes, compressor and fixed it. Was a enormous work since we almost dismateled the front part the car to have compressor access. All done when we just started the car, the same problem again. It seamed two things, or the compressor is not working or the something is telling the compressor to stop working to avoid. The specialist said could be the big radiator Fan as it has a viscous liquid to push the fan to help the compressor. He noticed he could stop the fan with the hands. So he dismantled everything again and we changed the fan, ( the car is 125.000 km or about 90.000 miles), we changed it and it was like doing nothing since the beginning. A new Compressor here in Brasil is amazingly expensive and just buy a new one to "try" is out of the possibility. Also, since the car was 15.000 miles a sign in the dashboard are telling that the car are having a problem with the coolant sensor. Another specialist check it long time ago that it wasn't interfering in anything and it was just a bad sensor working. The air conditioner specialist said "MAYBE" it could be interfering in the properly work of the AC. So I am desperate with that and I would "BUY" more one part which is the COLANT TANK mean more expenses without a clue if it will work or not. We are crazing looking for the problem and my car is already 30 days stopped on his garage trying and trying. Does any specialist can HELP ME on it?
  
Post #160119429th Jan 2016 10:48 am
View user's profile Send private message View poster's gallery Reply with quote
Southcoast
 


Member Since: 09 May 2016
Location: Sussèx
Posts: 9


Hi All

I have a leak in the Air Con in my 2005 D3 - had it in for a re-gas but it failed the pre-gas test, the garage couldn't find the source of the leak using dye so have said to take it to a specialist or main dealer to be fixed..

Reading up it seems a common fault on this model / age but I was wondering do they usually fail in the same place..? What do those who have had this fixed suggest..? Is it a simple fix by mobile a Air-con specialist or is this one best left to a LR main dealer..?

Any advice would be greatly appreciated..!
  
Post #165549916th May 2016 3:35 pm
View user's profile Send private message View poster's gallery Reply with quote
Southcoast
 


Member Since: 09 May 2016
Location: Sussèx
Posts: 9


Further to my last post - Does any one have any recommendations for an Aircon fix in the Brighton / West Sussex area... either garage or mobile technician..?
  
Post #165573816th May 2016 10:26 pm
View user's profile Send private message View poster's gallery Reply with quote
UtilityGuy
 


Member Since: 26 Mar 2016
Location: Northampton
Posts: 343

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

I guess my ones leaking then, is it a simple de-gas, new rubber seal, and re gas and its fixed ?

  
Post #181851123rd May 2017 10:45 pm
View user's profile Send private message View poster's gallery Reply with quote
lynalldiscovery
 


Member Since: 22 Dec 2009
Location: Maidstone
Posts: 3920

United Kingdom 2006 Discovery 3 TDV6 Metropolis LE Auto Bonatti GreyDiscovery 3

Give it a good clean and if its coming from the joint itself a seal should do the trick, mine rotted the pipe out just slightly to one side of the same joint.
 No Illeism here.  
Post #181853924th May 2017 5:39 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 4 of 4 <1234
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site