Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Electrical] Airbag Warning Light
Post Reply  Down to end
Page 2 of 3 <123>
Miguel
 


Member Since: 16 Sep 2008
Location: Viseu
Posts: 103

Portugal 2005 Discovery 3 4.4 V8 HSE Auto Tonga GreenDiscovery 3

It all happened when making the GLP the mechanic pulled the driver seat to the front and got a nice red light right afterwards.. so I am guessing that either the door or the driver seat are the problem.

I was stupid enough to go to the stealer to solve this problem two days ago, without asking for a cost estimate.
They now tell me that after two days they can't find the problem so probably only tomorrow will I have the car.. at least 16 hours to solve this problem or maybe 24 .. I fear for the final tab ..

Big Cry Big Cry
  
Post #53392613th Oct 2009 1:56 pm
View user's profile Send private message View poster's gallery Reply with quote
Miguel
 


Member Since: 16 Sep 2008
Location: Viseu
Posts: 103

Portugal 2005 Discovery 3 4.4 V8 HSE Auto Tonga GreenDiscovery 3

Just came back from the stealer.. the problem was a screw holding the glp tube inserted from the downside that cutted one or two wires coming from the airbag :S... hope the GLP mechanic has got a good insurance for this kind of things, because I won't pay that bill!!!! Evil or Very Mad Evil or Very Mad
  
Post #53395213th Oct 2009 2:57 pm
View user's profile Send private message View poster's gallery Reply with quote
Dazzahooz
 


Member Since: 31 Oct 2009
Location: Surrey
Posts: 23

United Kingdom 2005 Discovery 3 TDV6 S Manual Zermatt SilverDiscovery 3

Happy Chappy wrote:
My wife's TDV6 base had this fault from new. It recurred each time I drove the car but not when she did. Reported to Guy Salmon who claimed to have "fixed" the problem only for it to re-occur next time I drove it. Eventually deduced it was moving the seat base that triggered the problem. Once I told GS this they simply unclipped and reclipped a multiplug under the dreivers seat and "robert is your aunty's husband". All Ok for 3000 miles now (touch wood)


Is this clipping and unclipping easy to do? Should i try it?
  
Post #55603425th Nov 2009 12:38 pm
View user's profile Send private message View poster's gallery Reply with quote
Mike767
 


Member Since: 15 Oct 2008
Location: Congleton, Cheshire.
Posts: 137

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Lugano TealDiscovery 3

I've just checked the loom on my 06 HSE. Basically, wife is 5'2" and the seat is a long way forward when she drives the car. When I get in, the seat runs almost fully back and in doing so, part of the seat base runs over the loom. At least one wire is exposed as the insulation has been worn away.

Is this the subject of a recall because it seems to pose a fire risk?
  
Post #57942612th Jan 2010 8:46 am
View user's profile Send private message View poster's gallery Reply with quote
Adam Tricks
 


Member Since: 31 May 2010
Location: Redditch
Posts: 2

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

Hi there i just had same problem today, my wife is 5ft2 and im nearly 6ft. She moved it on the drive today and the air bag light stuck on. I just played with wires at the front of the seat behind plastic panel and its gone off now. Only had car 2 weeks and love it. Its a 54 plate HSE with 88000 miles.
  
Post #6587629th Jun 2010 10:25 pm
View user's profile Send private message View poster's gallery Reply with quote
sopjas
 


Member Since: 30 Dec 2008
Location: Its never Dull in Hull
Posts: 280

United Kingdom 2005 Discovery 3 TDV6 S Manual Buckingham BlueDiscovery 3

I have had this problem for a few months now , it sometimes wont come on for days then for no reason it comes on.

Although i have checked the fault code and the all rh airbag connections and modules i cannot find the cause!
 'Just because you're breathing doesn't mean you're alive'

Buckingham blue, Webast timer/remote, AT2s, Black & Silver ovals ,
Privacy Glass , Drilled and Groved Discs , Xenons, Rear LED's , Light Guards,Hawkeye diagnostic unit.
TL1000R--XR600R-- 
 
Post #65929411th Jun 2010 7:54 am
View user's profile Send private message View poster's gallery Reply with quote
Blue
 


Member Since: 10 Mar 2005
Location: Zaragoza, Spain
Posts: 95


This problem appeared in my 2005 HSE for the first time this summer. Back then they told me it was a known issue, and replaced the "spiral" connector in the steering wheel. The problem reappeared, so they told me the pins in the connector needed adjusting for a good contact. The next day it was back again, and I think they're plain clueless. They'd probably keep replacing costy parts forever.

I'll take a look at the wiring under the seat as you guys suggested, there's such a mess down there that something is sure to go wrong.

I've been away from the forum for a while so I forgot how important it is to check the forums first before taking the car for repairs. Sometimes it'll help you speed the repair and save money, others it can help you dodge the BS the shop throws at you, but in any case you're better informed.
 Blue  
Post #71588314th Nov 2010 11:10 am
View user's profile Send private message View poster's gallery Reply with quote
harrim51
 


Member Since: 29 Aug 2009
Location: Malvern
Posts: 275

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Had this problem start at Xmas when I changed the washer fuse. Went through all the fixes on here with no luck so went to dealers... They downloaded new soft ware into the airbag ecu and fixed it. £165 for the job. It did come back very clean and shiny Thumbs Up
  
Post #7413865th Jan 2011 8:20 am
View user's profile Send private message View poster's gallery Reply with quote
Blue
 


Member Since: 10 Mar 2005
Location: Zaragoza, Spain
Posts: 95


Just a quick update: the cables were pretty tight under the seat and moving them did nothing so I finally took it to the dealer. They replaced the same part again saying that the connector was faulty. So far, its going well.
 Blue  
Post #7414235th Jan 2011 9:41 am
View user's profile Send private message View poster's gallery Reply with quote
aglewis
 


Member Since: 13 Jan 2011
Location: Lancaster
Posts: 6

United Kingdom 2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3
air bag warning light

I have a 2004 Disco 3 the air bag warning light came on a couple of months ago so took into Land rover main dealer who said it was a software problem, which sorted it. However it now started to come on after I turn right and stays untill I switch the engine off and then the same thing happens again, any ideas?
  
Post #7839868th Apr 2011 8:55 pm
View user's profile Send private message View poster's gallery Reply with quote
Blue
 


Member Since: 10 Mar 2005
Location: Zaragoza, Spain
Posts: 95


I suggest you have them look at the airbag connectors in the steering wheel for loose, defective or damaged contacts.
 Blue  
Post #7840058th Apr 2011 10:08 pm
View user's profile Send private message View poster's gallery Reply with quote
aglewis
 


Member Since: 13 Jan 2011
Location: Lancaster
Posts: 6

United Kingdom 2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

ok thanks for the info but would you believe it it has not come all day today, can not wait till tomorrow to see if it comes on or stays off. Maybe I have been turning left all day and gone round in circles Laughing
  
Post #7842339th Apr 2011 9:03 pm
View user's profile Send private message View poster's gallery Reply with quote
magwa
 


Member Since: 11 Sep 2013
Location: llanbrynmair
Posts: 5

Wales 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3
2005 55 plate 107,000 miles Airbag fault

My airbag light comes on with ignition, then goes off........as you turn the wheel ( either way) after 90degs the light comes on and stays on until you reset by stopping and re starting.
Its been plugged into the fault reader

They say its the driver airbag fault

Looks like the clock spring connector to me
So something to replace before the next MOT
As SRS faults are straight MOT FAILURES now !!!

Sad
  
Post #115622011th Sep 2013 8:13 pm
View user's profile Send private message View poster's gallery Reply with quote
alloyman
 


Member Since: 11 Jan 2014
Location: little hadham
Posts: 2

England 2008 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3
srs /airbag light

Dont laugh !! Reversed into a tree whilst being nagged at for not listening to the wife . Air bag/ srs light came on instantly and despite numerous attempts by a local dealer to turn it off
, it comes straight back on when ignition is turned on and stays on. Is there a crash sensor / accelorometer sensor that needs attention ?
  
Post #121590411th Jan 2014 8:40 pm
View user's profile Send private message View poster's gallery Reply with quote
washley
 


Member Since: 26 Aug 2008
Location: Australia
Posts: 14

2008 Discovery 3 TDV6 SE Auto Atacama SandDiscovery 3

I've had this problem for about a month. After reading this forum I went under the drivers seat, wiggled the wires around, slide the seat back and forth violently, and hey presto the light went out when I next started the ignition.

Not sure if this will be a lasting fix, but at least I know what area of the car is causing the problem.
  
Post #123798917th Feb 2014 1:03 am
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 2 of 3 <123>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site