Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > General (D4)

can't get warm in this car!
Post Reply  Down to end
Page 9 of 10 <12345678910>
Robbie
 


Member Since: 05 Feb 2006
Location: Waiting for my old avatar to be allowed back... we miss her!
Posts: 17555

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Auto Baltic BlueDiscovery 4

I've had a bit of a play and the interior sensor offset appears to be self-heating through the thermistor. If they want to keep this thermistor JLR need to either reduce the current flowing through it or increase the airflow over it.

There we go, investigation over - JLR can send my fee to Robbie Towers.

Right, what's next?
 Land Rover - Turning Drivers into Mechanics Since 1948

Battery & Quiescent Current Drain Testing

Diagnostics for:
Defender, FL2, D3, D4, Evoque, RRS & FFRR
A not-for-profit enterprise


 
 
Post #180370614th Apr 2017 8:36 pm
View user's profile Send private message View poster's gallery Reply with quote
Tanglewood
 


Member Since: 27 Feb 2011
Location: In the sun
Posts: 1261

United Kingdom 

70 miles to the gallon Thumbs Up
  
Post #180370914th Apr 2017 8:42 pm
View user's profile Send private message View poster's gallery Reply with quote
SkyeScot
 


Member Since: 21 May 2017
Location: Skye
Posts: 1

United Kingdom 2016 Discovery 4 3.0 TDV6 Landmark LE Auto Unknown ColourDiscovery 4

Anyone have a recent update on the heating problem? I live about 3 hours drive from nearest Land Rover garage but car is going in for a service so I was hoping there might have been some resolution that I can ask the dealer about.

However I suspect that, like me, people are finding it less noticeable now given the weather is warmer. I also suspect that come autumn/winter it will start to annoy again!
  
Post #181740121st May 2017 2:13 pm
View user's profile Send private message View poster's gallery Reply with quote
okennedy
 


Member Since: 03 Dec 2008
Location: Roscommon
Posts: 138

Ireland 2015 Discovery 4 3.0 SDV6 Commercial Auto Causeway GreyDiscovery 4

Thread revival! Whistle

Did any of ye guys have LR get to the bottom of this or have this resolved? Reading the thread I've have noticed coming from MY12 to MY15 that I too have to fiddle with the heater controls more and put the heat up further to get the cabin to a somewhat ambient temperature.

Coming into the cooler months now, was wondering had LR come up with a right fix!
 MY15 D4 Causeway Grey
MY12 D4 Orkney Grey - Gone
MY07 D3 Java Black - Gone 
 
Post #186797412th Oct 2017 11:30 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
nazca sand eddie
 


Member Since: 29 Oct 2015
Location: England
Posts: 41

United Kingdom 2016 Discovery 4 3.0 SDV6 SE Auto Firenze RedDiscovery 4

Twelve months ago I had the TSB....... update.

That stopped the sudden blast of cold air that would come through after a few minutes after driving for the first time that day.

But, the heater output is still very poor.

I have had two Freelander2 before the Disco4, and after their almost immediate warm up, the Disco4 is certainely not working correctly.

After a year I have learnt to live with it, but it's not right, especially on a high priced car.
  
Post #186800313th Oct 2017 8:23 am
View user's profile Send private message View poster's gallery Reply with quote
ecs0set
 


Member Since: 25 May 2017
Location: Dorset
Posts: 33

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Lux Auto Baltic BlueDiscovery 4

I believe the cause is above. The thermistor is self-heating.

In most cars, these have a tiny fan blowing the air over them but I suspect the Disco doesn't. When I get time, I'm going to get a small laptop fan and hook it up to blow or suck air over the thermistor. Should be a cheap fix if it works.
  
Post #186805213th Oct 2017 11:38 am
View user's profile Send private message View poster's gallery Reply with quote
okennedy
 


Member Since: 03 Dec 2008
Location: Roscommon
Posts: 138

Ireland 2015 Discovery 4 3.0 SDV6 Commercial Auto Causeway GreyDiscovery 4

Thanks lads, no point in heading for the stealers for a fix then! Thumbs Up
 MY15 D4 Causeway Grey
MY12 D4 Orkney Grey - Gone
MY07 D3 Java Black - Gone 
 
Post #186806313th Oct 2017 12:17 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Robbie
 


Member Since: 05 Feb 2006
Location: Waiting for my old avatar to be allowed back... we miss her!
Posts: 17555

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Auto Baltic BlueDiscovery 4

The fan works although on some D4s the pipe to the HEVAC is kinked. The real fix is to add a resistor to the loom to reduce the current flow a bit to give the thermistor a chance.
 Land Rover - Turning Drivers into Mechanics Since 1948

Battery & Quiescent Current Drain Testing

Diagnostics for:
Defender, FL2, D3, D4, Evoque, RRS & FFRR
A not-for-profit enterprise


 
 
Post #186820213th Oct 2017 6:20 pm
View user's profile Send private message View poster's gallery Reply with quote
tonymcg
 


Member Since: 15 Mar 2016
Location: basingstoke
Posts: 36

2016 Discovery 4 3.0 TDV6 HSE Lux Auto Santorini BlackDiscovery 4

Hi guys

Anyone got anywhere with a dealer fix for this?

Drove home tonight and had the temp on both heater controls set to 26 degrees as well as controlling the fan speed myself rather than leaving on "auto"

Cheers Very Happy
 D4 HSE Luxury 2016
D3 HSE 2009
D2 ES Premium 2003 
 
Post #187432431st Oct 2017 8:27 pm
View user's profile Send private message View poster's gallery Reply with quote
Tanglewood
 


Member Since: 27 Feb 2011
Location: In the sun
Posts: 1261

United Kingdom 

Get used to it mate, it doesn’t get any better.
  
Post #187433031st Oct 2017 8:38 pm
View user's profile Send private message View poster's gallery Reply with quote
Somerset Bumpkin
 


Member Since: 08 Mar 2015
Location: Gosport
Posts: 137

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Lux Auto Causeway GreyDiscovery 4

Mine is fine once it's warm, it's just the blast of cold air when you first start her up that does my head in.
  
Post #187434431st Oct 2017 9:06 pm
View user's profile Send private message View poster's gallery Reply with quote
Keyframe
 


Member Since: 01 May 2017
Location: Epsom
Posts: 10

United Kingdom 

This is a very interesting thread, My 2012 D4HSE also has this exact fault. It's in the workshop of the supplying LR Dealer and they're firm in their opinion that the climate is "operating as designed". They were swift to point out that LTB00963 does not apply to my car and I'm unable to get them to physically investigate further despite having 12+months of LR warranty.

Any advice is welcome and gratefully received.
  
Post #18746641st Nov 2017 6:50 pm
View user's profile Send private message View poster's gallery Reply with quote
yellodisco
 


Member Since: 17 Nov 2010
Location: Penicuik
Posts: 92

Scotland 2008 Discovery 3 TDV6 HSE Auto Tangiers OrangeDiscovery 3

Also suffering from similar issues - has to have heater set to 28 or HI to get warm air - anything else just blows cool air. Even when its on HI, I get cool air blowing up from windscreen vents. Wasn't a problem thro the summer but now that its turning colder, I'm getting the hot feet, cold head syndrome. I also asked for it to be checked out (under warranty) and was also told its "working to specification". Shouldn't have to wear a woolly hat driving a D4 in the winter months so as per post above, if anyone has any ideas for taking this back to dealer and making more of a fuss, that would be appreciated.
  
Post #18748112nd Nov 2017 12:26 am
View user's profile Send private message View poster's gallery Reply with quote
mark the spark
 


Member Since: 22 Jun 2011
Location: southampton
Posts: 1742

2014 Discovery 4 3.0 TDV6 XXV LE Auto Causeway GreyDiscovery 4

Mines in for its annual service today with west 4 X 4
spoke to the switched on techie guy who sorted my gearbox change down happy issues earlier this year

again he was aware of this reported issue and has a possible solution based around Robbies thinking of insulation of the thermistor that regulates cabin temp

When i get it back today i will update you but he was aware of a TSB about this exact issue on MY 14 and newer vehicles. fingers crossed he has a fix
 MY05 SE D3 Manual my first LR what a car
MY10 HSE D4 auto
MY14 XXV more buttons than the spaceshuttle 
 
Post #18770778th Nov 2017 9:46 am
View user's profile Send private message View poster's gallery Reply with quote
Armpit
 


Member Since: 08 Mar 2017
Location: Manchester
Posts: 22

England 2016 Discovery 4 3.0 SDV6 Graphite LE Auto ArubaDiscovery 4

Mark - any update on how you got on today at the dealers ?
Cheers - Paul
  
Post #18773078th Nov 2017 7:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 9 of 10 <12345678910>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site