Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > General (D4)

can't get warm in this car!
Post Reply  Down to end
Page 10 of 10 <12345678910
mark the spark
 


Member Since: 22 Jun 2011
Location: southampton
Posts: 1953

2014 Discovery 4 3.0 TDV6 XXV LE Auto Causeway GreyDiscovery 4

Couldt get over to pick it up tonight so picking up tomoz will update asap
 MY05 SE D3 Manual my first LR what a car
MY10 HSE D4 auto
MY14 XXV more buttons than the spaceshuttle 
 
Post #18773378th Nov 2017 9:43 pm
View user's profile Send private message View poster's gallery Reply with quote
mark the spark
 


Member Since: 22 Jun 2011
Location: southampton
Posts: 1953

2014 Discovery 4 3.0 TDV6 XXV LE Auto Causeway GreyDiscovery 4

picked the car up this morning but unfortunately the techie who did my job wasnt in today as off with the lurgy

any way via another guy i was told that the insulation foam that wraps the sensor was poorly fitted and they re insulated it and moved it slightly away from the duct .also carried out an HVAC software update

the result

now once the car is warm if i turn the heating up i now actually get some warm airflow via the dash vents although i wouldnt describe this as full force ,but it didnt do anything before so this is a difference
but i cant be sure if this is a s a result of the software uodate or the sensor work

hope this helps

the sensor is located behind the trim panel that surrounds the middle right dash vent so stikes me as something that can be done as a DIY i will take this off the weekend and have a look myself now i know were it is
 MY05 SE D3 Manual my first LR what a car
MY10 HSE D4 auto
MY14 XXV more buttons than the spaceshuttle 
 
Post #18774689th Nov 2017 11:24 am
View user's profile Send private message View poster's gallery Reply with quote
Somerset Bumpkin
 


Member Since: 08 Mar 2015
Location: Gosport
Posts: 161

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Lux Auto Causeway GreyDiscovery 4

Mines going in to finally get this fix. I hope it works as it’s doing my head in. My middle right vent doesn’t actually work (ie. I can’t open or close it) so I hope that’s part of the problem.
  
Post #188339925th Nov 2017 10:39 am
View user's profile Send private message View poster's gallery Reply with quote
Robbie
 


Member Since: 05 Feb 2006
Location: ¯\_(ツ)_/¯
Posts: 17690

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Auto Baltic BlueDiscovery 4

Helping the sensor work as intended can only improve matters but it does nothing for the self-heating of the thermistor. So on longer journeys the repeated nudging up of the dial will still be needed.
 Land Rover - Turning Drivers into Mechanics Since 1948

Battery & Quiescent Current Drain Testing

Diagnostics for:
Defender, FL2, D3, D4, Evoque, RRS & FFRR
A not-for-profit enterprise


 
 
Post #188340025th Nov 2017 10:44 am
View user's profile Send private message View poster's gallery Reply with quote
Tanglewood
 


Member Since: 27 Feb 2011
Location: In the sun
Posts: 1344

United Kingdom 

It should work regardless!
  
Post #188343825th Nov 2017 12:38 pm
View user's profile Send private message View poster's gallery Reply with quote
mark the spark
 


Member Since: 22 Jun 2011
Location: southampton
Posts: 1953

2014 Discovery 4 3.0 TDV6 XXV LE Auto Causeway GreyDiscovery 4

after a few long trips i can say its better but still not right after half an hour have to turn it up to 26 to keep temp descent and i still think the high level vent mix is wrong i do now get some warm airflow out of mid vent but nothing from the side and i think this is key as the cold from the side window needs side vent warm airflow to negate got home from a long run with a very cold right arm
 MY05 SE D3 Manual my first LR what a car
MY10 HSE D4 auto
MY14 XXV more buttons than the spaceshuttle 
 
Post #188351025th Nov 2017 4:58 pm
View user's profile Send private message View poster's gallery Reply with quote
NoosaMick
 


Member Since: 29 Oct 2017
Location: North
Posts: 2

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Unknown ColourDiscovery 4

Previously owned a RRS with FBH and it worked to heat the car up in just a few minutes and temps set to 21 would keep the car warm and comfortable.

I've now owned my D4 MY12 for three weeks and have found it very slow to warm up inside (FBH tested and is working) Also been driving around with temps set to 26 to keep warm and wife has to leave seat heat on all the time.

Definitely feels like the sensor is not correctly measuring the cabin temperature. It seems to work for a short while from start up, then starts blowing cold air, as if the sensor is now detecting the cabin has got too hot.

I'm wondering if this can be fixed by repositioning the sensor?

Also, reading above that the sensor is 'self heating', then maybe fitting a simple heatsink could help.

Am I right in thinking it's located behind to small grill to the side of the steering column?
  
Post #188361725th Nov 2017 10:46 pm
View user's profile Send private message View poster's gallery Reply with quote
lespes
 


Member Since: 17 Sep 2009
Location: Sitting Down
Posts: 1954

Guernsey 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Santorini BlackDiscovery 4

Last couple of days in cooler weather gave me a chance to play with lots of different settings over several long journeys.

What I found was that on virtually any setting cool air was still coming from the upper dash vents.

Eventually decided to switch these vents off manually and put the settings back to normal Auto operation set at 21c.

What an improvement! Temp remained steady felt warm and cosy and no other temp adjustment needed. Felt much more like it used to in previous models I have had.

I did find that the side window was still a little colder as no warm air hitting it at all but as no cool air coming from dash vents a major improvement overall in cabin comfort
 D4 HSE MY12 Marmais Teal: Gone. Missed a lot!
Freelander 2 SD HSE MY11 Silver:Thankfully gone.
D4 HSE MY11 Silver: Gone missed !
Range Rover Sport MY06 HSE Buck Blue: Gone missed!
Discovery D2 TD5 Facelift MY Red Gone Missed!
Discovery D2 TD5 Cobalt Blue: Gone Missed!
Discovery D1 Auto Oxford Blue Not missed at all!
Discovery D1 Avalon Blue First LR! missed!

Now driving a rather nice Black Van (joined Club Landmark) 
 
Post #18875007th Dec 2017 12:40 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 10 of 10 <12345678910
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site