Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Central locking problem
Post Reply  Down to end
Page 1 of 1
Alan ratty
 


Member Since: 31 Jan 2016
Location: Blackburn
Posts: 16

England 2007 Discovery 3 TDV6 GS Manual Stornoway GreyDiscovery 3
Central locking problem

Hi all, has anyone had problems with central locking just on the off side of disco 3,near side working as it should but when I lock with fob drivers door and rear door don't lock. Indicators flash but doors will open and alarm will sound. HELP Big Cry

This post has been edited by the site administration team
Post given its own title and thread. Was lost in aircon discussion.
  
Post #165869023rd May 2016 7:14 pm
View user's profile Send private message View poster's gallery Reply with quote
navedman
 


Member Since: 19 Jun 2016
Location: Cumbria
Posts: 3

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Zermatt SilverDiscovery 3

Hi all. I have a problem with opening my rear passenger door. The door is locked and does not release with the remote or the internal button. I have tried playing with the internal handle but had no luck. Can anyone help me open the door so I can investigate the door lock fault. Itmakes a noise like it is trying to open but remains locked.
  
Post #166987819th Jun 2016 8:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Leesbay
 


Member Since: 20 Dec 2011
Location: rainford
Posts: 1567

United Kingdom 2006 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

its the latch mechanism failing
its a common fault on the D3
fairly easy to repair and there is a wiki on the forum
ive just bought a new front near side and rear nearside latch mechanism which will be next weekends jobs
its a a case of taking the old mechanism out and replacing it with new. I have done it once and its not difficult just very fiddly and takes a bit of skin off your knuckles
I got my parts of ebay. new are around £80 and second hand around £45
 ....................................................................................................


If my wife ever sells my stuff for what she thinks I paid for them, you lot are gonna get some bargains! 
 
Post #166993319th Jun 2016 10:55 pm
View user's profile Send private message View poster's gallery Reply with quote
navedman
 


Member Since: 19 Jun 2016
Location: Cumbria
Posts: 3

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Zermatt SilverDiscovery 3
Central Locking

Thanks for the info. The door has unlocked this morning so I will have a look at the mechanism and give it some lubricant. The problem only seems to exist when the outside temp goes up, so I am hoping it is just sticking when something is expanding due to heat.
  
Post #166996820th Jun 2016 6:43 am
View user's profile Send private message View poster's gallery Reply with quote
Raggytigger
 


Member Since: 09 Apr 2018
Location: Shrewsbury
Posts: 2

United Kingdom 

Hi everyone, my vehicle lr3 06. Won't open using the key fobs, both fobs stopped working at the same time! I think its a problem with the car, either it doesn't recognise the fob signal or the system has faulted, it worked one day and the next nothing, I'm having to enter and exit through the passenger door lock, its a little annoying.
Can anyone give me an idea of what could be causing this please, thanks.
  
Post #19347489th Apr 2018 8:03 am
View user's profile Send private message View poster's gallery Reply with quote
Plumber
 


Member Since: 26 Nov 2016
Location: Fife
Posts: 4

Scotland 2006 Discovery 3 TDV6 Base 7 Seat Auto Cairns BlueDiscovery 3

Hi RT.
Did you get any response to your post? I have a similar problem but very erratic.
I note that if the fob doesn't lock the door I can sometimes get a response after re-entering an putting the ignition on and off again.
Infuriating!
 Previously Series 3, 108", station wagen. 300tdi Discovery Commercial. Discovery 2 TDi Commercial.  
Post #198222810th Sep 2018 5:26 pm
View user's profile Send private message View poster's gallery Reply with quote
Mikeyocdisco
 


Member Since: 18 May 2015
Location: Ramsgate Kent
Posts: 2

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

Hi had the problem where my fobs weren’t working traced the fault to water in passenger footwell where wiring loom sits and how it got there was through a perished sunroof drain nipple where it exits the body did some YouTube searches and found the easiest ways to fix both problems not an expensive fix .
  
Post #198223210th Sep 2018 5:38 pm
View user's profile Send private message View poster's gallery Reply with quote
Raggytigger
 


Member Since: 09 Apr 2018
Location: Shrewsbury
Posts: 2

United Kingdom 

I eventually got a pro to sort it out (Neil Davies Landrover, Yockleton)
It was the wiring, passengers footwell, against the outside wall. All is working perfect now, no glitches at all, this guy KNOWS Landrover.
  
Post #198231310th Sep 2018 9:39 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site