Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D4)

Centre interior Lights work but vanity and Map lights don't
Post Reply  Down to end
Page 1 of 2 12>
mcgreen1966
 


Member Since: 16 Aug 2017
Location: Leicestershire
Posts: 95

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Mariana BlackDiscovery 4
Centre interior Lights work but vanity and Map lights don't

Hi i have the same issue as this chap here :-

https://www.disco3.co.uk/forum/interior-li...ity+lights

I cannot seem to find a resolution to this issue anywhere ??

anyone else had this issue and solved it ?

Cheers
Mark
  
Post #226961129th Dec 2021 9:52 am
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 8882

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Fuse behind glovebox.

No. 1 or 2
  
Post #226962329th Dec 2021 10:37 am
View user's profile Send private message View poster's gallery Reply with quote
Kilovolt
 


Member Since: 29 Jun 2015
Location: South Derbyshire
Posts: 914

United Kingdom 2013 Discovery 4 3.0 SDV6 Commercial XS Auto Baltic BlueDiscovery 4

Morning, I can see you posted this twice so I will reply to this one.

I had an issue last month with both the front and rear centre lights not working (sometimes both, sometimes one and not the other and then the reverse). Sort of a weird combination of failures.

A couple of years ago I changed all the interior lights to LEDs (which is a great mod) and one appears to have gone faulty (likely a temperamental short circuit) which caused them both to fail (being on a common supply).

I changed both centre LEDs (not knowing which was duff) and there has been no issue since.

https://www.ebay.co.uk/itm/114467787066. He happens to be in Leicestershire same as you. Not sponsored by me though Whistle

Although your's are the vanity ones, might I suggest you remove all the lamps (front, rear and sun visors) and try inserting one bulb at one location. See if you can progress from there?

If the 12 VDC supply is shorted by just one lamp (or even faulty fitting), then they will all not work.

Just a thought Thumbs Up
 "Track day running - Don't put your foot back on the accelerator until your absolutely sure you don't have to take it off again"

Current Ride: D4 XS Commercial Baltic Blue SDV6 fully loaded with heated everything Smile
Track Days: BMW E36 M3 Evolution MY 1996 (3.2 Litre 377 BHP sat in 1,250 Kgs of car, with a pro safety cage and some serious braking power) Smile 
 
Post #226962429th Dec 2021 10:44 am
View user's profile Send private message View poster's gallery Reply with quote
mcgreen1966
 


Member Since: 16 Aug 2017
Location: Leicestershire
Posts: 95

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Mariana BlackDiscovery 4
Fuses

Pete K wrote:
Fuse behind glovebox.

No. 1 or 2


Hi Pete, i think in the D4 its fuse 57, its not the same as the D3.

Cheers
Mark
  
Post #226962729th Dec 2021 10:54 am
View user's profile Send private message View poster's gallery Reply with quote
mcgreen1966
 


Member Since: 16 Aug 2017
Location: Leicestershire
Posts: 95

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Mariana BlackDiscovery 4

Kilovolt wrote:
Morning, I can see you posted this twice so I will reply to this one.

I had an issue last month with both the front and rear centre lights not working (sometimes both, sometimes one and not the other and then the reverse). Sort of a weird combination of failures.

A couple of years ago I changed all the interior lights to LEDs (which is a great mod) and one appears to have gone faulty (likely a temperamental short circuit) which caused them both to fail (being on a common supply).

I changed both centre LEDs (not knowing which was duff) and there has been no issue since.

https://www.ebay.co.uk/itm/114467787066. He happens to be in Leicestershire same as you. Not sponsored by me though Whistle

Although your's are the vanity ones, might I suggest you remove all the lamps (front, rear and sun visors) and try inserting one bulb at one location. See if you can progress from there?

If the 12 VDC supply is shorted by just one lamp (or even faulty fitting), then they will all not work.

Just a thought Thumbs Up


Cheers I will do that and see what happens Smile
  
Post #226962829th Dec 2021 10:56 am
View user's profile Send private message View poster's gallery Reply with quote
Kilovolt
 


Member Since: 29 Jun 2015
Location: South Derbyshire
Posts: 914

United Kingdom 2013 Discovery 4 3.0 SDV6 Commercial XS Auto Baltic BlueDiscovery 4

Oh meant to say, the faulty LED did not blow the fuse Rolling Eyes which is why I changed the lamps.

And yes, I am an electrical engineer Whistle
 "Track day running - Don't put your foot back on the accelerator until your absolutely sure you don't have to take it off again"

Current Ride: D4 XS Commercial Baltic Blue SDV6 fully loaded with heated everything Smile
Track Days: BMW E36 M3 Evolution MY 1996 (3.2 Litre 377 BHP sat in 1,250 Kgs of car, with a pro safety cage and some serious braking power) Smile 
 
Post #226962929th Dec 2021 10:59 am
View user's profile Send private message View poster's gallery Reply with quote
mcgreen1966
 


Member Since: 16 Aug 2017
Location: Leicestershire
Posts: 95

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Mariana BlackDiscovery 4
Lights

Cheers, I presume its fuse 57 ? if you can remember

Cheers
mark
  
Post #226963229th Dec 2021 11:06 am
View user's profile Send private message View poster's gallery Reply with quote
Kilovolt
 


Member Since: 29 Jun 2015
Location: South Derbyshire
Posts: 914

United Kingdom 2013 Discovery 4 3.0 SDV6 Commercial XS Auto Baltic BlueDiscovery 4

Give me a minute, I have the wiring diagrams here, let me check for sure.
 "Track day running - Don't put your foot back on the accelerator until your absolutely sure you don't have to take it off again"

Current Ride: D4 XS Commercial Baltic Blue SDV6 fully loaded with heated everything Smile
Track Days: BMW E36 M3 Evolution MY 1996 (3.2 Litre 377 BHP sat in 1,250 Kgs of car, with a pro safety cage and some serious braking power) Smile 
 
Post #226963329th Dec 2021 11:09 am
View user's profile Send private message View poster's gallery Reply with quote
Kilovolt
 


Member Since: 29 Jun 2015
Location: South Derbyshire
Posts: 914

United Kingdom 2013 Discovery 4 3.0 SDV6 Commercial XS Auto Baltic BlueDiscovery 4

Yes definitely Fuse 57 which is rated 10 amps Thumbs Up
 "Track day running - Don't put your foot back on the accelerator until your absolutely sure you don't have to take it off again"

Current Ride: D4 XS Commercial Baltic Blue SDV6 fully loaded with heated everything Smile
Track Days: BMW E36 M3 Evolution MY 1996 (3.2 Litre 377 BHP sat in 1,250 Kgs of car, with a pro safety cage and some serious braking power) Smile 
 
Post #226963829th Dec 2021 11:20 am
View user's profile Send private message View poster's gallery Reply with quote
Kilovolt
 


Member Since: 29 Jun 2015
Location: South Derbyshire
Posts: 914

United Kingdom 2013 Discovery 4 3.0 SDV6 Commercial XS Auto Baltic BlueDiscovery 4

Could you guys be suffering the same issue?

https://www.disco4.com/forum/battery-saver-relay-198713.html

Question
 "Track day running - Don't put your foot back on the accelerator until your absolutely sure you don't have to take it off again"

Current Ride: D4 XS Commercial Baltic Blue SDV6 fully loaded with heated everything Smile
Track Days: BMW E36 M3 Evolution MY 1996 (3.2 Litre 377 BHP sat in 1,250 Kgs of car, with a pro safety cage and some serious braking power) Smile 
 
Post #22702881st Jan 2022 6:35 pm
View user's profile Send private message View poster's gallery Reply with quote
mcgreen1966
 


Member Since: 16 Aug 2017
Location: Leicestershire
Posts: 95

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Mariana BlackDiscovery 4
Fuse 57

Hi I think that's for a D3 ? but my fuse 57 has blown, I tried a new one and it blew straight away Sad

I have taken out all the bulbs, they are normal ones, but I need to order some more spare 10A fuses to try. looks like its a short somewhere.

looking at the diagram the relay is before the fuse, so its will not be that, the rest is just simple lights and switches to ground.

Cheers
Mark
  
Post #22705653rd Jan 2022 3:37 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 10902

Ukraine 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

I found that, when fitting LEDs in the interior light housings, it was very easy to push the middle of the fitting backwards through the housing. Check none have gone backwards enough to short the circuit.
 .


Dean
====================================

2011 D4 XS - OBD port protection, RLD spare wheel protector, All LED interiors lights, Timed Climate enabled, iiD tool paired.
2011 D4 Landmark - Stolen from same dealer before I paid for it
2011 D4 GS - Stolen whilst at dealer Sad ... All LED interiors lights, DRLs, Spare Wheel protector.
1996 300Tdi - Eaten by tin worms 
 
Post #22705683rd Jan 2022 4:30 pm
View user's profile Send private message View poster's gallery Reply with quote
mcgreen1966
 


Member Since: 16 Aug 2017
Location: Leicestershire
Posts: 95

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Mariana BlackDiscovery 4
Lights

Hi I haven't swapped for LED's yet. once I get some more 10A fuses, ill try with all the bulbs out.
Then put one in at a time and see which circuit causes the fuse to blow.

I don't seem to have a Glove box light, which is in the diagram, weird !

unless one of the wires is already pinched to ground somewhere Sad

Cheers
Mark
  
Post #22705703rd Jan 2022 4:38 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 10902

Ukraine 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

From what I remember, the glovebox light is a real pain in the hand.

Think I did a thread on it a million years ago ... I'll try and find it.
  
Post #22705863rd Jan 2022 6:14 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 10902

Ukraine 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

partial result ...

https://disco4.com/forum/glove-box-light-apology-dsl-163634.html


now need to find the one DSL commented in.


yertiz ... https://disco4.com/forum/post1851377.html
  
Post #22705893rd Jan 2022 6:19 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2022 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site