Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D4)

Cruise Control on Display
Post Reply  Down to end
Page 1 of 1
alastaid
 


Member Since: 31 May 2011
Location: York
Posts: 93

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Santorini BlackDiscovery 4
Cruise Control on Display

All,

Is it just mine, but there is no consistency (that I can work out), when you have set cruise, sometimes it says "Cruise Setspeed: xxMph" all the time, and sometimes it dissappears whilst still in cruise. Not serious but for all the hours ploughing up the motorway it gets me wondering why sometimes it says it sometimes it doesnt. I have tried cancelling/resuming etc, but cant see the consistency.

Anyone else?

Rgds

Alastair
  
Post #8429963rd Oct 2011 4:44 pm
View user's profile Send private message View poster's gallery Reply with quote
MartinR
 


Member Since: 27 Jan 2008
Location: Oxon
Posts: 708

United Kingdom 2012 Discovery 4 3.0 SDV6 XS Auto Galway GreenDiscovery 4

Not just you... I never worked out the pattern! So far (all 180 miles, very little on cruise...) the new one seems better behaved!
  
Post #8430023rd Oct 2011 5:05 pm
View user's profile Send private message View poster's gallery Reply with quote
Hairy Dan
 


Member Since: 19 Jan 2011
Location: Co. Durham
Posts: 12319

United Kingdom 2016 Discovery 4 3.0 TDV6 Landmark LE Auto Santorini BlackDiscovery 4

Can't say I've seen my disappear at all, I'll have to keep a close eye on it Shocked
 Cheers Ian
--------------------
Club N.E.R.D.S
Kielder 4x4 Safari
Discoless 
 
Post #8430123rd Oct 2011 5:33 pm
View user's profile Send private message View poster's gallery Reply with quote
crews control
 


Member Since: 18 Mar 2007
Location: Dorset
Posts: 5011

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Lux Auto Waitomo GreyDiscovery 4

Not noticed mine disappearing and I use it most days?
  
Post #8430133rd Oct 2011 5:37 pm
View user's profile Send private message View poster's gallery Reply with quote
amazing
 


Member Since: 05 Mar 2011
Location: chengdu
Posts: 1540

China 2011 Discovery 4 3.0 SDV6 HSE Auto Santorini BlackDiscovery 4
still there

mine stays too
 It is better to have and not need it then need and not have it.  
Post #8432094th Oct 2011 3:49 am
View user's profile Send private message View poster's gallery Reply with quote
steveraspberry
 


Member Since: 18 Sep 2011
Location: Nr Sevenoaks,Kent
Posts: 2081

United Kingdom 

Mine stays put too - maybe time to visit the stealer? Whistle
 My17 Volvo XC90 Inscription
MY15 Mitsubishi L200 Barbarian
RGK Tiga Fx Wheelchair,
Large Alsation called Abbs Smile
Medium blue Staffie called Piglet
Medium Alsation called Bailey Smile 
 
Post #8432594th Oct 2011 9:21 am
View user's profile Send private message View poster's gallery Reply with quote
Baben
 


Member Since: 15 Feb 2006
Location: Kyalami
Posts: 2059

South Africa 2006 Discovery 3 TDV6 SE Auto Cairns BlueDiscovery 3

I have the same experience with the FFRR from time to time - when setting cruise, you normally get that message in the dash:

"Cruise set speed xxxkm/h"

sometimes it flashes up so quick you don't get to read it in time. The cruise works just fine, and (on the FFRR TFT dash) you have the little green indicator to show your set speed. Not really an operational issue, but nevertheless a little irritating software glitch
  
Post #8432654th Oct 2011 9:31 am
View user's profile Send private message View poster's gallery Reply with quote
alastaid
 


Member Since: 31 May 2011
Location: York
Posts: 93

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Santorini BlackDiscovery 4

Yes thats it exactly, still get the little green dial thingy, and cruise works perfectly. Hmmm, its due for a service soon, see how the dealer will cope with this one Smile, as I bet they wont be able to repro it.
  
Post #8432684th Oct 2011 9:36 am
View user's profile Send private message View poster's gallery Reply with quote
games1
 


Member Since: 15 Jan 2011
Location: Dalkeith
Posts: 4

Australia 2010 Discovery 4 3.0 TDV6 SE Auto Zermatt SilverDiscovery 4

The set speed indication is not always shown however if you increase or decrease speed by the + or _ buttons the visual indicator will again be shown. If you increase speed by accelorating and then resume and you are over the set speed when doing so it will not show the visble speed indicator.
  
Post #84791416th Oct 2011 11:42 am
View user's profile Send private message View poster's gallery Reply with quote
alastaid
 


Member Since: 31 May 2011
Location: York
Posts: 93

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Santorini BlackDiscovery 4

Thanks for that, glad I am not going mad, I think you are right have played about with it a bit and mine does exhibit this. Why it doesnt just show it all of the time I dont know,

Cheers

Alastair
  
Post #84807016th Oct 2011 8:40 pm
View user's profile Send private message View poster's gallery Reply with quote
WOODY179
 


Member Since: 01 Jun 2005
Location: Chesterfield
Posts: 3459

United Kingdom 

not used my cruise control a lot but very time I have used it the selected speed has been displayed until I have cancelled.
  
Post #84814716th Oct 2011 11:19 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Wenier
 


Member Since: 15 Jul 2016
Location: Christchurch
Posts: 5

New Zealand 2005 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Old thread to dig up but was getting annoyed by this exact thing of the cruise setspeed disappearing on my 2010 RRS so D4 type interior.

I have done an update of the Instrument Pack software to the latest version for me and it so far appears to have sorted that issue and now stays there.

It does shift where it is display on the screen to the top area instead of middle so maybe it is out of the way for other messages that appear now.
 2005 D3 TDV6 HSE  
Post #22710496th Jan 2022 9:13 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2022 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site