Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D4)

Electrical issues
Post Reply  Down to end
Page 1 of 1
alex0264
 


Member Since: 16 Apr 2012
Location: Taunton
Posts: 132

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Lux Auto Scotia GreyDiscovery 4
Electrical issues

I've noticed a few times since owning the car that the rear wiper is sometimes quick at sweeping across the screen, then other times it is rather slow. This morning it was literally like a snail in glue, got so far and then stopped. It's worth noting that I'd turned off stop/start, then back on again (habit) and in order to resolve the wiper issue I had to repeat this procedure, which indeed did fix it. I also have a continuous whining / high pitched noise coming through the speakers, and there are times when the audio goes quiet and gets louder again. I've read that rear screens can cause issues here, but both of those work fine and I have no faults logged when checking with IID.

This to me seems like it's some kind of power issue, and I'm considering getting the car booked in for a new engine ground cable. I appreciate that starting the car is what strains said cable the most, but if this is also the ground cable for the alternator, surely if the cable is degraded you're going to experience potential electrical issues due to high resistance?
 ------------------------------------------------------------------------------------
2016 - D4 HSE Luxury Scotia Grey - Pending...
2014 - D4 HSE Indus Silver - A total mystery
2011 - D4 HSE Stornoway Grey - Legendary car
2006 - D3 HSE Buckingham Blue - Moneypit v1 
 
Post #23657153rd Apr 2024 8:10 am
View user's profile Send private message View poster's gallery Reply with quote
Gary_P
 


Member Since: 03 May 2016
Location: Kent
Posts: 1560

Ukraine 2016 Discovery 4 3.0 SDV6 HSE Auto Corris GreyDiscovery 4

I also notice the rear wiper variation in speed, but never stopped and never at snails pace.
 Gary
-------------------------------------------

Discovery 4 HSE 2016MY 
 
Post #23657283rd Apr 2024 10:40 am
View user's profile Send private message View poster's gallery Reply with quote
itsaguything
 


Member Since: 20 Dec 2023
Location: Manotick, On
Posts: 189

Canada 2015 LR4 3.0 SCV6 HSE Lux Auto Aintree GreenLR4

Coincidentally, I took the rear wiper motor and axle apparatus apart for the. same experience.
There was corrosion on the axle and it did require effort to dislodge it from its housing.
Anyhow, emery paper and grease, reassembly, and now it works like a charm.
Clearly mechanical.

if you suspect an electrical supply issue, battery and generator and (depending on the year) bms.
Happy for you if you have caught a failing generator early…. I experienced the alternative, while travelling.

I quite like the signature block.

Cheers
 2015 LR4 HSE Lux Aintree Green
2013 LR2 HSE Radiance Red
2007 XKR Jaguar Racing Green
2005 XJR Jaguar Racing Green
2002 S-Type R British Racing Green 
 
Post #23657373rd Apr 2024 12:04 pm
View user's profile Send private message View poster's gallery Reply with quote
alex0264
 


Member Since: 16 Apr 2012
Location: Taunton
Posts: 132

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Lux Auto Scotia GreyDiscovery 4

I was once told that apparently they fitted a different motor from 2014 onwards, and that it was known to be slower? I would be inclined to think it's mechanical on this one if it were consistently slow, but as it's intermittent and after it's behaviour this morning I'm leaning more towards the electrics.

Battery was new at Christmas - genuine LR. Car is a 2016 MY with 93k on the clock. Maybe the alternator is on its way out, it's done well in fairness given the amount of work it has to do. I do still wonder about the ground cable though, probably worth getting that done at the same time as the alternator if I do get it done.
 ------------------------------------------------------------------------------------
2016 - D4 HSE Luxury Scotia Grey - Pending...
2014 - D4 HSE Indus Silver - A total mystery
2011 - D4 HSE Stornoway Grey - Legendary car
2006 - D3 HSE Buckingham Blue - Moneypit v1 
 
Post #23657393rd Apr 2024 12:25 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site