Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Australia & New Zealand

Engine cuts out whilst driving???
Post Reply  Down to end
Page 1 of 1
Baggy
 


Member Since: 11 Feb 2006
Location: sydney.....in the land of oz
Posts: 183

Australia 2011 Discovery 4 TDV6 SE Auto Stornoway GreyDiscovery 4
Engine cuts out whilst driving???

IN the last few months, my TDV6 engine would just cut out whilst driving. It has not occurred in the past, but about 6 times in the last two months. Just have to restart and off you go again. Any one else experienced this?
I'll be dropping it off to the dealer shortly for a noisy compressor, but thought someone may have had a similar intermittent fault.
 '11 TDV6 - Stornoway Grey.... still lovin' it!!

REDUCE GREENHOUSE GASSES.......Eat more BEEF!!
Addendum: Red wine goes REALLY well with BEEF 
 
Post #4326364th Mar 2009 1:11 pm
View user's profile Send private message View poster's gallery Reply with quote
ianv
 


Member Since: 20 Dec 2007
Location: Bungendore, New South Wales
Posts: 338

Australia 2015 Discovery 4 3.0 TDV6 Base 7 Seat Auto Fuji WhiteDiscovery 4

Hi,

Never heard of that and it is definetly not something to tolerate.

Needs some diagnostics ASAP, do you get any warning loghts, messages or codes or does it just drop dead?

Ianv
 TDV6  
Post #4326704th Mar 2009 1:48 pm
View user's profile Send private message View poster's gallery Reply with quote
Baggy
 


Member Since: 11 Feb 2006
Location: sydney.....in the land of oz
Posts: 183

Australia 2011 Discovery 4 TDV6 SE Auto Stornoway GreyDiscovery 4

Hi Ianv,
Just cuts out as if the engine was switched off. No alarms or warning messages. Funnily enough, it doesn't happen at idle but whilst driving (luckily only around town at reasonably low speeds).
 '11 TDV6 - Stornoway Grey.... still lovin' it!!

REDUCE GREENHOUSE GASSES.......Eat more BEEF!!
Addendum: Red wine goes REALLY well with BEEF 
 
Post #4326814th Mar 2009 1:57 pm
View user's profile Send private message View poster's gallery Reply with quote
wirrah
 


Member Since: 27 Feb 2009
Location: Maitland
Posts: 5

Australia 2009 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

I apologise that this is my first post and haven't got around to introducing myself, but here is a possibility. An acquaintance of mine had exactly the same issue in a D1. It was finally sorted out by a third party 4wd shop as the local Land Rover dealer couldn't make heads or tails of it. What was happening was that the engine immobiliser was playing up. It was activating and shutting the motor off!

Worth consideration anyway.

cheers

Greg

PS MY01/09 TDV6 D3 just delivered
  
Post #4330094th Mar 2009 10:27 pm
View user's profile Send private message View poster's gallery Reply with quote
marcon
 


Member Since: 01 Mar 2006
Location: wex's Shed
Posts: 457

Ireland 2006 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

My 07 D3 was(is) doing this,started with alternator light flashing and progressed to HDC fault.Dealer has changed camshaft sensor,ECU and god knows what else.Left it in for a week and collected last Sat morning,drove about 15 miles and same thing happened again.They now think it could be related to fuel pump. Rolling Eyes
  
Post #4330244th Mar 2009 10:42 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Neil Pettersen
 


Member Since: 23 Nov 2007
Location: Cutting the grass
Posts: 1176


wirrah wrote:
..Greg..PS MY01/09 TDV6 D3 just delivered


Welcome Greg Thumbs Up
  
Post #4330504th Mar 2009 11:13 pm
View user's profile Send private message View poster's gallery Reply with quote
marcon
 


Member Since: 01 Mar 2006
Location: wex's Shed
Posts: 457

Ireland 2006 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Yeah welcome Greg. Thumbs Up

Just noticed this thread is in Australia and New Zealand section. Embarassed still..... we have the same problems in Ireland with our D3s
  
Post #4330534th Mar 2009 11:18 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
ianv
 


Member Since: 20 Dec 2007
Location: Bungendore, New South Wales
Posts: 338

Australia 2015 Discovery 4 3.0 TDV6 Base 7 Seat Auto Fuji WhiteDiscovery 4

Just remembered through the day I had a fuel injected bike that did this, it took the dealer 2 top end rebuilds, they thought it was leaky valves, and an ECU change, 6 months and 14,000km to solve it for that engine.

It was a poristy in one of the bores that let a small amount of fresh air get in, it confused the oxy sensor in the exhaust so the ECU turned of the motor at odd times, eg gear changes, accelerating from a stand still etc

They traded back the bike for me.
 TDV6  
Post #4332125th Mar 2009 10:26 am
View user's profile Send private message View poster's gallery Reply with quote
wirrah
 


Member Since: 27 Feb 2009
Location: Maitland
Posts: 5

Australia 2009 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

Thanks for the welcome people!

Baggy I hope you find out what the problem is soon.

cheers

Greg
  
Post #4332415th Mar 2009 11:42 am
View user's profile Send private message View poster's gallery Reply with quote
Baggy
 


Member Since: 11 Feb 2006
Location: sydney.....in the land of oz
Posts: 183

Australia 2011 Discovery 4 TDV6 SE Auto Stornoway GreyDiscovery 4

THanks guys - appreciate the advice....the D3 is booked in to the dealer so hopefully they will sort it out. Can't say I've had too many problems really, all fairly minor and it will be 3-yrs in July!! Very Happy

Will post the outcome when they find it. CHeers all....


PS> welcome to the group Greg!
 '11 TDV6 - Stornoway Grey.... still lovin' it!!

REDUCE GREENHOUSE GASSES.......Eat more BEEF!!
Addendum: Red wine goes REALLY well with BEEF 
 
Post #4355399th Mar 2009 12:40 pm
View user's profile Send private message View poster's gallery Reply with quote
Hercules
 


Member Since: 11 Oct 2017
Location: Sydney
Posts: 1

Australia 2006 Discovery 3 4.4 V8 HSE Auto Zambezi SilverDiscovery 3

Hi Baggy,

Old post i know but i recently purchased a used 2006 V8, and similar thing happening. Did they ever find out what the issue was?
  
Post #186723311th Oct 2017 3:16 am
View user's profile Send private message View poster's gallery Reply with quote
Sea Raider
 


Member Since: 01 Nov 2016
Location: Argyll
Posts: 2027

Scotland 2006 Discovery 3 TDV6 SE Auto Cairns BlueDiscovery 3

Think he may have moved on, his last post on here was in 2013
You may wait some time for a reply, hopefully not.
  
Post #186727911th Oct 2017 9:31 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2019 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site