Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D3)

Fault finding - D3 electrical faults and suspension down
Post Reply  Down to end
Page 1 of 1
MatcherMike
 


Member Since: 15 Sep 2012
Location: Gloucestershire
Posts: 42

2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3
Fault finding - D3 electrical faults and suspension down

Hi all.

I think I've bitten off more than I can chew Sad

Just picked up my first d3 which has dropped suspension, lights on dash and numerous errors on display. Just received my iid tool and would appreciate some pointers on what to check and where to go please.

Car: 2005 discovery s 2.7 manual

Lights:
Click image to enlarge


Messages:
Suspension fault max speed 30mph
Park brake fault. To hold vehicle remove key then apply park brake
HDR fault system not available
System fault special programs not available
Special programs off

Symptoms:
Errors and beeps as above
Car sat on bump stops
If I rev the engine, It brings up "engine system fault" and stalls. It idles nicely

What I have tried:
Fully charged battery (appears new)
Multimeter tests. Battery is 12.6v and when idling it reads 15.1v

I have bought a brake pedal switch, new bulbs and will do these at some point.

Following a clear of faults I get the following:

Body Control
B1B02-28 (2F) Low frequency coil - General signal failure - signal bias level is out of range/zero adjustment failure
( at 9940 km )
B1C57-14 (2F) Passive start ignition relay coil circuit - General electrical failure - circuit short to ground or open
( at 9940 km )

Engine TDV6
P0578-00 (2F) Speed control multi-function input A circuit is stuck
P0404-00 (2F) Exhaust gas recirculation control - circuit range/performance
P140D-00 (2F) Exhaust gas recirculation control circuit B range/performance
P2288-00 (2E) Injector control pressure too high

Parking Brake
U0122-87 (EB) Lost communication with vehicle dynamics control module - Bus signal/message failure - missing a message
( at 149122 km )

Suspension
C1A08-1C (AF) Pressure sensor supply - General electrical failure - circuit voltage out of range
( at 149122 km )
C1A37-01 (AF) Front cross-link valve - General failure information - general electrical failure
( at 149122 km )
C1A03-1C (AF) Front left height sensor - General electrical failure - circuit voltage out of range
( at 149122 km )
C1A04-1C (AF) Front right height sensor - General electrical failure - circuit voltage out of range
( at 149122 km )

Transfer Case
U0132-86 (2F) Lost communication with ride level control module - Bus signal/message failure - signal is invalid
( at 149122 km )
U0122-87 (2F) Lost communication with vehicle dynamics control module - Bus signal/message failure - missing a message
( at 149122 km )

Ventilation
B1B74-00 (2F) Front foot-defrost mode stepper actuator
( at 149122 km )
B1B75-00 (2F) Front foot-face mode stepper actuator
( at 149122 km )
B1B76-00 (2F) Front left air blend stepper actuator
( at 149122 km )
B1B77-00 (2F) Front right air blend stepper actuator
( at 149122 km )
B1B78-84 (2F) System pressure - Bus signal/message failure - signal is below allowable range
( at 149122 km )

Quite a few messages and I don't know where to start, or even if I should bother!

Appreciate advice. Will spend rest of day researching on here.
Thanks
Mike
  
Post #200367525th Nov 2018 5:04 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 4285

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

I wouldn't worry too much. You may only have 2 or 3 faults

focus on these. Can prob ignore others


Engine TDV6
P0578-00 (2F) Speed control multi-function input A circuit is stuck (cruise control, steering wheel clock wheel)
P2288-00 (2E) Injector control pressure too high (this needs sorting - maybe reason for stall)


Suspension
C1A08-1C (AF) Pressure sensor supply - General electrical failure - circuit voltage out of range
( at 149122 km )
C1A37-01 (AF) Front cross-link valve - General failure information - general electrical failure
( at 149122 km )
C1A03-1C (AF) Front left height sensor - General electrical failure - circuit voltage out of range
( at 149122 km )
C1A04-1C (AF) Front right height sensor - General electrical failure - circuit voltage out of range
( at 149122 km )

There is a valve block below the drivers front fog light or access through drivers wheel arch.
SOunds like this connector is off, or the wiring needs tracing

Take the passenger front plastic wheel liner off, and check out the wiring plugs at the bottom.
Follow the height sensor wiring and see if its ok

I think the pressure sensor is near the compressor (under rear left door)
  
Post #200368325th Nov 2018 5:45 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 4285

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

I wonder if the car being on the floor is causing the height sensor faults? Would you be that lucky!!

Could try using the IID or key to get the compressor going and maybe raise it a bit
  
Post #200368925th Nov 2018 6:09 pm
View user's profile Send private message View poster's gallery Reply with quote
MatcherMike
 


Member Since: 15 Sep 2012
Location: Gloucestershire
Posts: 42

2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

Thanks Pete.

I haven't heard compressor run. Didn't know I could do this with key or iid. (Should read the info on here!).

I'll pull the liner and look for connector.

Thanks for your input I appreciate it greatly

Mike
  
Post #200369125th Nov 2018 6:12 pm
View user's profile Send private message View poster's gallery Reply with quote
MatcherMike
 


Member Since: 15 Sep 2012
Location: Gloucestershire
Posts: 42

2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

I just quickly popped iid in and read sensor heights:

Front
176 176
Rear
-107 -117

What should this read?

Tried to raise car but nothing happens. Should I hear compressor somewhere?

Thanks
Mike
  
Post #200371425th Nov 2018 7:00 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 4285

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Compressor is under rear left door
Under a plastic cover.

You could try applying power to the thick wires to see if it runs.

There is a
Relay and fuse under bonnet, but the ecu could be holding it off due to faults.
  
Post #200372525th Nov 2018 7:23 pm
View user's profile Send private message View poster's gallery Reply with quote
ontheair79
 


Member Since: 03 Mar 2018
Location: Dublin
Posts: 38

Ireland 2005 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3
same problem here

Did you get this sorted?
U have 3 errors:

steering angle
u0155-87(2F) lost communication with instrument cluster control module- bus signal/message failure
missing a message

transfer case
u0155-87(2F) lost communication with instrument cluster control module- bus signal/message failure
missing a message

transmision
u0155-87(2F) lost communication with instrument cluster control module- bus signal/message failure
missing a message

checked fuses, clean plugs in integrated transfer case behind battery, car want start, the dash, sat nav and radio shutdown...
  
Post #20158236th Jan 2019 5:43 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 4285

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

start your own thread. You will get more help.
I doubt its those fault codes, so provide more info on what is happening and how it started
  
Post #20158296th Jan 2019 6:11 pm
View user's profile Send private message View poster's gallery Reply with quote
ontheair79
 


Member Since: 03 Mar 2018
Location: Dublin
Posts: 38

Ireland 2005 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

thank you for quick respond. I will try write down my issue.
  
Post #20158406th Jan 2019 6:48 pm
View user's profile Send private message View poster's gallery Reply with quote
bigbill110
 


Member Since: 18 Jun 2016
Location: liverpool
Posts: 163

England 2005 Discovery 3 TDV6 SE Manual Siberian SilverDiscovery 3
Fault codes

Hi pal they are generic codes stored in the ecu
  
Post #20158716th Jan 2019 7:54 pm
View user's profile Send private message View poster's gallery Reply with quote
MatcherMike
 


Member Since: 15 Sep 2012
Location: Gloucestershire
Posts: 42

2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

Haven't updated in a while but finally got this sorted today. Very Happy

The root cause was ecu putting out 12v to sensors. New ecu resolved this.

Then compressor was failing to vent. I ordered new valve but the metal collet on intake and exhaust pipes had disintegrated. The mount plate was also shot. I bought an amk complete with mount and all pipes and a valve block for £100. It's dated 2017 and mint condition so should be a good runner.

Mounted today and was an easy fit thanks to guide on here. Just had to cut and join 1 exhaust pipe as I think this must of been off a newer disco as pipes connevt different to the kits.

All fitted and I had the same problem as before I removed old compressor. Unable to calibrate as front won't rise and rear only rises halfway. Suspension fault on dash. Compressor doesn't run on start-up.

Played with iid and came across the solution.... reenable eas option!!! Doh. Suspension jumped into life. Now sits level, drops, extends, all good.

Compressor hits 1780kpa and gets to about 80c. No faults logged except epb as I have done all brakes and need to replace fuse and bed in.

Feel like I'm finally winning and understand the car much better now.

Many thanks to all for help on my threads.

Mike
  
Post #202031719th Jan 2019 10:24 pm
View user's profile Send private message View poster's gallery Reply with quote
XDAndy
 


Member Since: 16 Jan 2018
Location: Shropshire
Posts: 510

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Zermatt SilverDiscovery 3

Quick question?

Was old compressor an AMK?

If it was a hitachi then you need to change the software; something to do with run times and overheating.

The IIDtool can do this for you, but would be worth making sure if you haven’t already
  
Post #202036120th Jan 2019 12:26 am
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 4285

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Thumbs Up

Yeah if you get a red suspension light and have been trying to calibrate, you need to re-enable it.
  
Post #202044920th Jan 2019 12:38 pm
View user's profile Send private message View poster's gallery Reply with quote
MatcherMike
 


Member Since: 15 Sep 2012
Location: Gloucestershire
Posts: 42

2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

Hi All,

Just a quick(ish) update. Finally got my D3 on the road this week. Passed it's MOT on Thursday with no advisories. First MOT in 5 years! Very Happy

Been driving it for 3 days and i'm in love! so much smoother than my d2.

Overall i have had to sort:

Brake disks, calipers and pads - new all round due to serious corrosion
Suspension on bumps - Faults fixed with replacement ECU and upgrade to AMK compressor
Stalling - Caused by incorrectly connected fuel filter
ESF - Caused by stuck actuator
EPB fault - Caused by faulty handbrake switch
Amber parking light - Fixed with XYZ recalibration

Massive thanks to all of you, and this forum. I couldn't of done it without the extensive knowledge on here, and the generosity and time from everyone who's responded to my questions.

I'm not out of the woods yet. Still got to resolve occasional HDC fault and transmission fault message (neither of which seem to have any symptoms) and non working cruise control. But for now i'm going to enjoy it!

I feel i've learnt alot, i'm keeping an eye out so i can help someone else on this forum.

Thanks again
Mike
  
Post #203763516th Mar 2019 10:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Oswiperus
 


Member Since: 02 Apr 2010
Location: Chelmsford, Essex
Posts: 1136

United Kingdom 2005 Discovery 3 TDV6 SE Auto Java BlackDiscovery 3

I agree, there is so much knowledge on this forum, it's a great place to be. I wouldn't have done half the work I've done on the Disco without this forum and and that includes body removal!
 Stu

D3 & D4 club

D4 2014 XS Commercial - current
D4 2016 hse lux montalcino red - Gone
D3 2005 se java black - current
D3 2005 base manual - gone 
 
Post #203766117th Mar 2019 9:22 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2019 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site