Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Webasto Fuel Burning Heater

FBH Cutting out
Post Reply  Down to end
Page 1 of 2 12>
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3
FBH Cutting out

So rather predictably, after having an FBH controller fitted last week, the FBH is now cutting out after around 2 minutes Very Happy I love these cars!

It's making all the right noises at startup, and I can see smoke/feel warm air from the exhaust - but then it just stops. Same symptoms if I fire it from the Altox or if the car tries to start it up.

I've ordered a diagnostic lead from the site shop, but I really want this up and running by the weekend when we're off to Scotland.

Thinking I'm as well to just bite the bullet and follow Robbie's FBH servicing guide? Or will the diagnostic 'stuff' give me any other pointers?

Oh - error code from the altox is showing as Error Code 02 - heater failed to start (which isn't that helpful!) I'm also not seeing the 'Flame Sensor' value change from 'no' to 'yes' at any point..
  
Post #17748246th Feb 2017 12:39 pm
View user's profile Send private message View poster's gallery Reply with quote
Gazellio @ Prestige Cars
Site Sponsor 


Member Since: 08 Jan 2011
Location: Chilterns- Site Sponsor
Posts: 3217

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Firenze RedDiscovery 4

This is not going to help but having had the Altox Fitted about three weeks ago I still have identical symptoms. Same codes same 2 minutes. However you can use the Altox App to clear any codes and then restart it. On very cold mornings I can run it for two minutes twice and get about 20c which is more than enough to start her first turn. Not perfect but better than not having it.

The long term answer of course is an overhaul...
 
We buy forum member cars - PM to get a quote. http://www.garyelliott.co.uk 
 
Post #17748396th Feb 2017 1:26 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3

Annoying thing is it's only just started doing it.. I think short term I'm going to try the brake cleaner/easy start thing to see if that helps at all.

I can pretty much guarantee that if I try and take the FBH out this close to needing the car for a long distance trip the engine will fall out.. Rolling with laughter
  
Post #17749046th Feb 2017 4:20 pm
View user's profile Send private message View poster's gallery Reply with quote
nrich
 


Member Since: 04 Jan 2015
Location: Huddersfield
Posts: 132

United Kingdom 2007 Discovery 3 TDV6 XS Auto Stornoway GreyDiscovery 3

I had same problem cleared codes fired it up with software whilst blowing air in to the intake with airline not too much pressure after a lot of trying got it to run up to temp after five mins leaned it off a bit with software been fine ever since saves stripping it down to clean if this does not work i suggest Robbies guide to strip and clean good luck.
  
Post #17750336th Feb 2017 8:11 pm
View user's profile Send private message View poster's gallery Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3

I don't have a compressor/airline.. but was thinking about using an airbed pump that I've got in the car Whistle
  
Post #17750876th Feb 2017 9:23 pm
View user's profile Send private message View poster's gallery Reply with quote
Bodsy
Site Sponsor 


Member Since: 06 Nov 2006
Location: In the Clubhouse
Posts: 20791

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

That would do it. Thumbs Up
 Bodsys Brake Bible

D4/D3 Remote FBH heat kits
BAS Remaps/ EGR Blank
Transmission Flush
Software updates/enabling


Clock/ SNOTM /3Flash / 4x4Info /BT Update /Service Reset/Error Codes / Gearbox Reset
See It Here 
 
Post #17750936th Feb 2017 9:33 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3

No luck with that either Sad It's doing less now than it was before Very Happy (no whooshy noises). I also can't clear down the fault codes with the Altox so have pulled the fuse and will try again later when I am less inclined to set fire to the car!

FBH cable should hopefully be with me tomorrow so will maybe get some more clues after that.
  
Post #17752537th Feb 2017 12:26 pm
View user's profile Send private message View poster's gallery Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3

Pulled fuse and managed to get it to at least try and start, but even blowing air into the intake and 'some' brake cleaner I'm still not getting it to start. Brake cleaner does make it pop a bit and I thought it had fired up but after about 30 secs the fan comes on which I assume is it's shut down sequence? (Possibly because the Altox has not been able to get a signal back that it's started?)

The last few texts from the Altox have said "heater does not start" but now I'm not getting any error codes Confused
  
Post #17755427th Feb 2017 9:09 pm
View user's profile Send private message View poster's gallery Reply with quote
nrich
 


Member Since: 04 Jan 2015
Location: Huddersfield
Posts: 132

United Kingdom 2007 Discovery 3 TDV6 XS Auto Stornoway GreyDiscovery 3

Do you have the Webasto software it took loads of goes for me using the software to get it running and lots of air in to intake.
  
Post #17755447th Feb 2017 9:12 pm
View user's profile Send private message View poster's gallery Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3

I've got the software, but no lead yet - should be arriving today.
  
Post #17756818th Feb 2017 8:23 am
View user's profile Send private message View poster's gallery Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3



It's alive!

Used the Webasto software to clear the faults and then fire up the heater.

I can now fire it up using the Altox app as well.
  
Post #17758928th Feb 2017 5:26 pm
View user's profile Send private message View poster's gallery Reply with quote
Bodsy
Site Sponsor 


Member Since: 06 Nov 2006
Location: In the Clubhouse
Posts: 20791

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

Thumbs Up Thumbs Up
 Bodsys Brake Bible

D4/D3 Remote FBH heat kits
BAS Remaps/ EGR Blank
Transmission Flush
Software updates/enabling


Clock/ SNOTM /3Flash / 4x4Info /BT Update /Service Reset/Error Codes / Gearbox Reset
See It Here 
 
Post #17759828th Feb 2017 8:29 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
jdhx
 


Member Since: 16 May 2009
Location: Dorset/Devon border
Posts: 289

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Auto Aintree GreenDiscovery 4

So to use the Altox unit you have to use the webasto test rig/software to clear faults first? Sounds quite useless!
 Discovery HSE MY16 (fantastic apart from the heating)
Audi TT Roadster (wow)
MGB Roadster (owned since 1992)
Discovery 3 TDV6 HSE MY08
Saab 9-5 Aero 2002 (gone but not forgotten) 


Last edited by jdhx on 11th Feb 2017 12:07 am. Edited 2 times in total 
Post #17763859th Feb 2017 5:26 pm
View user's profile Send private message View poster's gallery Reply with quote
badgerade
 


Member Since: 31 Jul 2010
Location: Berkshire
Posts: 270

United Kingdom 2006 Discovery 3 TDV6 GS Manual Zambezi SilverDiscovery 3

Hmm not sure that's overly fair!

Reading some other posts I think I'd fully locked the FBH out - probably voltage related failed starts as I saw some voltages in the 11.x areas. (I had been able to clear the errors on the FBH using the Altox app up to a point, then they stopped clearing)

Although this in itself won't cause the lockouts, Robbie mentions somewhere that if the FBH is struggling to start, a lower voltage will mean lower fan speeds and less chance of ignition.

Once I'm back off hols I'm going to give the FBH a service which will hopefully improve things, but for now the Altox is starting the FBH every time.
  
Post #177663510th Feb 2017 8:14 am
View user's profile Send private message View poster's gallery Reply with quote
geoff.
Site Sponsor 


Member Since: 24 Jan 2010
Location: West kent
Posts: 8429

England 

i can supply the service kit for the fbh @ 185 inc posted uk only

part numbers LR010329,LR004235,LR004141

If anybody is interested pls pm me Thumbs Up
 

IID PRO M/V LICENCE DIAGNOSTICS EQUIPMENT & D3,D4,RRS FORTRON TRANSMISSION FLUSHING & POWER STEERING FLUSHING
GENERAL SERVICING
B.A.S Authorised Dealer Remaps & egr blank and software patches 
 
Post #177678310th Feb 2017 1:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site