Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Webasto Fuel Burning Heater

FBH Loom
Post Reply  Down to end
Page 1 of 1
Jubbly
 


Member Since: 20 Nov 2016
Location: Stourbridge
Posts: 143

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Stornoway GreyDiscovery 4
FBH Loom


I've got the loom from the shop and connected it up to my fbh, no faults at all, though I couldn't do anything with a fbh other than run the fuel pump, control the glow plug and run the fan.

It wouldn't let me run the heater in either mode.

am i doing something wrong?
  
Post #186100023rd Sep 2017 9:32 pm
View user's profile Send private message View poster's gallery Reply with quote
Jubbly
 


Member Since: 20 Nov 2016
Location: Stourbridge
Posts: 143

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Stornoway GreyDiscovery 4

All I can do with the webasto software to do is connect to the heater and test the different components.

I can pres the park heat, or supplementary heating buttons or the EOL ones and nothing happenes, should it???

I have no fault codes in the heater, We stripped it down and the heater is immaculate no carbon build up or anything, it is black inside though. The fuel pumps the glow plug works, the fan works.

Just the heater doesn't run.

any ideas anyone?
  
Post #186128724th Sep 2017 6:20 pm
View user's profile Send private message View poster's gallery Reply with quote
okennedy
 


Member Since: 03 Dec 2008
Location: Roscommon
Posts: 138

Ireland 2015 Discovery 4 3.0 SDV6 Commercial Auto Causeway GreyDiscovery 4

If the temperature outside is too warm, over 15 degress C, the heater will not heat up if you understand me. The outside temperature needs to be below a certain temperature before the fbh will start and go through the sequence correctly. If the temp outside is warm enough the system will blow cool air in to cool the vehicle. As you said the the fuel pumps, the glow plug is working and the fan works so perhaps you just need the outside temp to get colder to see if it does the job Thumbs Up
 MY15 D4 Causeway Grey
MY12 D4 Orkney Grey - Gone
MY07 D3 Java Black - Gone 
 
Post #186134524th Sep 2017 8:21 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Jubbly
 


Member Since: 20 Nov 2016
Location: Stourbridge
Posts: 143

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Stornoway GreyDiscovery 4

It's fired up this morning, smoke everywhere. Two holes in my fbh exhaust though lol.
  
Post #186182126th Sep 2017 6:44 am
View user's profile Send private message View poster's gallery Reply with quote
riverblanche
 


Member Since: 31 Aug 2010
Location: retford'ish
Posts: 983

England 

Hi Jubly,
From memory you should be able to tell the fbh to run if you can tell it to test the other items,
The software overrides the car so no need for the temp to be low
If you have run the fuel pump !! Lots of fuel now about so LOTs of smoke, may be leave that test if you now know it works.
There are many joints in the exhaust that "breath"! So maybe not holes.
Keep playing with it
👍
 .
Life advice. Always pick up the stick in the Middle !!

Club DG Mclaren jacket and it fits better now
.
2016 RRS2 its a ! 
 
Post #186183026th Sep 2017 6:57 am
View user's profile Send private message View poster's gallery Reply with quote
Jubbly
 


Member Since: 20 Nov 2016
Location: Stourbridge
Posts: 143

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Stornoway GreyDiscovery 4

the holes are on the fbh silencer, at both ends, though the FBH fired up again today and I saw no smoke at all from it.
  
Post #186305729th Sep 2017 11:55 am
View user's profile Send private message View poster's gallery Reply with quote
Martin
Site Admin and Owner 


Member Since: 06 Nov 2004
Location: Hook Norton
Posts: 16864

Wales 2006 Discovery 3 TDV6 SE Manual Buckingham BlueDiscovery 3

Hi Jubbly please see this thread for possible solution for running your D4's FBH.

https://www.disco3.co.uk/forum/topic155750.html
 06 D3 SE / 15 LR D90 XS SW / 88 LR 90 Td5 / 68 BMW 2000 ti
Any issues with the site let me know! 
 
Post #186765111th Oct 2017 11:14 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Jubbly
 


Member Since: 20 Nov 2016
Location: Stourbridge
Posts: 143

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Stornoway GreyDiscovery 4

Thanks Martin, I was following that thread also, I will check it's operation and report back, though happy to say my FBH is working perfectly now anyway Smile Thumbs Up
  
Post #186799213th Oct 2017 7:34 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site