Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Maintenance & Mods (D3)

Front suspension slow to raise then normal hight only
Post Reply  Down to end
Page 1 of 1
Grips0
 


Member Since: 16 Oct 2017
Location: East Kilbride
Posts: 4

United Kingdom 2005 Discovery 3 TDV6 XS Auto Adriatic BlueDiscovery 3
Front suspension slow to raise then normal hight only

Need a bit of help guys, got a 2005 2.7 d3, slow front suspension raise then 5 mins later the dreaded "bing" and normal hight only sign on the dash,, iv had a new amk compressor last year so I no its not that so iv just fitted two front air shocks and an air crossover into the last two days and still the problem won't go away, any help as I am now lost as to what it could be,
Richie
  
Post #187802610th Nov 2017 5:40 pm
View user's profile Send private message View poster's gallery Reply with quote
lynalldiscovery
 


Member Since: 22 Dec 2009
Location: Maidstone
Posts: 3912

United Kingdom 2006 Discovery 3 TDV6 Metropolis LE Auto Bonatti GreyDiscovery 3

Read the other day same problem and guy got his squirty bottle of soapy water and found multiple leaks on the air tank, new tank fixed his issues.
 No Illeism here.  
Post #187803310th Nov 2017 5:56 pm
View user's profile Send private message View poster's gallery Reply with quote
Grips0
 


Member Since: 16 Oct 2017
Location: East Kilbride
Posts: 4

United Kingdom 2005 Discovery 3 TDV6 XS Auto Adriatic BlueDiscovery 3

Even though the back suspension has no issues and raises and lowers?
  
Post #187803710th Nov 2017 5:59 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 1694

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Try changing the seals in the front valve block.
£17 off eBay
  
Post #187805510th Nov 2017 6:34 pm
View user's profile Send private message View poster's gallery Reply with quote
Grips0
 


Member Since: 16 Oct 2017
Location: East Kilbride
Posts: 4

United Kingdom 2005 Discovery 3 TDV6 XS Auto Adriatic BlueDiscovery 3

Hi, I put a new front valve block/air cross over on today, I even cleaned all fuses to give better connection in the hope it was just a bad connection but still it's a pain in the #@-:

Iv used a squeeze bottle but not in the air cylinder only on all the suspension bag and joins parts
  
Post #187806310th Nov 2017 6:44 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site