Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Electrical] Gear selected not showing
Post Reply  Down to end
Page 2 of 5 <12345>
wezzzor
 


Member Since: 25 May 2008
Location: limerick
Posts: 86

Ireland 2005 Discovery 3 TDV6 S Manual Zambezi SilverDiscovery 3

while offroading today managed to get this fault, not sure if it was related to offroading or not.gear selecter not displaying, amber break fault light and revs would not settle around the idle speed for a few seconds but only when in gear. did the retrain procedure, worked a treat. fine since. touch wood.
  
Post #3677551st Nov 2008 10:14 pm
View user's profile Send private message View poster's gallery Reply with quote
richh
 


Member Since: 07 Feb 2009
Location: scarborough
Posts: 24

United Kingdom 

hi guys, if this happens all the time even if the 'XY' sensor has been replaced it could be the early stages of the clutch slipping, we had one at our delership a few months ago.
  
Post #4171107th Feb 2009 6:48 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
paulJ1
 


Member Since: 17 Mar 2009
Location: Stewarton, Scotland
Posts: 268

2005 Discovery 3 TDV6 HSE Auto Zermatt SilverDiscovery 3

I'm confused.... help !

I have an auto HSE, what should I see ref gear indication.

In the window that has the mileage odometer in I see PRND etc as I select the relevent location, but I dont see 6,5,4,3,2,1 to the left of this when i auto, should I be ?

If I push the gear lever to the left the word "sport" appears, General question, is what is the sport mode ?

Then if i push the gear stick and get the command shift mode, I then get the 6,5,4,3,2,1 as i select, This is what i expect to see.

What to know if I have a problem as it in to dealer on saturday AM.

Ta very much !

Paul
 Got our Disco... Love it.....  
Post #4481851st Apr 2009 9:18 pm
View user's profile Send private message View poster's gallery Reply with quote
10forcash
 


Member Since: 09 Jun 2005
Location: Ubique
Posts: 16534

United Kingdom 2007 Discovery 3 TDV6 HSE Manual Zermatt SilverDiscovery 3

don't worry, everything's normal for an auto, 'sport' mode basically holds on to each gear longer and will change down quicker when under load
the thread started off referring to the 4x4 info screen then moved on to failure or loss of calibration of the 'X-Y' sensor on manual transmission variants of the disco3
  
Post #4481881st Apr 2009 9:23 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
paulJ1
 


Member Since: 17 Mar 2009
Location: Stewarton, Scotland
Posts: 268

2005 Discovery 3 TDV6 HSE Auto Zermatt SilverDiscovery 3

Thanks 10forcash was getting confused !!!

Look forward to using your services in due course.
 Got our Disco... Love it.....  
Post #4481991st Apr 2009 9:46 pm
View user's profile Send private message View poster's gallery Reply with quote
10forcash
 


Member Since: 09 Jun 2005
Location: Ubique
Posts: 16534

United Kingdom 2007 Discovery 3 TDV6 HSE Manual Zermatt SilverDiscovery 3

Thumbs Up you know it makes sense! Laughing
  
Post #4482101st Apr 2009 9:58 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
drjonathanneville
 


Member Since: 19 Aug 2009
Location: Sussex
Posts: 12

United Kingdom 2005 Discovery 3 TDV6 S Manual Zambezi SilverDiscovery 3

I'm going to give this fix a go later. My non-main-dealer garage gets no faults up on their computer, so a bit of a waste of cash.
  
Post #50933519th Aug 2009 4:38 pm
View user's profile Send private message View poster's gallery Reply with quote
DigitalJunior
 


Member Since: 22 Nov 2008
Location: Cumbria
Posts: 4231

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Zermatt SilverDiscovery 3

I really wish I had read this thread before now! My manual had same symptons on Monday - taken in to dealer whilst we are on holiday - they still have it. Needs new X-Y switch £155, clutch £230 and flywheel £££ plus labour looking at £1k.

Makes me wonder if a re-calib would have sorted. Right now the D3 is in the dog house.
  
Post #50949419th Aug 2009 10:34 pm
View user's profile Send private message View poster's gallery Reply with quote
drjonathanneville
 


Member Since: 19 Aug 2009
Location: Sussex
Posts: 12

United Kingdom 2005 Discovery 3 TDV6 S Manual Zambezi SilverDiscovery 3

All working properly, very pleased with the fix and avoiding main dealer labour rates to sort this out, thanks to those who posted the fix.
  
Post #50959120th Aug 2009 9:25 am
View user's profile Send private message View poster's gallery Reply with quote
bottg
 


Member Since: 26 Aug 2009
Location: Cotswolds
Posts: 1

United Kingdom 2007 Discovery 3 TDV6 GS Manual Stornoway GreyDiscovery 3

My XY switch has failed 6 times over the last 18 months (from about 6 months old) and eventually it has been diagnosed as a faulty clutch/flywheel. The dealers say it is a mechanical fault and covered by the warranty, but the LR warranty people disagree.

I have just been told that the warranty only covers the clutch up to 15,000 miles or 12 months, whichever is sooner! Other dealerships (three in total now) have told me that they see quite a few failures on the D3 Manual, because the clutch is not up to the job. So now i have a £1K repair bill. Customer Care (they get very confused if you call them customer service!) seem fairly didinterested and said that a clutch is a wear and tear item and warranties don't generally apply.

I have to say this has probably put me off buying another land rover in the future. My 1969 IIA Lightweight is still on its original clutch!
  
Post #51179426th Aug 2009 2:41 pm
View user's profile Send private message View poster's gallery Reply with quote
Wex
 


Member Since: 16 Apr 2007
Location: Knackeragua
Posts: 5173

Ireland 2006 Discovery 3 TDV6 S Manual Bonatti GreyDiscovery 3

Horseshyte , clutch on my manual failed a couple of K over warranty , they tried to wriggle out of it ( didn't give much of fight TBH) , after one phonecall they replaced the clutch & flywheel.

Stand your ground on this one.

Edit: forgot to add the XY was replaced a couple of times and retraining the sensor became second nature to m by the time the actual fault was recognised.
  
Post #51180626th Aug 2009 3:25 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
wiggs
 


Member Since: 03 Sep 2006
Location: Manchester
Posts: 14295

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

My clutch and flywheel was replaced at about 19000 miles ..so there talking tosh Evil or Very Mad
 G4 Gone ...but not forgotten  
Post #51184626th Aug 2009 6:07 pm
View user's profile Send private message View poster's gallery Reply with quote
andy lamb
 


Member Since: 16 Jan 2010
Location: Durham
Posts: 7

United Kingdom 
amber parking fault & gear selection now fixed

i had to undertake the reset procedure (R 1,2,3,4,5&6) due to trying to put away quickly in 2nd gear. Embarassed (think i must have made clutch slip hence fault on LCD display. the reset worked a treat. thanks for the help and support people. Very Happy ps dont usually set of quickly in second gear, just knackered after long day at work. Rolling Eyes
  
Post #60189312th Feb 2010 12:20 am
View user's profile Send private message View poster's gallery Reply with quote
ringoosmeg
 


Member Since: 16 Aug 2008
Location: Shropshire
Posts: 51

United Kingdom 2006 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

My D3 has just suffered with the no gears, brake light on, no reversing lights etc.....

Thanks to this site now cured.....D3.co.uk just gets beter and better in my book!, several resets repairs etc, on here has save me hundreds at the dealers.

Top job lads, I hold a glass up to you all.

best regards

Ringo
 Discovery 3 "Black Bear II"
Defender 90 "Joe" Having a 200tdi conversion at the moment
Series One "Grommet" Now re-homed......

Whats yours called? 
 
Post #62252917th Mar 2010 8:22 pm
View user's profile Send private message View poster's gallery Reply with quote
Discoed
 


Member Since: 16 Jun 2010
Location: Yorkshire
Posts: 951

United Kingdom 2005 Discovery 3 TDV6 S Manual Bonatti GreyDiscovery 3
Re: Gear selected not showing & Auto relaese on manual d

LRA TECH wrote:
The first issue is the calibration of the "x-y" gear position switch situated onto of the gearbox,,it's come out of sequence thats all.Symtoms drving along you change gear and then amber park/brake is on and no gear display.H/Brake does still work, if you cycle ignition everything comes back to normal, set off again when you select third3 gear bang it happens again, not a common fault, as we carry full LR IDS diagnosics we can calibrate on site.This involves driving the car through all the gears inc Reverse,,making sure the clutch pedal is fully depressed after each gear change...Doing it this way you the system resets and clears all faults codes...

The auto handbrake relaese on manual disco3 not 100% when it was standard, but am driving a 08reg now,but it was on my last assist vehicle which was a 56reg...


Just got my 05 D3 and have had this issue. I have followed your instructions and the amber park brake fault light has gone and the gear indicators have returned to instant. Is this issue likely to crop up again? is there a proper fix?
  
Post #66556428th Jun 2010 10:46 am
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 2 of 5 <12345>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2019 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site