Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Electrical] Gear selected not showing
Post Reply  Down to end
Page 5 of 5 <12345
bigtam64
 


Member Since: 19 Nov 2009
Location: Leeds
Posts: 192

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Santorini BlackDiscovery 3

Cheers for the offer Gary
The car is at Morar motors at Kyle and my sister lives on Skye so she is going
To collect the car when ready and take it to my mothers in Glasgow
I have just got to collect it when I can.
Once again cheers

Doug
Thumbs Up Thumbs Up
 Weekends are to short
Egr valves removed 
 
Post #103687817th Jan 2013 7:08 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Tosspot
 


Member Since: 01 Jun 2014
Location: Sutton Coldfield
Posts: 46

United Kingdom 2005 Discovery 3 TDV6 SE Manual Adriatic BlueDiscovery 3

Woohoo !! Just followed the instructions for the xy sensor reset ... My engine idles perfect braking on approach my reverse lights work and my parking sensors come straight on (still long tone need to chase the wires ) but you gotta love this site Very Happy brilliant cheers fellas that's anther one off the list Very Happy
 When I said life couldn't get much worse god it wasn't a challenge with this landrover .....  
Post #129914016th Jun 2014 9:00 pm
View user's profile Send private message View poster's gallery Reply with quote
ponymum
 


Member Since: 16 Nov 2014
Location: northwest
Posts: 11

England 2007 Discovery 3 TDV6 XS Manual Stornoway GreyDiscovery 3

Hi everyone, I bought my car about a month ago and yesterday I experienced the same problems as mentioned here - park brake failure, gear display slow or not displaying and reverse sensors not working. I have to say I panicked! Having checked out this forum and following the advice im pleased to say it fixed it! im so grateful, thank you!😄
  
Post #137460616th Nov 2014 8:15 pm
View user's profile Send private message View poster's gallery Reply with quote
Robbie
 


Member Since: 05 Feb 2006
Location: Waiting for my old avatar to be allowed back... we miss her!
Posts: 17560

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Auto Baltic BlueDiscovery 4

Welcome to the forum!
 Land Rover - Turning Drivers into Mechanics Since 1948

Battery & Quiescent Current Drain Testing

Diagnostics for:
Defender, FL2, D3, D4, Evoque, RRS & FFRR
A not-for-profit enterprise


 
 
Post #137460816th Nov 2014 8:17 pm
View user's profile Send private message View poster's gallery Reply with quote
Tonypearce
 


Member Since: 29 Jan 2015
Location: Bulford
Posts: 9

United Kingdom 2005 Discovery 3 TDV6 SE Manual Buckingham BlueDiscovery 3

Just joined the other day got some of the same dramas will try a reset tomorrow fingers crossed but it's got a warranty still Bow down
  
Post #14186471st Feb 2015 9:50 pm
View user's profile Send private message View poster's gallery Reply with quote
ponymum
 


Member Since: 16 Nov 2014
Location: northwest
Posts: 11

England 2007 Discovery 3 TDV6 XS Manual Stornoway GreyDiscovery 3

Hi I am sure it will work, it certainly worked for me. Welcome to the forum, it's a great forum and there are so many helpful people! Very Happy
  
Post #14187102nd Feb 2015 6:46 am
View user's profile Send private message View poster's gallery Reply with quote
Tonypearce
 


Member Since: 29 Jan 2015
Location: Bulford
Posts: 9

United Kingdom 2005 Discovery 3 TDV6 SE Manual Buckingham BlueDiscovery 3

All done thanks guys top job Bow down
  
Post #14196083rd Feb 2015 3:12 pm
View user's profile Send private message View poster's gallery Reply with quote
J13FFB
 


Member Since: 13 Oct 2014
Location: Sudbury
Posts: 1

United Kingdom 2006 LR3 TDV6 XS Manual Galway GreenLR3

I had this problem after aqua planning on puddles, the drive switched between on and off load as a wheel span freely on the water. Found this post and today followed the instructions and pleased to say the problem has gone away. Thank you to everyone who has contributed.
  
Post #143023520th Feb 2015 9:15 pm
View user's profile Send private message View poster's gallery Reply with quote
JCP
 


Member Since: 06 Oct 2016
Location: Wiltshire
Posts: 14

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Zambezi SilverDiscovery 3
Clutch slipping whilst driving

Hi,

I've read through this and various other threads and I appreciate this is an old thread but it seems the most relevant to my woes. D3 2.7TDv6 Manual. It's done over 100k now.

I've been suffering the XYZ issues for sometime and noted that the reset procedure (picked up on this site some time ago so cheers for that), works, provided I then drive with great care. That is, placing the car under any sort of normal duress whilst accelerating causes the clutch to feel like it's slipping, even though I'm already in gear, have been for some time and, not resting my foot on the pedal. So for example, at say 50mph in four, if I depress the accelerator more than a couple of inches to accelerate to say 60' you can actually feel like the clutch has engaged and is now slipping as if pulling away from a standstill. It's not restricted to 4th gear. Within a couple of minutes, usually when I pull to a stop or slower speed, the amber park brake light will come on.
The other half today drove it and over took a very slow lorry on an uphill (2 lanes) and changed from 3rd to 4th midway. Smoke started coming from under bonnet and the car now reeks of burnt clutch. Having driven it back with the XYZ light on again, it feels decidedly slippy on pull away and, it really reeks.
I've had many cars over the years, never had to have a clutch replaced on any car I've owned before.

Can someone shed any light on to this 'clutch slip whilst driving/accelerating' and advise what role the flywheel plays with this issue, if any.

I fear I have a big bill waiting for me, if I can find an independent who's decent enough to entrust it to near me.
 Discovery 3 2.7TDV6 Man
Defender 90 200Tdi 
 
Post #172379724th Oct 2016 11:38 am
View user's profile Send private message View poster's gallery Reply with quote
jetmech
 


Member Since: 22 Feb 2016
Location: Suffolk
Posts: 152

United Kingdom 2008 Discovery 3 TDV6 SE Manual Stornoway GreyDiscovery 3

It sounds to me as if it's simply a worn out clutch or clutch plate.
 Simon.
2008MY Dicovery 3 TDV6 SE Manual 
 
Post #172384124th Oct 2016 1:12 pm
View user's profile Send private message View poster's gallery Reply with quote
bigtam64
 


Member Since: 19 Nov 2009
Location: Leeds
Posts: 192

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Santorini BlackDiscovery 3

Sounds like your clutch needs replacing find a reliable Indi I would recommend flywheel as well
Other wise could end up doing new clutch twice as initial replacement said they had done flywheel but 18 month later clutch went again and my indi in Leeds reckoned they hadn't done flywheel but had no proof so had to bite the bullet and pay twice
Big Cry Big Cry
 Weekends are to short
Egr valves removed 
 
Post #172386124th Oct 2016 2:25 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
JCP
 


Member Since: 06 Oct 2016
Location: Wiltshire
Posts: 14

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Zambezi SilverDiscovery 3

Thanks for the responses thus far.

Yes, I'm pretty certain the clutch needs replacing. I was wondering if anyone could shed any light on why the clutch feels like it's engaging mid driving without any intervention on my part. I know where I am with my defender, the discovery is an electrical box of wizardry which seems to have a will of its own. Hence, having read this thread and others and seen several references to the flywheel playing various contributing roles to others woes, I was wondering what the deal is as I appreciate that clutch changes may or may not be needed throughout a cars life but so many flywheels too just sounded strange.
 Discovery 3 2.7TDV6 Man
Defender 90 200Tdi 
 
Post #172395024th Oct 2016 5:50 pm
View user's profile Send private message View poster's gallery Reply with quote
JCP
 


Member Since: 06 Oct 2016
Location: Wiltshire
Posts: 14

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Zambezi SilverDiscovery 3

Whilst we are on the subject, can anyone recommend a good LR independent in my area? I'm between Royal Wootton Bassett and Chippenham in Wiltshire. We've not long moved to this part of Wilts so I've not found anything other than main dealers at the mo.
 Discovery 3 2.7TDV6 Man
Defender 90 200Tdi 
 
Post #172399924th Oct 2016 7:59 pm
View user's profile Send private message View poster's gallery Reply with quote
JCP
 


Member Since: 06 Oct 2016
Location: Wiltshire
Posts: 14

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Zambezi SilverDiscovery 3

Just wanted to add that I've replaced the clutch and flywheel (as diagnosed above Thumbs Up )with a kit from AF and all the issues relating to the judder and the XYZ switch have gone. So thanks to all, appreciated.
 Discovery 3 2.7TDV6 Man
Defender 90 200Tdi 
 
Post #175230221st Dec 2016 10:26 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 5 of 5 <12345
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site