Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Hanbrake Failure
Post Reply  Down to end
Page 16 of 18 <123 ... 15 161718>
LR3norway
 


Member Since: 25 Dec 2016
Location: NORWAY
Posts: 193

Norway 

Maybe I was not quite right. Don't think the car missed the ECU, but at least the IID Tool didn't find it, therefore no codes. Not sure honestly.
Somehow I found a "refresh" or identify ECU's. And then it popped up again. With codes of course.

I also drove a long time without the fuse, kept the alarm away Whistle
  
Post #204024925th Mar 2019 10:44 pm
View user's profile Send private message View poster's gallery Reply with quote
graymattor
 


Member Since: 26 Nov 2018
Location: Retford
Posts: 4

United Kingdom 2005 Discovery 3 TDV6 SE Auto Adriatic BlueDiscovery 3

Right I've borrowed a GAP IID Tool, and it found faults with the EPB, the code was C1A47-01(FB) Force Sensor Electrical fault! I've done a bit of googling and it's come up with next to nothing, does anyone know what could cause this? Can it be a broken wire or is it the force sensor that's failed? Can it be replaced or is it a full new unit?

Any help would be grreat

http://imgur.com/a/t78KNoi
  
Post #204168430th Mar 2019 5:57 pm
View user's profile Send private message View poster's gallery Reply with quote
LR3norway
 


Member Since: 25 Dec 2016
Location: NORWAY
Posts: 193

Norway 

https://www.disco3.co.uk/forum/epb-help-172832.html
  
Post #204168630th Mar 2019 6:14 pm
View user's profile Send private message View poster's gallery Reply with quote
macko
 


Member Since: 09 Apr 2018
Location: essex
Posts: 11

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Baltic BlueDiscovery 3
handbrake failure

just need to know if i pull the release cable am i going to have to pull a fuse to stop hand brake applying when i take key out? mine wont release, its a manual. cheers.
  
Post #204558213th Apr 2019 11:57 am
View user's profile Send private message View poster's gallery Reply with quote
ianm27
 


Member Since: 02 Jun 2016
Location: Hertfordshire
Posts: 2154

England 2012 Discovery 4 3.0 SDV6 GS Auto Orkney GreyDiscovery 4

Someone with more knowledge will be along shortly but I would say yes, you would need to pull the fuse to stop the EPB trying to re-engage.
 Uncle Ray's spare wheel protector
Limo Tint
Blackvue front & rear dashcam
Cruise control switch pack
Bodsy's remote for FBH 
 
Post #204560513th Apr 2019 1:26 pm
View user's profile Send private message View poster's gallery Reply with quote
macko
 


Member Since: 09 Apr 2018
Location: essex
Posts: 11

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Baltic BlueDiscovery 3

meant to say its a disco 3......not sure if its the same as the disco 4?? pardon my ignorance!!
  
Post #204567013th Apr 2019 5:07 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 12827

United Kingdom 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

i WAS going to say the fault is the D missing in the title of this thread BUT i've noticed the thread is coming up to 10 years old, so i can't blame you Macko !
  
Post #204567213th Apr 2019 5:14 pm
View user's profile Send private message View poster's gallery Reply with quote
MatcherMike
 


Member Since: 15 Sep 2012
Location: Gloucestershire
Posts: 94

2005 Discovery 3 TDV6 S Manual Java BlackDiscovery 3

Hi all,

Sorry, cant find the info on here.

What's the best way to get the epb module off the vehicle so I can work on it please? I had to pop the emergency release so needs setting up and repairing.

8 torx screws are corroded so too difficult to do in situ.

Thanks
Mike
  
Post #207879827th Aug 2019 7:08 pm
View user's profile Send private message View poster's gallery Reply with quote
gearmuncher
 


Member Since: 30 Oct 2018
Location: Woodley
Posts: 143

United Kingdom 2006 Discovery 3 TDV6 SE Manual Buckingham BlueDiscovery 3

there is a youtube video.
  
Post #207883427th Aug 2019 9:04 pm
View user's profile Send private message View poster's gallery Reply with quote
LandyIRL
 


Member Since: 24 Mar 2016
Location: Galway
Posts: 123

Ireland 2006 Discovery 3 TDV6 Commercial Auto Bonatti GreyDiscovery 3
Handbrake module cycling in and out after replacement

I replaced a HB module (rebuilt one) on a manual D3 (on coil springs) and adjusted it up after. The handbrake would not go into bedding in mode for the brake shoes and there is the red light and the amber brake shoes light on and the usual error. The HB when i try it (as if for bedding in) is activating if i hold it and stopping the vehicle but not staying on when stationary. It cycles in and out several times before stopping. I had cleared the faults and still lights flashing. There were other lights like the steering angle sensor etc and i reset the xyz switch and cleared them though now i am seeing a clutch sensor fault on the fault reader in the EPB module which doesn't clear. I replaced the EPB switch with a new one and saw someone had been at the wires on this before and doing some repair work.
Any ideas as to why the EPB is repeatedly cycling in and out and not engaging to hold ?
  
Post #211539024th Jan 2020 7:17 pm
View user's profile Send private message View poster's gallery Reply with quote
gearmuncher
 


Member Since: 30 Oct 2018
Location: Woodley
Posts: 143

United Kingdom 2006 Discovery 3 TDV6 SE Manual Buckingham BlueDiscovery 3

the EPB module has a torque sensor, different torque for different situations, sounds like this is not working, are the brakes actually coming on ?.
I think a IID or nanocom will show the torque value.
  
Post #211586426th Jan 2020 5:42 pm
View user's profile Send private message View poster's gallery Reply with quote
blakemore333
 


Member Since: 17 Jan 2020
Location: Shrewsbury
Posts: 11

United Kingdom 2010 Discovery 4 3.0 TDV6 GS Auto Barolo BlackDiscovery 4

Just joined the EPB fault club Sad

Mine has come up with the yellow warning light on the dash, but it still works manually and isn't making any weird noises.

Really dont want to go to a garage and be charged £££!

Anybody in Shropshire know how to fix this? Very Happy
 D4 Barolo Black  
Post #211735731st Jan 2020 3:05 pm
View user's profile Send private message View poster's gallery Reply with quote
PROFSR G
 


Member Since: 06 Mar 2017
Location: Lost
Posts: 4851

Ukraine 2009 Discovery 3 TDV6 Commercial XS Auto Stornoway GreyDiscovery 3

Sounds like the XY sensor might need recalibrating. Have you noticed the gear position indicator on the dash change? Or the reverse lights not working?
 yµ (idµ - eAµ) ψ=mψ

 
 
Post #211736431st Jan 2020 3:38 pm
View user's profile Send private message View poster's gallery Reply with quote
blakemore333
 


Member Since: 17 Jan 2020
Location: Shrewsbury
Posts: 11

United Kingdom 2010 Discovery 4 3.0 TDV6 GS Auto Barolo BlackDiscovery 4

well it did change to jut display E. but now its sorted its self out and the gear numbers display.

However dont know if the reverse light comes on.

I have tried the calibration where you start in reverse, go through all the gears till they display on the dash, turned the ignition off. but that hasn't done anything
 D4 Barolo Black  
Post #211736531st Jan 2020 3:42 pm
View user's profile Send private message View poster's gallery Reply with quote
PROFSR G
 


Member Since: 06 Mar 2017
Location: Lost
Posts: 4851

Ukraine 2009 Discovery 3 TDV6 Commercial XS Auto Stornoway GreyDiscovery 3

Are the digits displayed in full size? Sometimes you might have to do the recalibration more than once if using the manual method as its easy to make a mistake. Beyond that you will need diagnostics read so you should consider a GAP IID or similar if you're going to be running a D3 long term!
 yµ (idµ - eAµ) ψ=mψ

 
 
Post #211736731st Jan 2020 3:50 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 16 of 18 <123 ... 15 161718>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site