Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Maintenance & Mods (D4)

Help! Locking problems after removing door cards
Post Reply  Down to end
Page 1 of 1
Knockinroe
 


Member Since: 23 Mar 2014
Location: Kenilworth
Posts: 59

England 2012 Discovery 4 3.0 SDV6 HSE Auto Nara BronzeDiscovery 4
Help! Locking problems after removing door cards

Hi there.
Arrrhhhh!
After my wife made a significant unauthorised bodywork modification to the rear quarter panel... Rolling Eyes A local and very helpful body guy ( a friend) has done a great repair. However.... now we can’t get the car to lock. Embarassed
He had the door cards off in order to strip the door handles and this seems to have made a problem somewhere.

So let’s try and give as much detail as possible...

Electronic Lock button on drivers door :
You hear car lock, but all doors immediately unlock.

Locking car with fob:
Locks all doors except drivers door. You see the drivers door physical lock button ‘twitch’ but doesn’t go the full way to lock.

Engaging deadlock with fob:
Very shortly the alarm activates.

IID tool: no reported faults

Rear right door: replaced door latch cable as the clip got damaged. At first this door wouldn’t lock at all, and the lock button was stiff. With lots of wiggling, trying to pull external handle and push lock button at same time, etc etc it now will lock if you use the remote fob, but not lock using the internal button.

Left rear door: this had the door card stripped purely to get a visual on how the latch cable was supposed to attach. At first it wasn’t locking, after some wiggling discovered the handle hadn’t seated properly back to the door, so after a tap it has been working fine.

Front passenger door: not stripped, behaves fine.

Front drivers door: This one got stripped for the door handles too. Now it won’t lock either with internal physical lock button, internal electrical button or fob. The physical button doesn’t ‘feel’ like it is locking / unlocking. I’ve tried wiggling, holding lock button and pulling external handle, locking & unlocking repeatedly with door open and closed etc etc.

No joy.

Any ideas very gratefully received!!!! I’d like my car back. Big Cry Big Cry

Trev
  
Post #18752072nd Nov 2017 10:46 pm
View user's profile Send private message View poster's gallery Reply with quote
KiwiD4
 


Member Since: 17 Aug 2017
Location: Dunedin
Posts: 64

New Zealand 2011 Discovery 4 5.0 V8 HSE Auto BournvilleDiscovery 4

Are any of the door lock buttons stiff to operate? Sounds to me like one of them (possibly the drivers door) is too stiff for the actuator trying to lock it, and therefore it unlocks again.

I've had this on other cars.
 King of the typo.

MY11 D4 5.0 V8, Bourneville, lots of goodies!

Now departed: '85 RR Vogue, '94 D1, '95 D1, '70 SIIA, '97 D1, '04 D2a. All V8, except for the SIIA - but that drank as much petrol anyway! 
 
Post #18752303rd Nov 2017 12:30 am
View user's profile Send private message View poster's gallery Reply with quote
Knockinroe
 


Member Since: 23 Mar 2014
Location: Kenilworth
Posts: 59

England 2012 Discovery 4 3.0 SDV6 HSE Auto Nara BronzeDiscovery 4

Yes, drivers door physical lock button is stiff / doesn’t feel right.

Rear door isn’t stiff, but still doesn’t quite ‘feel’ right.

Any idea what could be causing the stiffness?

Is it possible that the lock mechanism can get ‘out of sync’ with the button or cable? I seem to recall from my old D3 that it’s just a motor in the lock. How does it know it’s position?
  
Post #18752543rd Nov 2017 7:10 am
View user's profile Send private message View poster's gallery Reply with quote
Knockinroe
 


Member Since: 23 Mar 2014
Location: Kenilworth
Posts: 59

England 2012 Discovery 4 3.0 SDV6 HSE Auto Nara BronzeDiscovery 4

So... in case it helps someone one day...

I went over myself and stripped the doors.

Rear door: Turns out when the body guy rebuilt the door, one of the plastic clips on the lock mechanism was broken, so the latch cable wasn’t correctly seating. With the help of a bit of superglue, the cable now locates in the correct location on the lock.

Front door: The white catch on the end of the latch cable was broken and not correctly locating in the back of the internal door handle. (See photo below) Closer inspection showed that this has previously been repaired (must have been when the car went into LR for the door mirror to be replaced! New one ordered... Hoping with the new cable we’ll be up and running again.





Thanks guys!
  
Post #18753193rd Nov 2017 1:43 pm
View user's profile Send private message View poster's gallery Reply with quote
Knockinroe
 


Member Since: 23 Mar 2014
Location: Kenilworth
Posts: 59

England 2012 Discovery 4 3.0 SDV6 HSE Auto Nara BronzeDiscovery 4

Yeah.

New cable fitted. All doors locking and unlocking again! Very Happy
  
Post #18753433rd Nov 2017 5:10 pm
View user's profile Send private message View poster's gallery Reply with quote
KiwiD4
 


Member Since: 17 Aug 2017
Location: Dunedin
Posts: 64

New Zealand 2011 Discovery 4 5.0 V8 HSE Auto BournvilleDiscovery 4

Thumbs Up
 King of the typo.

MY11 D4 5.0 V8, Bourneville, lots of goodies!

Now departed: '85 RR Vogue, '94 D1, '95 D1, '70 SIIA, '97 D1, '04 D2a. All V8, except for the SIIA - but that drank as much petrol anyway! 
 
Post #18754814th Nov 2017 3:53 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site