Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D3)

Hifi / telephone on satnav screen INCLUDING brightness fix
Post Reply  Down to end
Page 39 of 40 <123 ... 383940>
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 5144

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

cut the wrong wire? try reconnecting it

In RR mode the buttons should be swapped around
  
Post #20505473rd May 2019 1:49 pm
View user's profile Send private message View poster's gallery Reply with quote
yellowbelly
 


Member Since: 16 Oct 2013
Location: Lincolnshire
Posts: 132

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Vienna GreenDiscovery 3

I seem to be moving in the right direction. For some reason it had lost the pairing with my phone. So I now have the dialing pad on the sat Nav screen but when I input a number the green dial button does not seem to work nor the one on the steering wheel. This was working before. If I go into the phone book for contacts I can bring up a contact and the green button works and dials the number. However now the call recipient cannot hear me although I can hear them. Again all was good before. By way of background I have the d4 module and everything was working well before this so I am reasonably happy that all is good with the phone system.
 55 Plate Disco 3 HSE. EGR blanked, Decat exhaust, AMK Compressor, bought 20 Dec 13. Watch this space for future upgrades. - Disco 4 front cup holders, D4 Bluetooth, Brembo 4 pot front V8 rear brakes, front diff breather mod, BAS FBH controller, fixed towbar, D4 heated washer jets
Silicone intercooler hoses, RS 500 Intercooler, decat exhaust, remap
IID tool used to enable 3 flash indicators, clock on dash, reverse follow me home lights, snotm, AMK compressor update and still learning 
 
Post #20505843rd May 2019 6:07 pm
View user's profile Send private message View poster's gallery Reply with quote
Crossa
 


Member Since: 27 Mar 2019
Location: Newcastle upon Tyne
Posts: 1

United Kingdom 
Panoramix

Hi Panoramix, are you still able to supply the kit for the brightness fix?

Thanks

Jim
  
Post #20510986th May 2019 10:47 am
View user's profile Send private message View poster's gallery Reply with quote
Johnny Oxford
 


Member Since: 14 Dec 2014
Location: Princes Risborough
Posts: 371

United Kingdom 2014 Discovery 4 3.0 SDV6 HSE Auto Corris GreyDiscovery 4

if anyone is looking for the Panoramix kit I have 1 spare - I bought it last month, havent got round to fitting it and yesterday decided to sell the D3 so drop me a PM. In UK. Any sensible offer.
 2014 D4 HSE Facelift Corris Grey

Previous :

Discovery Sport SE (awful)
56 plate D3 HSE TDV6 Zermatt Silver
Defender 90 200tdi 
 
Post #205204710th May 2019 8:39 am
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 376

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

Panoramix are the dimming kits still availible ?
  
Post #206834514th Jul 2019 7:49 pm
View user's profile Send private message View poster's gallery Reply with quote
Panoramix
 


Member Since: 16 Dec 2008
Location: Milan Area
Posts: 3213

Italy 2008 Discovery 3 TDV6 SE Auto Buckingham BlueDiscovery 3

yes mate, PM'd Thumbs Up
 

By Land Rover Passion:
- EASY LIFT Suspension module
- Tree Sliders
- HD front bumper
- Gear plate
- Switch panel
- Tarox Brake Discs
- Altox Webasto GSM Remote Control

By others:
- DeCat, EGR blanked and DPF removed by BAS
- K&N Filter
- HD rear bumper and wheel carrier by Kaymar
- 19" RRS Rims + GY Duratrac
- 17" LR Rims + Tagom Country Track
- Rear Entertainment System DIY 
 
Post #206839015th Jul 2019 6:18 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
A.J.M
 


Member Since: 31 Oct 2009
Location: Airdrie
Posts: 2704

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

I’ll have mine available shortly.

This upgrade has been a disaster for my car so it’s getting removed and taking sat nav back to D3 spec and I’ll have the Bluetooth system double checked to make sure it’s ok.

Hopefully others have better luck but for my car it’s not worked and caused more issues than worth.
  
Post #206842615th Jul 2019 11:59 am
View user's profile Send private message View poster's gallery Reply with quote
Panoramix
 


Member Since: 16 Dec 2008
Location: Milan Area
Posts: 3213

Italy 2008 Discovery 3 TDV6 SE Auto Buckingham BlueDiscovery 3

Sorry, if you've already talked about it but I don't remember the post Embarassed

what problems did you get?
 

By Land Rover Passion:
- EASY LIFT Suspension module
- Tree Sliders
- HD front bumper
- Gear plate
- Switch panel
- Tarox Brake Discs
- Altox Webasto GSM Remote Control

By others:
- DeCat, EGR blanked and DPF removed by BAS
- K&N Filter
- HD rear bumper and wheel carrier by Kaymar
- 19" RRS Rims + GY Duratrac
- 17" LR Rims + Tagom Country Track
- Rear Entertainment System DIY 
 
Post #206843515th Jul 2019 12:49 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
A.J.M
 


Member Since: 31 Oct 2009
Location: Airdrie
Posts: 2704

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

I believe the issue has been changing from D3 to RR sat nav mode.

The system struggles to pick up the Bluetooth system, which is a D4 module and has the most cable for the system to work.
It can be up to 2 minutes before the system wakes up and realises I have a phone pared.
I can be chatting on loud speaker that whole time, the system will flash up “phone disconnected” then “phone connected” the the system works.

I was on a drive with my gf in the car and she spotted twice that the system would disconnect and reconnect phone. Even without it being used. It was like it just rebooted itself, when it did that the stereo volume stopped for a couple of seconds then came back on like nothing had happened.

Or, it can freeze when I hang up on people so the sat nav screen and radio don’t respond for a minute then it will disconnect phone and reconnect and work again.

The radio no longer gives volume without the key in and turned to position 1.
It turns on fine, but gives no volume regardless of what the volume button on stereo and steering wheel does.

The system just doesn’t work so I’m going to remove everything and go back to D3 spec and try again with it as it’s been a complete disaster.
  
Post #206843915th Jul 2019 1:06 pm
View user's profile Send private message View poster's gallery Reply with quote
Panoramix
 


Member Since: 16 Dec 2008
Location: Milan Area
Posts: 3213

Italy 2008 Discovery 3 TDV6 SE Auto Buckingham BlueDiscovery 3

just to leave nothing out.
Have you checked that you have properly connected the yellow and white cables of the kit?

The light sensor works fine?
 

By Land Rover Passion:
- EASY LIFT Suspension module
- Tree Sliders
- HD front bumper
- Gear plate
- Switch panel
- Tarox Brake Discs
- Altox Webasto GSM Remote Control

By others:
- DeCat, EGR blanked and DPF removed by BAS
- K&N Filter
- HD rear bumper and wheel carrier by Kaymar
- 19" RRS Rims + GY Duratrac
- 17" LR Rims + Tagom Country Track
- Rear Entertainment System DIY 
 
Post #206852815th Jul 2019 6:59 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
A.J.M
 


Member Since: 31 Oct 2009
Location: Airdrie
Posts: 2704

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

I didn’t fit it, it was fitted by a Discovery specialist on here.

All instructions were there for the fitting of it.
  
Post #206853715th Jul 2019 7:25 pm
View user's profile Send private message View poster's gallery Reply with quote
ricajoinvillediscovery
 


Member Since: 19 Jan 2019
Location: joinville
Posts: 1

Brazil 
usb / hdmi/ dvd multimidia

hello gentlemen, how are you?
so i'm from brazil and i have a discovery 3 hse and i would like to know if there is any way to adapt a usb or hdmi input to the car's original multimedia. Thank you very much in advance.
  
Post #20743527th Aug 2019 7:00 pm
View user's profile Send private message View poster's gallery Reply with quote
PaulHam
 


Member Since: 11 Nov 2019
Location: Potters Bar
Posts: 2

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Bonatti GreyDiscovery 3

FAO: Panoramix

Can you PM me with details of your brightness mod please?
  
Post #210494010th Dec 2019 5:55 pm
View user's profile Send private message View poster's gallery Reply with quote
Discoveringcomfort
 


Member Since: 16 Sep 2015
Location: Berkshire
Posts: 428

England 2005 Discovery 3 4.4 V8 HSE Auto Zambezi SilverDiscovery 3

A.J.M wrote:
I believe the issue has been changing from D3 to RR sat nav mode.

The system struggles to pick up the Bluetooth system, which is a D4 module and has the most cable for the system to work.
It can be up to 2 minutes before the system wakes up and realises I have a phone pared.
I can be chatting on loud speaker that whole time, the system will flash up “phone disconnected” then “phone connected” the the system works.

I was on a drive with my gf in the car and she spotted twice that the system would disconnect and reconnect phone. Even without it being used. It was like it just rebooted itself, when it did that the stereo volume stopped for a couple of seconds then came back on like nothing had happened.

Or, it can freeze when I hang up on people so the sat nav screen and radio don’t respond for a minute then it will disconnect phone and reconnect and work again.

The radio no longer gives volume without the key in and turned to position 1.
It turns on fine, but gives no volume regardless of what the volume button on stereo and steering wheel does.

The system just doesn’t work so I’m going to remove everything and go back to D3 spec and try again with it as it’s been a complete disaster.


I have the same issues but having a phone I can use is worth it for now. New proposed laws may make it worthless later on.
 Series 1 V8
Series 2 Hibrid V8
Discovery 3 HSE V8 
 
Post #210504911th Dec 2019 9:56 am
View user's profile Send private message View poster's gallery Reply with quote
Gnomad
 


Member Since: 22 Jul 2018
Location: Harbor Springs
Posts: 9

United States 2008 LR3 4.4 V8 HSE Auto Buckingham BlueLR3

I've done the mod and now used my Christmas present Gap tool to enable the reverse camera, when I shift into reverse it shows me a warning about moving with caution and a black screen, so now if I add a reverse camera it should work, right?
  
Post #210914729th Dec 2019 5:25 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 39 of 40 <123 ... 383940>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2020 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site