Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Electrical] Infotainment System Crash
Post Reply  Down to end
Page 2 of 3 <123>
bkehoe
 


Member Since: 24 Feb 2006
Location: Wexford
Posts: 1481

Ireland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Bonzo, sounds like the problem might be with the clock spring/rotary coupler in the steering column. It's a relatively common problem, and should be quite easy for the dealer to diagnose when you describe the problem, and to fix/replace.
 IE - 05 D3 TDV6 HSE - Zambezi Silver
SA - 07 VW Golf TDI - White - Sold! 
 
Post #13873214th Mar 2007 1:28 pm
View user's profile Send private message View poster's gallery Reply with quote
CJS
 


Member Since: 02 Nov 2006
Location: East Lothian
Posts: 61

Scotland 2014 Discovery 4 3.0 SDV6 HSE Auto Corris GreyDiscovery 4

I see someone has said CDs keep playing even when the unit appears to be off. This can happen if you have had people listening to the CD using the door mounted headphone sockets in the rear. If the headphone sockets are left in CD mode the unit will keep playing CDs even if you are listening to the radio up front. I heard mine changing discs while I was listening to the radio. I checked all the headphone sockets and switched them to 'radio' and the CD stopped playing.
  
Post #13910015th Mar 2007 12:30 am
View user's profile Send private message View poster's gallery Reply with quote
Drookit Dug
 


Member Since: 11 Jun 2007
Location: SOUTH EAST
Posts: 58

United Kingdom 2007 Discovery 3 TDV6 SE Manual Stornoway GreyDiscovery 3
ICE FAILURE

A mate of mine had a stereo failure in his Disco 3 and it would'nt power up at all. After checking the usual things, fuses etc he took it to a dealer. All they did was disconnect the battery terminals and touch them together (The free cable ends that is, not the baterry terminals!). When they reconnected the battery everything worked fine!
  
Post #16813319th Jun 2007 7:56 am
View user's profile Send private message View poster's gallery Reply with quote
tinsel1980
 


Member Since: 14 Aug 2009
Location: east riding of yorkshire
Posts: 1

United Kingdom 2005 Discovery 3 TDV6 SE Manual Bonatti GreyDiscovery 3

Sad HI, I WAS JUST WONDERING IF ANYONE KNOWS WHAT I COULD DO. I HAVE RECENTLY GOT A DISCOVERY 3 THE STEREO WORKS APART FROM THE DISPLAY ON IT. THE SAT NAV WORKS FINE AND ALSO DOES IT HAVE THE BLUETOOTH KIT BUILT INTO IT. IT IS THE 2005 SE MODEL, I EVEN BOUGHT A NEW STEREO AND STILL NO DISPLAY. HELP NEEDED
 STUART  
Post #50755914th Aug 2009 10:19 pm
View user's profile Send private message View poster's gallery Reply with quote
Growler
 


Member Since: 11 Sep 2009
Location: Johannesburg
Posts: 34

South Africa 2006 Discovery 3 4.4 V8 SE Auto Zermatt SilverDiscovery 3

I had a similar problem, costing the dealer to replace the AMP under the drivers seat Big Cry , fortunately under warranty. 2 Years on no further problems. Very Happy
 Live Life, do Africa!
V8 SE, Auto
Custom Exhaust System, Duall Battery System,
Snorkel, Front Skid Plate, Auxillary Fuel Tank,
Spare Wheel Swing Arm, General Grabber AT2's 
 
Post #5305046th Oct 2009 1:34 pm
View user's profile Send private message View poster's gallery Reply with quote
TwelveSticks
 


Member Since: 16 Jan 2010
Location: Dublin
Posts: 798

Ireland 2005 Discovery 3 TDV6 S Manual Zermatt SilverDiscovery 3

Have seen this problem alluded to before, but not fully explained, so this may add to the knowledgebase...

I picked car up from the stealer today after they'd been working on the door (under warranty, thankfully). When I got in, the radio (basic model) was completely dead. They sent one of their sparks out and all he did was disconnect the positive from the battery, earth the end of the positive lead to the frame using his spanner, wait about five seconds, then reconnect the battery. All solved.

He told me that they'd flattened the battery while working on the door ( Shocked ) and had then had it on the charger, and that the radio would sometimes shut down under these conditions - something to do with an electrical spike or current surge. Must be a surge protector on it or something.

He also said that this sometimes happens if you start the engine on a cold morning when the alternator can provide enough of a spike to shut the radio down as well. So I guess this could happen to anyone. The solution is the same.
  
Post #6138063rd Mar 2010 4:55 pm
View user's profile Send private message View poster's gallery Reply with quote
alfheim1
 


Member Since: 23 Mar 2010
Location: Bergen
Posts: 1

2005 Discovery 3 TDV6 HSE Auto Cairns BlueDiscovery 3
resetting the infotainment system

thank you guys Bow down , I managed to restart my stereo tonight, the whole infotainment system, radio, monitor, everything was black, I basically tried all different things posted, but none worked. Iin the end i pulled out all the sockets on the amplifier under the seat, pulled out all the fuses, reset the system (battery hard reset) and put everything back, voila!!! it worked! thank you again
  
Post #62615623rd Mar 2010 8:21 pm
View user's profile Send private message View poster's gallery Reply with quote
E-peich
 


Member Since: 15 Jan 2009
Location: Pamplona
Posts: 41

Spain 2005 Discovery 3 TDV6 SE Manual Zermatt SilverDiscovery 3

Hello to everybody, yerterday morning an error that has occurred to me suddenly on the radio 6CD display screen, without warning, seems software, but with the use of several buttons (eject the CD, front windows up or down or activate the mute parrot that starts in radio) playing with these buttons undid the error.
The error is the total disappearance of the contents of the radio display, but everything works perfectly, all CD, stations, controls volume, balance or facer, the phone parrot etc ... all OK. Suddenly just give me the display error, not seen nothing. Why? Because I use some of the 6cd from home-burned cd? for updating with the faultmate some infotainment modules I have’t yet installed (screen-subwofer browser) which can not be the cause.
I read on the forum some similar, but apparently only affected few people, they say that with a battery reset the car is fixed, I have’t done yet.
Before the "erase" the entire screen, he began looking like if you read in a mirror the text, then began to "re-pixels" all content disappearing parts of letters and eventually was it. On the first occasion, before the error, I go to reset all the radio using the control menu on the radio, and was solved, but not the second or third because I was driving and esuddenly "delete" all the radio display.

Any idea how to reset the radio without removing the battery?
You know if you would have to put a "patch" software with faultmate or Land Rover?
Recently (4 weeks) I update my radio from basic radio to 6cd with amplifier.

If somebody could help me plese I hear his knoledge about this problem.

Cheers
 E-peich

"A man with a new idea is a madman until the idea triumphs" - Mark Twain 
 
Post #6889443rd Sep 2010 8:31 am
View user's profile Send private message View poster's gallery Reply with quote
frenchy
 


Member Since: 05 Dec 2007
Location: Halewood
Posts: 819

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Nara BronzeDiscovery 4

Hi E-P

Radio / Bluetooth / Sat Nav display went down yesterday (2nd time in about 6 wks Evil or Very Mad )

To reset the readio without battery removal...............

Open up the Large Glovebox to access the fusebox (by pushing down on the curved retainers either side.)

Remove fuse 53 - double check the fuse number in the hand book to check

Wait 10 - 15 mins and re insert the fuse - radio unit takes a couple of minutes to reset and then works fine.

You'll need a torch to find the fuse numbers as all pretty dark down there.

Thumbs Up
  
Post #6890263rd Sep 2010 11:58 am
View user's profile Send private message View poster's gallery Reply with quote
E-peich
 


Member Since: 15 Jan 2009
Location: Pamplona
Posts: 41

Spain 2005 Discovery 3 TDV6 SE Manual Zermatt SilverDiscovery 3

Hi thank you for, I open the Glovebox and instead off the fuse 53 removing I unplug the C0582 connector who have all the wiring cables from the dash (radio, steering wheel, nav, airbag,... etc.) and after 15 min (more or less) nothing the nothing the radio was without display screen again.

I try with your option after lunch.


Cheers
 E-peich

"A man with a new idea is a madman until the idea triumphs" - Mark Twain 
 
Post #6890283rd Sep 2010 12:05 pm
View user's profile Send private message View poster's gallery Reply with quote
E-peich
 


Member Since: 15 Jan 2009
Location: Pamplona
Posts: 41

Spain 2005 Discovery 3 TDV6 SE Manual Zermatt SilverDiscovery 3

After a couple of days testing different failures, my conclusion, that it is a problem of the CD-changer, it have some problem to understand properly the CD music when these are "burned at home", the display loose the control on his correct way of function. I don't know exactly if the error it is caused by some special CD format (CD-R , CD-RW or other) but with using original music CD the Radio-6CD hi-line don't have any problem on display.
These are my trial and error results.

Cheers.
 E-peich

"A man with a new idea is a madman until the idea triumphs" - Mark Twain 
 
Post #6907278th Sep 2010 2:04 pm
View user's profile Send private message View poster's gallery Reply with quote
lawman
 


Member Since: 06 May 2005
Location: South East
Posts: 72

Sat Nav Lock Up Disco 3.

Tried to enter a route for this coming Saturday and for some reason all I am getting is the LR logo/piccie and it wont go to the "I agree" stuff so I can't use the satnav. Anyone know how to try a reset please? PS. My amp packed up about a week ago BUT I still had satnav albeit without voice until the amp is fixed/replaced. Thanks Big Cry
  
Post #80660514th Jun 2011 6:11 am
View user's profile Send private message View poster's gallery Reply with quote
Richard scott
 


Member Since: 07 Nov 2011
Location: Sheffield
Posts: 3

United Kingdom 2008 Discovery 3 TDV6 GS Auto Siberian SilverDiscovery 3

My very first post on the forum

Recently purchased an 08 disco 3 that until today has been just wonderful. So glad to be back in a landrover after 2 years in an audi

Anyway, today the radio just froze. Illuminated but dead

I have done as mentioned i.e remove battery terminal and earth with a spanner!

It worked a treat! Cheers guys
  
Post #8561847th Nov 2011 9:03 pm
View user's profile Send private message View poster's gallery Reply with quote
Number 7
 


Member Since: 11 Nov 2011
Location: Carmarthenshire
Posts: 4

Wales 2005 Discovery 3 TDV6 Base 5 Seat Manual Java BlackDiscovery 3

Radio dead for two days - grovelled around checking fuses for an afternoon. Diconnected battery - Presto - all fixed.

Thanks all.

Alan
  
Post #85765811th Nov 2011 1:07 pm
View user's profile Send private message View poster's gallery Reply with quote
davemh_80
 


Member Since: 17 Jul 2010
Location: Sydney
Posts: 16

Australia 2007 Discovery 3 TDV6 SE Auto Lugano TealDiscovery 3

Same here. Radio completely dead - no sound, no display, and also noticed no clock/time display on the dashboard either. Performed the Hard Reset (see Wiki) and all restored to normal.
  
Post #96870623rd Aug 2012 8:47 am
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 2 of 3 <123>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site