Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Other] Further issues to be clarified
Post Reply  Down to end
Page 2 of 3 <123>
Rupertblw
 


Member Since: 14 May 2015
Location: Dubai
Posts: 1

United Arab Emirates 2008 Discovery 3 4.0 V6 Petrol Base 7 Seat Auto ChablisDiscovery 3
Engine coolant

Hi,

I am new to the site so apologies if this in posted in the wrong area!

I have a 2008 LR3 in Dubai and struggling to get help on this even from a Land Rover dealer!!

I have had issues with my engine coolant levels. A new radiator was fitted due to apparent leak. I then had what seemed to be decreasing engine coolant levels but with no apparent signes of a head gasket failure.

The issue I now have is that if I drive the car. Stop and then re drive the car the engine coolant warning comes on. Upon inspecting the coolant level in the expansion tank it does indeed show that the coolant level is way down at the bottom of the tank however as soon as I open the filler cap the level rises to above the max fill level. The issues then goes away but this has been happening for the past few days without the apparent need to top it up. Engine temp is in the normal range but it is very frustrating to have to keep opening the filler cap and I at a loss why this is happening!

Any help would be much appreciated as I wanting to sell the car!

Many thanks!!
  
Post #147333214th May 2015 6:16 am
View user's profile Send private message View poster's gallery Reply with quote
Disco_Mikey
 


Member Since: 29 May 2007
Location: Dundee, Scotland
Posts: 20778

Scotland 2005 Discovery 3 TDV6 HSE Auto Cairns BlueDiscovery 3

How much pressure is released when you open the cap?
 My D3 Build Thread

TDV8 Retrofit Build Thread 
 
Post #147333314th May 2015 6:33 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Tung
 


Member Since: 01 Nov 2015
Location: Nairobi
Posts: 3

Kenya 2005 LR3 TDV6 HSE Auto Unknown ColourLR3

Hi, am new to the forum but I have benefited greatly from these discussions. a problem I have note seen here or in the net is fault P023a-00 "charge air cooler coolant pump control open circuit" disco 3 , 2005. Vin salla.135A30****
 D3,2005/D4,2010/Merc w203, 2004  
Post #156769926th Nov 2015 4:59 pm
View user's profile Send private message View poster's gallery Reply with quote
WJL-D3
 


Member Since: 06 Apr 2018
Location: Clare
Posts: 3

Ireland 2008 Discovery 3 TDV6 Base 7 Seat Manual Siberian SilverDiscovery 3
LR3

Martin/ Anyone

I am new to the forum and have used it in the past as a guest and found it very helpful, I have a LR3 2.7TDV6- 2008 model which I have had for nearly two years.

Have you or anyone ever heard of the dash/ cluster going off/ shutting down completely, last time it happened the cluster was off for around 20 seconds? it looks like a loss of power to the cluster, everything else in the vehicle still works and stays on.

Can you help?
  
Post #19339526th Apr 2018 10:31 am
View user's profile Send private message View poster's gallery Reply with quote
Disco?
 


Member Since: 24 Dec 2018
Location: Chester
Posts: 2

United Kingdom 
Hazard/ electrical issue

Hi we have disco 3 many issues popped up, air suspension failure normal height only, and boot won’t open, read those issues but the big one is this...

Our car locks and unlocks fine, starts fine first time, drive it down the road and it locks and unlocks itself, then puts all the hazard lights on... if you continue to drive it repeatedly does this then turns off the heating, radio, and parrot... basically anything electrical if you stop and turn the engine off it won’t start for 20-30 mins absolutely flat unless you get out, remote lock and unlock then get in and starts fine again? Different codes coming up but disappear once engines switched off locked and started again?anyone else seen or heard of this? One garage thinks the keys have decoded but it’s worse with the spare key, other garage thinks electrical fault?

Doesn’t make any sense it’s like a mind of its own it’s xmas and no one will take it in now, if I take the alarm/ indicator fuse out will it make it worse? Police pulled us over at weekend and we’re very kind about it but don’t want it to be reoccurring only vehicle we own so got to be used!!
  
Post #201229124th Dec 2018 8:15 am
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 12827

United Kingdom 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

Welcome to the forum!
Start by checking the state of your battery... D3/4 is very sensitive to battery issues.
 .


Dean
====================================

2011 D4 XS - OBD port protection, RLD spare wheel protector, All LED interiors lights, Timed Climate enabled, iiD tool paired.
2011 D4 Landmark - Stolen from same dealer before I paid for it
2011 D4 GS - Stolen whilst at dealer Sad ... All LED interiors lights, DRLs, Spare Wheel protector.
1996 300Tdi - Eaten by tin worms 
 
Post #201229224th Dec 2018 8:21 am
View user's profile Send private message View poster's gallery Reply with quote
Bardley
 


Member Since: 02 May 2018
Location: Hertfordshire
Posts: 452

United Kingdom 2011 Discovery 4 3.0 TDV6 HSE Auto Santorini BlackDiscovery 4
Look at the battery..

If you can the battery tested, I would take a look in that direction first off, along with a plugin on a diagnostic tool such as the GAPII unit.

A low battery can produce all sorts of unrelated faults, so a check with a meter pre cold starting, then running will tell you what's happening with alternator too.
A drop test would also diagnose any faulty cells.

With all those electrical issues, unless you know the history of the battery, I would try that route first.
 2011 MY D4 HSE
Previously 2001 D2 TD5, 1996 D1 300Tdi, 1985 90 2.2 petrol.
Bikes! KTM, BMW, British, Classics and others.
 
 
Post #201229324th Dec 2018 8:25 am
View user's profile Send private message View poster's gallery Reply with quote
Disco?
 


Member Since: 24 Dec 2018
Location: Chester
Posts: 2

United Kingdom 
Re: Hazard/ electrical issue

Disco? wrote:
Hi we have disco 3 many issues popped up, air suspension failure normal height only, and boot won’t open, read those issues but the big one is this...

Our car locks and unlocks fine, starts fine first time, drive it down the road and it locks and unlocks itself, then puts all the hazard lights on... if you continue to drive it repeatedly does this then turns off the heating, radio, and parrot... basically anything electrical if you stop and turn the engine off it won’t start for 20-30 mins absolutely flat unless you get out, remote lock and unlock then get in and starts fine again? Different codes coming up but disappear once engines switched off locked and started again?anyone else seen or heard of this? One garage thinks the keys have decoded but it’s worse with the spare key, other garage thinks electrical fault?

Doesn’t make any sense it’s like a mind of its own it’s xmas and no one will take it in now, if I take the alarm/ indicator fuse out will it make it worse? Police pulled us over at weekend and we’re very kind about it but don’t want it to be reoccurring only vehicle we own so got to be used!!




Next issue checked fuse box half the fuses seem to be missing.... now car is in limp mode?!?! Never touching a disco again!!!!!
  
Post #20144892nd Jan 2019 12:34 pm
View user's profile Send private message View poster's gallery Reply with quote
ajn9000
 


Member Since: 28 Jul 2019
Location: Cornwall
Posts: 6

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Vienna GreenDiscovery 3
'Engine System Fault' warning

Hi
This warning has come up on the dash and it would be helpful to have a list of possible causes all in one place as a check list to run through in order of cost/complexity - does any one know if a post like this exists. There seem to be partial lists, but not a comprehensive check list.
Many thanks
  
Post #207179228th Jul 2019 11:38 am
View user's profile Send private message View poster's gallery Reply with quote
98
 


Member Since: 20 Jul 2020
Location: London
Posts: 6

United Kingdom 2007 Discovery 3 TDV6 Base 7 Seat Auto Java BlackDiscovery 3
Gear selector showing E on a automatic

Hi everyone new here! I’ve recently purchased a 2007 automatic Land Rover discovery 3 and which I had to change over the fuel injector on cylinder 5, LH EGR valve and a fuel sensor on the LH side. All of a sudden my cars spedometor is currently showing it’s in gear E, as it was driving before and now it won’t. Is it a safety feature where it’s gone into security mode etc. Thank you!

New battery has been installed and there’s a usual clicking sound inside the cabin when trying to turn it over but no turn over.
  
Post #216220820th Jul 2020 12:59 am
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 2462

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

I would start by doing a hard reset, it may be that the car was not asleep when you changed the battery and the ecu's have logged faults

https://www.disco3.co.uk/wiki/Hard_Reset
  
Post #216221420th Jul 2020 6:25 am
View user's profile Send private message View poster's gallery Reply with quote
98
 


Member Since: 20 Jul 2020
Location: London
Posts: 6

United Kingdom 2007 Discovery 3 TDV6 Base 7 Seat Auto Java BlackDiscovery 3

Thank you aja4x4, before I do a hard reset may I ask what caused the information screen on the dash to show th letter E instead of F? As i know that the “E” means error and the “F” is fault and wanted to troubleshoot what is causing the E to pop up and is it a easy fix as stated “limited gears available”

Much appreciated!
  
Post #216266822nd Jul 2020 9:08 am
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 2462

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

The car needs to be left for 20mins to go to sleep before disconnecting the battery if you don't it can cause problems with the ecu's if the gearbox ECU had a fault code caused by this it's possible it started up in safe mode.
This can also happen if the battery voltage is too low
  
Post #216268622nd Jul 2020 11:00 am
View user's profile Send private message View poster's gallery Reply with quote
98
 


Member Since: 20 Jul 2020
Location: London
Posts: 6

United Kingdom 2007 Discovery 3 TDV6 Base 7 Seat Auto Java BlackDiscovery 3

Thank you I was told to look at the mega fuse that’s located on the positive wire that connects on to the battery is there any way of telling if the fuse is blown on that and how would I go about checking it with my multimeter?

Thanks!
  
Post #216272122nd Jul 2020 1:59 pm
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 2462

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

You can test it with your multimeter set to volts dc.

1. Connect your earth lead to the battery negative terminal
2. Touch the positive lead on to the positive battery lead you will then get the battery voltage
3. Move the positive lead to the battery side of the fuse you should get the same reading
4. Move the positive lead to the load side of the fuse, if you get the same voltage all is good
If you get zero or very low 1or 2v the fuse has blown.

While you have your multimeter out set it to ohms touch both leads together you should get a reading of zero (some meters require you to press a button to zero the meter)
Connect one lead to the battery negative terminal and the other to a clean metalic part of the engine you should get a very low reading. If you have a bad earth connection you will get a high resistance reading.
  
Post #216276422nd Jul 2020 6:16 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 2 of 3 <123>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site