Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Key Entry
Post Reply  Down to end
Page 4 of 6 <123456>
Can you get in using the key
yes
63%
 63%  [84]
no
18%
 18%  [25]
yes but with difficulty
14%
 14%  [19]
I broke my key!
3%
 3%  [5]
Total Votes: 133

Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

Had to use key yesterday as remote stopped working, opened no problem. Going to dealer to be fixed, they suspect receiver aerial cable connection as they have seen a few failures of connection?
  
Post #9061067th Mar 2012 6:16 am
View user's profile Send private message View poster's gallery Reply with quote
bbyer
 


Member Since: 25 Dec 2008
Location: Edmonton Alberta
Posts: 678

Canada 2005 LR3 4.4 V8 HSE Auto Zambezi SilverLR3
Could also be splice.

If you have a second key fob, I assume that it does not open the vehicle either. Yes, what your dealer is talking about could be the problem. I presume you are familiar with the splice problem under the door sills per the link below. I also presume that your dealer is as well, however the thread is worth reading regardless.

http://www.disco3.co.uk/forum/topic29241-15.html

I thought of it as many have assumed the solution was with the receiver aerial or the power to wiring to it and instead discovered they had the corroded splice problem instead. The good news is that the splice thing is probably easier to get at than the aerial wiring.
 2005 LR3 HSE 4.4L AJ-V8 petrol; Traxide Dual Battery; PIAA 2500K Yellow Ion H11 Fog Light bulbs; CounterAct LT-2 Capacitive Corrosion control; LLumar AIR80 Blue clear Infra Red blocking side window film; Liftgate manual release; Schrader Valve "air in" mod to OEM air suspension reservoir tank; Akebono ceramic pads; OEM solid vented discs; LR4 design hitch receiver; Wiggs D4 MOST bluetooth module; Clock on the Dash; 3 Flash signal light mod; Backup Camera; 2015/16 Nav Data update.  
Post #9062367th Mar 2012 12:45 pm
View user's profile Send private message View poster's gallery Reply with quote
Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

Many thanks for reply. I might have described the dealers response wrong, as they said it was a possible wiring issue in the passenger side of car. Being an intermittent problem, so most likely the loose connection as you described. As car is covered by warranty going to get dealer to sort it out. Car going in tomorrow so will post response on their findings.
  
Post #9065057th Mar 2012 8:30 pm
View user's profile Send private message View poster's gallery Reply with quote
Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

As promised further feedback. After 2 days at dealers got the car back and no resolution to problem. They say that they checked all the wiring for loose connections and could not find any and now think problem lies with key so they have ordered a new key ( at their cost).

Highly frustrating so looks like I will have to check the connection referred to in other posts whilst waiting for the new key.

Will update once I have looked at connection.
  
Post #90802811th Mar 2012 6:34 pm
View user's profile Send private message View poster's gallery Reply with quote
bbyer
 


Member Since: 25 Dec 2008
Location: Edmonton Alberta
Posts: 678

Canada 2005 LR3 4.4 V8 HSE Auto Zambezi SilverLR3
Splice is near front seat on passenger side

Below is a pretty good link re a discussion as to where the splice is located for a LHD LR3. For RHD, it is still the passenger side, but this time on the left. There are posts regarding both LHD and RHD and finding the spice. It is well buried within a wiring bundle under the wide plastic covers between the carpet and the door sill metal. The last page of the thread shows pictures. Maybe you will teach the dealer something.

http://www.landroversonly.com/forums/f41/k...elp-28115/
 2005 LR3 HSE 4.4L AJ-V8 petrol; Traxide Dual Battery; PIAA 2500K Yellow Ion H11 Fog Light bulbs; CounterAct LT-2 Capacitive Corrosion control; LLumar AIR80 Blue clear Infra Red blocking side window film; Liftgate manual release; Schrader Valve "air in" mod to OEM air suspension reservoir tank; Akebono ceramic pads; OEM solid vented discs; LR4 design hitch receiver; Wiggs D4 MOST bluetooth module; Clock on the Dash; 3 Flash signal light mod; Backup Camera; 2015/16 Nav Data update.  
Post #90817311th Mar 2012 11:01 pm
View user's profile Send private message View poster's gallery Reply with quote
Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

Have redone the splice, as stated. quite a search in the wiring loom to find. The biggest pain was getting the covers back in.

Unfortunately the repair has not fixed the problem as the remote lock/unlock is still intermittent , so will now wait to see if new key fixes the problem. Censored
  
Post #90874513th Mar 2012 8:06 am
View user's profile Send private message View poster's gallery Reply with quote
bbyer
 


Member Since: 25 Dec 2008
Location: Edmonton Alberta
Posts: 678

Canada 2005 LR3 4.4 V8 HSE Auto Zambezi SilverLR3
two splices in there

I presume that the colour of the wires going into the splice you redid was some combination of white and green? I ask that as there is a second splice within the loom at about that location, but with red coloured wires that provide power to the power window switch lights.
 2005 LR3 HSE 4.4L AJ-V8 petrol; Traxide Dual Battery; PIAA 2500K Yellow Ion H11 Fog Light bulbs; CounterAct LT-2 Capacitive Corrosion control; LLumar AIR80 Blue clear Infra Red blocking side window film; Liftgate manual release; Schrader Valve "air in" mod to OEM air suspension reservoir tank; Akebono ceramic pads; OEM solid vented discs; LR4 design hitch receiver; Wiggs D4 MOST bluetooth module; Clock on the Dash; 3 Flash signal light mod; Backup Camera; 2015/16 Nav Data update.  
Post #90892013th Mar 2012 2:26 pm
View user's profile Send private message View poster's gallery Reply with quote
Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

Also wondered if did the correct splice, but was only one I could find with green/white stripe wires 1 on one side and 2 on the other end of which one went forward and the other under the passenger seat. Did also find 2 other splices, but they were both with red wires so left them alone.

Many thanks for all the help. Hope I did not get it wrong.
  
Post #90897713th Mar 2012 4:23 pm
View user's profile Send private message View poster's gallery Reply with quote
bbyer
 


Member Since: 25 Dec 2008
Location: Edmonton Alberta
Posts: 678

Canada 2005 LR3 4.4 V8 HSE Auto Zambezi SilverLR3
White/green are the correct wires.

It sounds like you redid the correct splice, the green white wires; it is unfortunate that does not appear to be the solution as it is a simple one once you find the splice.

Please keep us informed as to the final fix as we all benefit from others "found" solutions.
 2005 LR3 HSE 4.4L AJ-V8 petrol; Traxide Dual Battery; PIAA 2500K Yellow Ion H11 Fog Light bulbs; CounterAct LT-2 Capacitive Corrosion control; LLumar AIR80 Blue clear Infra Red blocking side window film; Liftgate manual release; Schrader Valve "air in" mod to OEM air suspension reservoir tank; Akebono ceramic pads; OEM solid vented discs; LR4 design hitch receiver; Wiggs D4 MOST bluetooth module; Clock on the Dash; 3 Flash signal light mod; Backup Camera; 2015/16 Nav Data update.  
Post #90909713th Mar 2012 8:10 pm
View user's profile Send private message View poster's gallery Reply with quote
Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

just a quick update, since the splice did not work.

Have read a few posts on the key battery being a problem sometimes with solder joint being loose after being banged around a bit. So now when remote won't open doors have tapped the key a bit and this has seemed to help, as the remote suddenly starts to work. Will now wait for new key to arrive from UK and if that solves problem, then will know it is old remote and will open it and replace battery, whilst resoldering battery connections. will update at that time. thanks again for help.
  
Post #90985315th Mar 2012 9:09 am
View user's profile Send private message View poster's gallery Reply with quote
Zono
 


Member Since: 28 Feb 2012
Location: Cape town
Posts: 8

South Africa 2007 Discovery 3 TDV6 SE Auto Santorini BlackDiscovery 3

Have had the new key for a few days now and working perfectly so looks like fault was with old key.

Will try open it sometime and resolder battery.
  
Post #91493727th Mar 2012 3:31 pm
View user's profile Send private message View poster's gallery Reply with quote
bmc052
 


Member Since: 22 Oct 2012
Location: Pembroke
Posts: 6

Malta 2008 Discovery 3 TDV6 S Auto Java BlackDiscovery 3
Key not keeping charge, possibly flat battery inside

I have one key not keeping charge. After a good drive i will be able to lock doors but once i am back after approx 6 hours the remote does not work. Am using the spare key and that works fine. Tried to order a new one but they asked me for 350 Euros for a new one. Any suggestions?
Thanks
  
Post #99313723rd Oct 2012 8:42 am
View user's profile Send private message View poster's gallery Reply with quote
bbyer
 


Member Since: 25 Dec 2008
Location: Edmonton Alberta
Posts: 678

Canada 2005 LR3 4.4 V8 HSE Auto Zambezi SilverLR3
Link showing battery replacement.

Below is a link to battery replacement. There are many other threads as well. Use +battery +replacement or similar as search words.

http://www.disco3.co.uk/forum/topic39609.h...key+%2Bfob
 2005 LR3 HSE 4.4L AJ-V8 petrol; Traxide Dual Battery; PIAA 2500K Yellow Ion H11 Fog Light bulbs; CounterAct LT-2 Capacitive Corrosion control; LLumar AIR80 Blue clear Infra Red blocking side window film; Liftgate manual release; Schrader Valve "air in" mod to OEM air suspension reservoir tank; Akebono ceramic pads; OEM solid vented discs; LR4 design hitch receiver; Wiggs D4 MOST bluetooth module; Clock on the Dash; 3 Flash signal light mod; Backup Camera; 2015/16 Nav Data update.  
Post #99322123rd Oct 2012 1:24 pm
View user's profile Send private message View poster's gallery Reply with quote
bmc052
 


Member Since: 22 Oct 2012
Location: Pembroke
Posts: 6

Malta 2008 Discovery 3 TDV6 S Auto Java BlackDiscovery 3

hi,
Thanks so much for the great help.

I was told you are helpful but i never thought it is this good.

Thanks so much guys Very Happy

BMC
  
Post #99350724th Oct 2012 7:58 am
View user's profile Send private message View poster's gallery Reply with quote
bbyer
 


Member Since: 25 Dec 2008
Location: Edmonton Alberta
Posts: 678

Canada 2005 LR3 4.4 V8 HSE Auto Zambezi SilverLR3
Not that much fun.

Replacing the battery is not what I would call a fun task. Splitting the case open it is suggested you wear gloves as that is the dangerous part of the whole procedure and tends to draw blood. Once you get the case open, look carefully at how the existing battery is soldered into the circuit.

I say that as it is possible that the existing battery is OK and that one of the soldered connections is cracked and then charging and operation can be intermittent. In other words, you just might try re-soldering the two tabs first.

To charge the battery back up, just tape it to the key fob in use. The radiated power will over a few days bring the charge back up. The good part about that technique is that you do not have to put the case back together and hence can measure the state of charge of the battery to see if anything good is happening. It is also possible that the battery will show near 3 volts when you open the case up. If so, that does suggest re-soldering is the answer to the problem as the cracked solder joints are for the most part, only affecting operation rather than the charging cycle as that occurs whenever the key is in or near the ignition cylinder.

We appreciated your thank you - it is nice to get feedback. Keep us informed as to how the fix proceeds if you go ahead.
 2005 LR3 HSE 4.4L AJ-V8 petrol; Traxide Dual Battery; PIAA 2500K Yellow Ion H11 Fog Light bulbs; CounterAct LT-2 Capacitive Corrosion control; LLumar AIR80 Blue clear Infra Red blocking side window film; Liftgate manual release; Schrader Valve "air in" mod to OEM air suspension reservoir tank; Akebono ceramic pads; OEM solid vented discs; LR4 design hitch receiver; Wiggs D4 MOST bluetooth module; Clock on the Dash; 3 Flash signal light mod; Backup Camera; 2015/16 Nav Data update.  
Post #99361624th Oct 2012 2:34 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 4 of 6 <123456>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site