Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Mutliple faults lit up the dashboard
Post Reply  Down to end
Page 14 of 15 <123 ... 131415>
NicoHarmsen
 


Member Since: 18 Jun 2020
Location: Red Creek
Posts: 4

Australia 2008 Discovery 3 TDV6 HSE Auto Arctic FrostDiscovery 3

Also , do not connect your iPhone to the stereo system. It’s ok to charge it via the 12v power plug , but don’t plug into back socket to play music from your iPhone through the stereo. I found this also throws the computer out ,too advanced forthr Disco3’s computer.
  
Post #22656705th Dec 2021 10:14 pm
View user's profile Send private message View poster's gallery Reply with quote
NicoHarmsen
 


Member Since: 18 Jun 2020
Location: Red Creek
Posts: 4

Australia 2008 Discovery 3 TDV6 HSE Auto Arctic FrostDiscovery 3
All errors solved .

Trailers with led lights are a big problem for the computer. Use 21w incandescent bulbs or a load resistor kit . Reset all errors . All your problems solved . This was an expensive lesson for me . Also don’t use your iPhone through the stereo system . Charging from 12 v cigarette lighter ok .
  
Post #226776317th Dec 2021 11:35 pm
View user's profile Send private message View poster's gallery Reply with quote
Gastón did castelnuovo
 


Member Since: 15 Apr 2022
Location: Argentina
Posts: 15

Argentina 2009 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3
Re: IID Tool Faults & Fixes please

F15KEY wrote:
I guess that these have all been covered before, but I'm loosing the will to live with our D3!

It keeps going into various fault modes and below is a previous grab from the IID report.

I've replaced the Air Suspension compressor, a complete AMK Kit and flashed the ECU for this, looking at the one removed it didn't look like anything was wrong, but hey, now has a new one for the next couple of years.

Changed the Brake Light Switch, this threw up many more codes that I could mention, so put the old one back on.

About to put in a new High Pressure Fuel Pump as LR say that is the problem.
So have you solved the problem with the new HPFP?? I'm having similar problems with my 2009 TDV6 LR3 with 115k on it

Before I fit the new one and void any chance of a refund if this doesn't fix it, HAS ANYONE GOT ANY OTHER SUGGESTIONS, please?

Many thanks

James

L319 - Discovery 3 2009
Vehicle scanned on 30-11-2021 8:34 pm
Using IIDTool BT V4.0 B2742

Body Control

B1B91-3A (2F) Seat tilt motor speed/position sensor - Frequency modulation/pulse width modulation failure - incorrect, has too many pulses
( on 29-11-2021 6:47:33 pm at 204810 km )
Cell Phone

U3003-17 (AC) Battery voltage - General electrical failure - circuit voltage above threshold
( on 30-11-2021 8:24:47 pm at 204930 km )
Engine TDV6

P117D-00 (68) Fuel volume regulator control exceeded maximum control limit
Parking Brake

U0100-87 (A8) Lost communication with engine control module/powertrain control module 'A' - Bus signal/message failure - missing a message
( on 29-11-2021 8:14:15 pm at 204820 km )
Suspension

C1A20-64 (2C) Pressure increases too slow when filling reservoir - Algorithm based failure - signal plausibility failure
( on 29-11-2021 7:30:12 pm at 204814 km )
Transmission

U2023-86 (AC) Control module network signal calibration data - Bus signal/message failure - signal is invalid
( on 29-11-2021 8:14:15 pm at 204820 km )
  
Post #228826517th Apr 2022 3:41 am
View user's profile Send private message View poster's gallery Reply with quote
terryall
 


Member Since: 17 Jun 2011
Location: Whitstable
Posts: 1429

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

I had the Christmas tree lights problem for almost a year and tried many remedies to no avail. Eventually, the fault was tracked down to a tiny leak in one of the front suspension air bags. It was only found by using a can of spray that plumbers use to detect gas leaks and was at the very top of the bag. Solved my problem by getting a new one and all was well afterwards.
  
Post #228826917th Apr 2022 7:53 am
View user's profile Send private message View poster's gallery Reply with quote
Sneakymickeyy
 


Member Since: 20 Dec 2021
Location: Høland
Posts: 11

Norway 2006 Discovery 3 TDV6 HSE Lux Auto Barolo BlackDiscovery 3


Hi.

Was out driving to Day in the New snow on wooden roads when my dash lit UP gear fault and som on same as many Others here have talked about. But my car won't start now tried reading fault codes but engine gear body and all related to motion modules isn't showing up and alot of other codes on everything. And i can't turn off my Hazzard lights when the pics was taken the engine was running

  
Post #231609723rd Nov 2022 10:20 pm
View user's profile Send private message View poster's gallery Reply with quote
Yankee_Rover
 


Member Since: 02 Jun 2021
Location: Seattle
Posts: 183

United States 2008 LR3 4.4 V8 HSE Lux Auto Zermatt SilverLR3

Looks like your transmission is throwing a fault. I’ve had an issue with the TCM (bad grounding wire in the loom) that caused loss of communication with the transmission, and mayhem ensued. Car would not start after it was turned off. This all happened after driving on a washboard gravel road for a mile.

Try disconnecting your battery for 10 minutes. Might let you restart the car. If that fails, try using the parking gear bypass under the gear shifter (instructions in the owners manual under the “towing/servicing” section). Once in neutral, try starting again. I did all this and it allowed me to get back to pavement to get sorted.

Good luck!
 2008 LR3 HSE, 4.4L V8  
Post #231612224th Nov 2022 2:30 am
View user's profile Send private message View poster's gallery Reply with quote
Sneakymickeyy
 


Member Since: 20 Dec 2021
Location: Høland
Posts: 11

Norway 2006 Discovery 3 TDV6 HSE Lux Auto Barolo BlackDiscovery 3

Thx Will do tomorrow i taken det TCM in yesterday and put IT on my radiator to dry up battery is charging in my livingrom but check the rest of it tomorrow BTW (New to LD D3 got mine 1 year whit out any problems feel lucky after what I've read in here.)

TCM is the one behind the battery right?
  
Post #231623025th Nov 2022 12:08 am
View user's profile Send private message View poster's gallery Reply with quote
Yankee_Rover
 


Member Since: 02 Jun 2021
Location: Seattle
Posts: 183

United States 2008 LR3 4.4 V8 HSE Lux Auto Zermatt SilverLR3

TCCM (transfer case control module) is behind the battery. TCM (transmission control module) is in the transmission, it’s part of the valve body. Fortunately true problems with the TCM are very rare, problems with them are usually wiring leading to the trans.

If you can pull diagnostic codes you’ll have a better idea. If you can do that, start a new thread and you’ll get more replies. 👍
 2008 LR3 HSE, 4.4L V8  
Post #231623425th Nov 2022 1:15 am
View user's profile Send private message View poster's gallery Reply with quote
Sneakymickeyy
 


Member Since: 20 Dec 2021
Location: Høland
Posts: 11

Norway 2006 Discovery 3 TDV6 HSE Lux Auto Barolo BlackDiscovery 3

My problem is that I can't see the tcm in diagnose norr tccm or ecu non of em shows up not abs or srs
  
Post #231623525th Nov 2022 1:17 am
View user's profile Send private message View poster's gallery Reply with quote
Yankee_Rover
 


Member Since: 02 Jun 2021
Location: Seattle
Posts: 183

United States 2008 LR3 4.4 V8 HSE Lux Auto Zermatt SilverLR3

Good news is that it sounds like there probably isn’t a problem with any of those modules. I’d start looking for a bad ground somewhere. There’s a main loom ground in the rear of the vehicle, left side, above the spare wheel well.

I think you’d best be served by starting a new thread for maximum visibility.
 2008 LR3 HSE, 4.4L V8  
Post #231623825th Nov 2022 2:17 am
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 2462

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

Check your battery terminals are tight, my securing bolt was tight but i had a crack in the clamp and you could move the clamp on the terminal.
 Andrew

D3 2.7tdv6 2005
D4 3.0 SDV6 Commercial died and gone to LR heaven
D5 3.0 SDV6 HSE 
 
Post #231623925th Nov 2022 7:14 am
View user's profile Send private message View poster's gallery Reply with quote
gstuart
 


Member Since: 21 Oct 2016
Location: kent
Posts: 13850

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Auto Java BlackDiscovery 3

Hi

Plus 1 what others have mentioned , also heard about some of the errors ur having with hazard light coming on , not starting and I wonder if ur instrument panel cluster may be at fault due to many modules that go through it

Can get it repaired but for the life of of me can’t remember who others have used

Fingers crossed it’s something simple , if u don’t get anywhere would at least try the connections on the back of ur instrument cluster are all ok

Can also do a can bus test using a multimeter TP is just short for test probe from ur multimeter

Disconnect the battery first then test

TP to pin 6 other TP to pin 14 , read ohms
TP to pin 3 other TP to pin 11, read ohms

Hope that also helps u
   
Post #231624725th Nov 2022 9:42 am
View user's profile Send private message View poster's gallery Reply with quote
Sneakymickeyy
 


Member Since: 20 Dec 2021
Location: Høland
Posts: 11

Norway 2006 Discovery 3 TDV6 HSE Lux Auto Barolo BlackDiscovery 3

Figuerd it out its the park brake modul that's gone so bypassing it for the winter and will have to change it to the spring
  
Post #231658627th Nov 2022 6:32 pm
View user's profile Send private message View poster's gallery Reply with quote
Landyjem
 


Member Since: 11 Mar 2023
Location: Cheshire
Posts: 2

United Kingdom 
New to me disco 3 manual 2007

Hi everyone, have a d3 2007 which has just brought up loafs of error messages at once -after my other half power washed rhe car...
Attached is the fault codes, I had the handbrake auto release error, then hill descent fault, then transmission range change, and special programs unavailable.
Where do I start? Thank you jem [/u]
  
Post #232974611th Mar 2023 12:13 pm
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 2462

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

Start by charging the battery, reset the codes and see what comes back
 Andrew

D3 2.7tdv6 2005
D4 3.0 SDV6 Commercial died and gone to LR heaven
D5 3.0 SDV6 HSE 
 
Post #232975911th Mar 2023 2:16 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 14 of 15 <123 ... 131415>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site