Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Maintenance & Mods (D3)

New EPB fault !
Post Reply  Down to end
Page 1 of 1
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 924

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4
New EPB fault !

Help !!!!!!!!!!!

ok , my EPB remained blocked today! no screaming , just block... Twisted Evil
With the red and amber light , with message : handbrake failure
I tried all known solutions, nothing worked!
ok, so I pulled the emergency release cable!
D3 can go now , but , I still have the red flashing light, message: handbrake not applied, pull the lever EPB!
nothing happens, no fault codes ................. Question

So how resets the cable if the Emergency release cable has been activated ?

Normally, just put the handbrake!? ..........

I read that: EPB stuck onhttp://disco3.co.uk/forum/topic51509.html?highlight=emergency

Your advice please! Bow down
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #9274752nd May 2012 5:16 pm
View user's profile Send private message View poster's gallery Reply with quote
D4JWW
 


Member Since: 20 Oct 2009
Location: London, UK
Posts: 1315

South Africa 2009 Discovery 3 TDV6 GS Manual Stornoway GreyDiscovery 3

Sorry to hear of your latest problem Marco, I can't help! Did you try to rewind the cable as suggested in the thread? Hope you find a solution soon!
 A few mods... and keeping it all running...Faultmate MSV2
MY09EGR's blanked Thanks Bellautos, BAS 
 
Post #9275612nd May 2012 8:23 pm
View user's profile Send private message View poster's gallery Reply with quote
SteveNorman
 


Member Since: 14 Oct 2005
Location: Somerset
Posts: 874

United Kingdom 

If the handbrake switch doesn't operate, suggest you read the fault codes to see the reason for failure in the first place.
This will point you in the right direction.

Regards
Steve
  
Post #9276753rd May 2012 9:30 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 924

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Hi Steve

Before I pull the "emergency release cable" , I had this code :C1AOO system failure,over temperature

And now : C1A53 Electronic parking brake latching failure, emergency release as been activated.
Normal ,but , now, How to connect the emergency release cable ? Normally, just put the handbrake!? .......But , he doesn't work.........
When I try to apply park brake , C1A00 appears again .........erased with my FCR
Look my video :
http://youtu.be/TUVhhymeoT4
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 


Last edited by marco 110 on 3rd May 2012 5:31 pm. Edited 2 times in total 
Post #9277073rd May 2012 12:40 pm
View user's profile Send private message View poster's gallery Reply with quote
D4JWW
 


Member Since: 20 Oct 2009
Location: London, UK
Posts: 1315

South Africa 2009 Discovery 3 TDV6 GS Manual Stornoway GreyDiscovery 3

It's not normal for red suspp light after using emergency cable, sounds like it could be the handbrake switch as well?
 A few mods... and keeping it all running...Faultmate MSV2
MY09EGR's blanked Thanks Bellautos, BAS 
 
Post #9277713rd May 2012 4:49 pm
View user's profile Send private message View poster's gallery Reply with quote
SteveNorman
 


Member Since: 14 Oct 2005
Location: Somerset
Posts: 874

United Kingdom 

Have you tried pulling the parkbrake switch twice quickly?

Also: for fault code C1A5368 Manual emergency release activated - automatic parking brake actuator module cable re- engagement (latching) failed,

Check that the emergency release cable is not permanently pulled (or stuck). Check the parking brake cables for broken or loose connections. Attempt to re-engage the parking brake by pulling the apply switch TWICE. Clear DTCs, complete the following drive cycle. Pull the parking brake emergency release cable. Pull the parking brake switch to the apply position, hold until the parking brake motor has stopped (this may take up to 20 seconds). Release the switch to idle position

As for code C1A00, there should be a 2 digit number after this which would point you in the right direction, as there a 4 fault codes starting with C1A00.
Usualyu a flashing red 'P' means, a component failure, i.e. not responding, perhaps wiring etc. have you got 'no communication with park brake module' listed in any other ecu's, i.e. engine, etc?

I think the C1A00-?? is the fault causing the cables/motor to not re-engage.

HTH
STeve
  
Post #9279864th May 2012 8:13 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 924

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Hello Steve.

First: thank you for your help!
I tried all your advice, nothing works ....
I hear the engine to the EPB, cloc cloc cloc, for 20 seconds, but nothing happens ......
The emergency cable seems to me "free", and slides well in his sheath, same for the cables that go to the rear brakes!

Quote:
I think the C1A00-?? is the fault causing the cables/motor to not re-engage.

I think too !
I only have this code, when I tried to apply the EPB, with the message system failure: over temperature, permanent!
What a fabulous car by itself, she'll save the economy of Land Rover!

What do you think about this :
Click image to enlarge


in this post : http://disco3.co.uk/forum/topic51509.html?highlight=emergency

Admin note: this post has had its images recovered from a money grabbing photo hosting site and reinstated Mr. Green
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #9280654th May 2012 10:14 am
View user's profile Send private message View poster's gallery Reply with quote
SteveNorman
 


Member Since: 14 Oct 2005
Location: Somerset
Posts: 874

United Kingdom 

C1A004B

Control module


NOTE: This is not a fault.
•Parking brake actuator module temperature protection invoked, typically due to overuse where there have been more than 15 apply and release cycles continuously

If the red parking brake warning indicator flashes the fault is the result of short term protection (message displayed). Allow the parking brake to cool for 60 seconds and retest for functionality. If the parking brake does not apply, check for other DTCs. Rectify as necessary. Clear DTCs, complete drive cycle 3 to test for normal operation, refer to the relevant drive cycle shown below this table.

Drive Cycle 3 Description
•Ignition On
•Make sure that the vehicle is stationary and that the parking brake is released
•Pull the parking brake switch to the apply position and hold in this position until the parking brake motor has stopped (this may take up to 5 seconds)
•Release the parking brake switch to the idle position, leave in the idle position for 2 seconds
•Push the parking brake switch to the release position (with foot on the brake pedal) and keep in this position until the parking brake motor has stopped (this may take up to 5 seconds)
•Release the parking brake switch to the idle position

If that fails, then the reason for the cables not relatching will have to be investigated, (are the free, i.e. movement in the wheel end). etc.
If it doesn't relatch then the thermal protection comes in.
The relatch is just a mechanical latch, the motor drives it to the position where it can latch in, unless something is physically stopping it.

regards
Steve
  
Post #9298109th May 2012 12:09 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 924

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Thank Steve ! Thumbs Up

I will test these methods tomorrow, I'll let you know!

regards.
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #9299349th May 2012 5:04 pm
View user's profile Send private message View poster's gallery Reply with quote
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 924

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Steve.

Tried everything, nothing works .............
Just the engine noise of the EPB we hear!
And, always the fault code C1A5368 :Manual emergency release activated - automatic parking brake actuator module cable re- engagement (latching) failed,

I'll have to disassemble, I think.

Thanks for your help. Thumbs Up
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #93054511th May 2012 10:09 am
View user's profile Send private message View poster's gallery Reply with quote
fatpipe12
 


Member Since: 15 Jun 2013
Location: Lancashire
Posts: 1

United Kingdom 2005 Discovery 3 TDV6 SE Manual Adriatic BlueDiscovery 3

Hello.

Two days after the LR3 passed the MOT the EPB stopped working, no squeeling sounds nothing not even when the key was removed. After messing for a while the brake actuated and came on. Then I parked up used the brake as normal and went about my business, when I returned it would not release at all ...... emergency release pulled and i'm on my way.

Now I have a permanently flashing red warning light on the dash with th error message Park Brake Fault. Whilst booking my wifes car in for a lamda sensor fault I ask the guy at the Garage if he can read the faults from the Landrover so He put the machine on and it stated the there was a fault and the emergency had been bulled he selected "reset" nothing happened .... he reset all DTCs and they instantly came back .... he's not an LR man so didn't want to go any further at this stage without consulting someone.

If I sit with the engine off and ignition on then pull and hold the paddle I can distinctly hear something like three soft clunks then the amber light comes on and the bloody dinging noise.

Can anyone offer an insight to this problem as the unit has been changed once according to the paperwork I got with it. And there was not the "usual" squeeling noises to indicate end of travel

Regards


Mike
  
Post #111788015th Jun 2013 9:02 pm
View user's profile Send private message View poster's gallery Reply with quote
gruodiz
Site Supporter 


Member Since: 16 Nov 2011
Location: Klaipeda
Posts: 273

Lithuania 2006 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

Some handy info from workshop manual

Amber Parking Brake Warning Indicator

The amber parking brake warning indicator is continuously illuminated if there is a parking brake system fault. Operation of the indicator is controlled by a high speed controller area network (CAN) bus signal from the parking brake module to the instrument cluster.

Red Parking Brake Warning Indicator

When the parking brake is applied, the red parking brake warning indicator is continuously lluminated while the ignition is on and for 3 minutes after the ignition is switched off. If the system is unable to comply with an apply or release request, due to a system fault, the indicator flashes. When the ignition is on and the indicator is not flashing, operation is controlled by a high speed CAN bus signal from the parking brake module to the instrument cluster. When the ignition is off or when the indicator is flashing, operation is controlled by a hardwired signal from the parking brake module to the instrument cluster
  
Post #159339315th Jan 2016 9:06 am
View user's profile Send private message View poster's gallery Reply with quote
raj03
 


Member Since: 05 Nov 2017
Location: blackburn
Posts: 1

United Kingdom 2007 Discovery 3 TDV6 Base 7 Seat Auto Aintree GreenDiscovery 3

I had the similar problem, i took my car to my local garage, they refurbished my epb module replace new rear discs and pad and new handbrake shoes. they charge me £550 with one year warranty. LR dealer quoted me £1600.
  
Post #18759965th Nov 2017 6:24 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 65

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

Odd first post as the company refurbishing most handbrake modules are from Blackburn and the original thread is from 5 years ago, I smell tinned meat, even after having my module done. Y them
  
Post #18760235th Nov 2017 7:22 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site