Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D3)

Please save my sanity... (and alarm!)- FIXED 13/10/17
Post Reply  Down to end
Page 1 of 2 12>
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3
Please save my sanity... (and alarm!)- FIXED 13/10/17

Over the last few days i've started having issues with my alarm activating seemingly randomly. I've searched on here, and found the bonnet catch to be a common culprit so replaced this today. Unfortunately this hasn't fixed the problem.

I have recently fitted a T-Max split charger and Optima yellow top battery, plus a brand new starter battery and thought that this could be the cause and the alarm could be reacting in the same way as a battery being disconnected, so have unplugged the alarm sounder module so that the alarm operates by horn (I believe this also deactivates the battery monitoring function) but this hasn't solved the issue.

The alarm is still triggered if I double lock and disable the internal sensors so it's not a spider/fly/mouse etc.

When the alarm does trigger, if i press unlock on the fob i get 8 indicator flashes, and if i try and re-arm by pressing lock straight away (without opening a door) the horn sounds once. If I open and close a door the alarm will re-arm.

I've got a nanocom evo, is there any way I can use this to determine what is activating the alarm?
Could it be the split charge system? If not, what are other likely candidates?

A
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 


Last edited by Downsman on 14th Oct 2017 8:20 am. Edited 1 time in total 
Post #18652485th Oct 2017 6:10 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

update: Went out to disconnect the split charger just to rule it out as a cause, and realised the internal lights were still on. Tried opening and closing all of the doors and boot, but lights stayed on.

Put key in ignition and drivers window down, shut the door and the car informed me the drivers door was still open. One firm slam of the door later, and interior lights go out and no door open message any more.

Result is that i'm 98% sure its the drivers door latch now! Assuming it's not as simple a job as the bonnet one?
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #18652855th Oct 2017 7:01 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Ok it's still going off even after making sure it recognised the door being shut.

Any help appreciated.
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #18653455th Oct 2017 8:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Erea
 


Member Since: 19 Mar 2012
Location: Munster
Posts: 665

Ireland 2006 Discovery 3 TDV6 Commercial Manual Zambezi SilverDiscovery 3

Press the lock button twice fairly fast turns off the internal sensors. A. to rule them out. B. Incase a fly or spider is having fun with your sensors. I know it's not much help but that's what normally sets my alarm off.
  
Post #18653875th Oct 2017 11:09 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Thanks, have tried that though and no success.

I'm still fairly sure it's the drivers door latch, my only hesitation is that the car seems to go from thinking it's closed to thinking its open without any physical movement of the door or mechanism. Does this still sound plausible?
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #18653895th Oct 2017 11:21 pm
View user's profile Send private message View poster's gallery Reply with quote
Narpy
Site Supporter 


Member Since: 18 Jul 2011
Location: Stockport
Posts: 6113

2005 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

Get your Ctek charger out and fully charge the battery. The car might be recognising a slight drop in voltage during the night with the replacement battery, charging it might help at least eliminate one possible cause and might eradicate it completely whilst it's charging. Thumbs Up
 Mods:
Front Fogs + Halos
FBH Remote Control
The 1st Ever RRS Modded Grill
Garmin Nuvi + D4 Surround + Reversing Camera.
D4 Steering Wheel.
Rear Boot Spoiler.
Twin Brake Lights.
Wing Mirror Indicator Repeaters.
Long Roof Rails
Make your own Narpy grill thread 
 
Post #18653955th Oct 2017 11:34 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Yep is on charge now. Am I right in thinking it is the alarm module that detects a drop in voltage and sets off the alarm though, or does another ECU do this?
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #18653965th Oct 2017 11:41 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Update: purchased a CTEK MXS25 so that I also have a 25A supply for doing any potential ECU work in future.

After leaving car unlocked overnight for a few days, car had a full overnight charge with the CTEK and in the morning the alarm was set with no issues. I did a few short journeys in the evening, locked up at 10pm and then the alarm went off again at 3am this morning.

Using DDM main battery is reading 12.69V and aux is reading 12.73V this morning with car asleep. Current draw is showing as 0.005Amp when connecting DDM in serial.

On Startup, alternator is putting out 13.6V, but when putting on high draw items (heated seats, lights, A/C) drops to 12.5V.

Alternator gone?
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #186697310th Oct 2017 1:57 pm
View user's profile Send private message View poster's gallery Reply with quote
Narpy
Site Supporter 


Member Since: 18 Jul 2011
Location: Stockport
Posts: 6113

2005 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

It does look like it's going down. Big Cry

Should really be high 14v (14.8v or similar) at start up dropping to low 14v after it's been running a while so your readings do seem low.

No idea if that's causing your alarm issues unfortunately. Confused
 Mods:
Front Fogs + Halos
FBH Remote Control
The 1st Ever RRS Modded Grill
Garmin Nuvi + D4 Surround + Reversing Camera.
D4 Steering Wheel.
Rear Boot Spoiler.
Twin Brake Lights.
Wing Mirror Indicator Repeaters.
Long Roof Rails
Make your own Narpy grill thread 
 
Post #186702210th Oct 2017 3:09 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Thanks, new denso on order and will update once fitted!

I'm also leaving the car plugged into the CTEK in supply mode, with the alarm set (and bonnet catch engaged) to see if effectively bypassing the battery system solves the alarm issue!

The only nagging doubt i have is that lots of others here have posted about parasitic drains, dead batteries etc but none have mentioned the alarm going off as part of this process...
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #186702410th Oct 2017 3:13 pm
View user's profile Send private message View poster's gallery Reply with quote
Narpy
Site Supporter 


Member Since: 18 Jul 2011
Location: Stockport
Posts: 6113

2005 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

Don't worry too much about other posters issues. If you read every post on here you'd become completely paranoid and just want to sell your Discovery before one of the posts became your impending nightmare. Rolling Eyes
 Mods:
Front Fogs + Halos
FBH Remote Control
The 1st Ever RRS Modded Grill
Garmin Nuvi + D4 Surround + Reversing Camera.
D4 Steering Wheel.
Rear Boot Spoiler.
Twin Brake Lights.
Wing Mirror Indicator Repeaters.
Long Roof Rails
Make your own Narpy grill thread 
 
Post #186703010th Oct 2017 3:34 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Last night the car was left locked with the CTEK providing supply to rule out power issues. Alarm went off again at 11:30pm so spent the rest of the night unlocked. Really need to get this sorted!!

When driving along dual carriageway today, the interior light came on and got a door open message flash up on the dash. Given I have the auto-lock set there definitely wasn't a door open! I didn't catch which door (eyes on the road) but presume drivers given the messages seen previously.

Alternator also arrived today, but damaged so needs to go back. Hopefully Ribble Valley 4x4 will provide a replacement FOC but doesn't look like that is impacting the alarm either way.


So.... replacement drivers door actuator? 315mhz or 433mhz for a UK spec 2007 D3?
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #186738311th Oct 2017 12:33 pm
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Mr postman kindly delivered my new door latch unit today, a helpful guide found on here and good weather forecast for the weekend. With any luck this cures my woes...
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #186803513th Oct 2017 10:45 am
View user's profile Send private message View poster's gallery Reply with quote
Mr Kington
 


Member Since: 12 Dec 2011
Location: Scottish Borders
Posts: 1179

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Siberian SilverDiscovery 3

You tried a hard re set ? Solves most issues electrical wise
 James favourite hobby is writing in the third person.  
Post #186804813th Oct 2017 11:10 am
View user's profile Send private message View poster's gallery Reply with quote
Downsman
 


Member Since: 04 Sep 2017
Location: Sussex
Posts: 87

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Montalcino RedDiscovery 3

Finished work early so thought I’d tackle replacing the actuator mechanism and managed it in around an hour down to the fantastic guides on here. Only issue encountered was using tape to hold the window in place - the Censored stuff took the lacquer layer off the door paint!!! Can’t believe it, only used insulation tape so nothing particularly strong.



Fingers crossed this has solved the alarm issue, what can I do with the paintwork though?!
 2007 Discovery 3 HSE
1986 Land Rover 90 Ex-MOD

1996 discovery 1 v8 (gone) 
 
Post #186819913th Oct 2017 6:17 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site