Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Revs Dropping
Post Reply  Down to end
Page 1 of 2 12>
MikeS2005
 


Member Since: 13 Sep 2008
Location: Midlothian
Posts: 920

Scotland 2005 Discovery 3 TDV6 HSE Manual Zambezi SilverDiscovery 3
Revs Dropping

Hi All
Can anyone help me with this Ive got an 05 HSE D3 manual and first thing in the morning when I start the car and drive away I get to the first road junction and slow down the revs suddenly drop and the battery light appears for a split second like it is going to stall then the revs come up again and all is okay,
It dosnt do it when its warm everything is fine and its not EGRs cause they have both been done.It has also had a brand new battery, its just a pain every now an again cause it keeps stalling
Im running out of ideas.
 

Last edited by MikeS2005 on 13th Dec 2009 6:46 pm. Edited 1 time in total 
Post #56447813th Dec 2009 4:43 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
kernowexpeditionaryforce
 


Member Since: 15 Jan 2009
Location: Kernow
Posts: 329

2006 Discovery 3 TDV6 S Auto Buckingham BlueDiscovery 3

mine also does that, but i dont get the battery light!
  
Post #56448813th Dec 2009 5:45 pm
View user's profile Send private message View poster's gallery Reply with quote
Gareth
Site Moderator 


Member Since: 07 Dec 2004
Location: Bramhall
Posts: 22717

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Lux Auto Fuji WhiteDiscovery 4

My original D3 (54 plate 05 model) used to do that every day. It did it from new, and never got any worse. Despite several 'software' upgrades it was always the same. It never caused me any problems in 125k miles so I would not worry.

FYI my newer 58 plate 08.5 model does not do it ever!
  
Post #56449013th Dec 2009 5:54 pm
View user's profile Send private message View poster's gallery Reply with quote
camelrock
 


Member Since: 11 Oct 2008
Location: north yorkshire
Posts: 425

England 

My 05 model does the same thing, but you'll find that it will only do it in cold weather. As soon as spring/summer comes it will stop till next winter. I understand that its a software thing that L/R have never got to the bottom of.
  
Post #5725781st Jan 2010 3:45 pm
View user's profile Send private message View poster's gallery Reply with quote
thorgal
 


Member Since: 26 Nov 2008
Location: on the east side
Posts: 438

United States 2005 LR3 4.4 V8 HSE Auto Bonatti GreyLR3

I had the same symptoms for months,no battery light though.I have changed a Throttle body and everything went back to normal. Thumbs Up
  
Post #58832723rd Jan 2010 2:26 pm
View user's profile Send private message View poster's gallery Reply with quote
TR
 


Member Since: 11 Nov 2007
Location: Hampshire
Posts: 77

2005 Discovery 3 TDV6 Base 7 Seat Manual Bonatti GreyDiscovery 3

How did you decide the throttle body was the cause , did a fault code register ?

I have the same issue from cold starting , below approx 5 degrees. on my 05 plate.

Fault was diagnosed by dealer as clutch drag , flywheel was found to have excessive movement and replaced together with clutch assy (2nd time in 43K miles) , thankfully under extended warranty. Previous attempts to fix included glow plugs and injector replacement.

However this has not resolved the problem and now looking for any leads into other causes.

Any help would be much appreciated.
  
Post #58871424th Jan 2010 6:58 am
View user's profile Send private message View poster's gallery Reply with quote
foggy19
 


Member Since: 04 Apr 2012
Location: Worcestershire
Posts: 48

England 2005 Discovery 3 TDV6 S Manual Adriatic BlueDiscovery 3

I have an 05 with the same issue also as revs drop battery light comes on briefly, I have just had service and mentioned it, still the same, Rolling Eyes
  
Post #9995917th Nov 2012 8:29 am
View user's profile Send private message View poster's gallery Reply with quote
Gornalhills
 


Member Since: 17 Jul 2012
Location: Dudley
Posts: 103

United Kingdom 

hi guys, had the same problem on my 05 when cold but fine when warm, asked the question on this amazing site and i was told battery or alternator. get it done before it bites you in the a**. Being a cautious person i decided to wait and see but guess what happend one day, only problem was the wife was collecting the kids so green flag had to come to the rescue. Should have listened ! Embarassed (fine now fixed) Bow down
  
Post #102180019th Dec 2012 8:34 pm
View user's profile Send private message View poster's gallery Reply with quote
Gornalhills
 


Member Since: 17 Jul 2012
Location: Dudley
Posts: 103

United Kingdom 

Hi again, forgot to ask, have you all got manual or does this also apply to autos as well. (mines the one with the longer stick) !! Thumbs Up
  
Post #102180819th Dec 2012 8:38 pm
View user's profile Send private message View poster's gallery Reply with quote
barti
 


Member Since: 14 Nov 2013
Location: Warsaw
Posts: 16

Poland 2006 Discovery 3 TDV6 SE Manual Belize GreenDiscovery 3

Hi Guys,

do you maybe have any update on this topic ?
My D3 started to have the same symptoms - revs below idle and ignition comes on. I noticed that it only happens when "stopping" the car with a clutch pressed and selected gear - then the revs go down and up. But I set to neutral and still keep the clutch pressed revs go to idle.
I also observed that after driving a longer distance(motorway) without using the clutch, the pedal gets harder than usually.

I suppose that it relates to problems with the clutch itself or the hydraulic system.

Do you maybe have any suggestions ?
Did you find a fix for that or you live with the dropping revs ?

Thanks
  
Post #13082338th Jul 2014 5:16 am
View user's profile Send private message View poster's gallery Reply with quote
pimackenzie
 


Member Since: 08 Jul 2012
Location: Hampshire
Posts: 63

United Kingdom 2006 Discovery 3 TDV6 S Manual Zermatt SilverDiscovery 3

Barti, I had the same on my 56 plate, stiff clutch pedal after long motorway journey ended up with new dual mass flywheel, clutch, pressure plate, and slave cylinder. £££££££££ Ouch Big Cry
  
Post #13082388th Jul 2014 6:14 am
View user's profile Send private message View poster's gallery Reply with quote
barti
 


Member Since: 14 Nov 2013
Location: Warsaw
Posts: 16

Poland 2006 Discovery 3 TDV6 SE Manual Belize GreenDiscovery 3

Pimackenzie you just made my day perfect Wink
Did you replace it all at once or step by step eliminating the issue ?
  
Post #13082468th Jul 2014 6:40 am
View user's profile Send private message View poster's gallery Reply with quote
pimackenzie
 


Member Since: 08 Jul 2012
Location: Hampshire
Posts: 63

United Kingdom 2006 Discovery 3 TDV6 S Manual Zermatt SilverDiscovery 3

Barti
I was told by the main stealers that my fly wheel was noisey and needed replacing, so while it was striped down I told them to put a complete clutch kit in. This made the clutch lighter, the gearbox quiter, and gear change smoother, what a differance it made to the whole driving experience.
  
Post #13084948th Jul 2014 3:03 pm
View user's profile Send private message View poster's gallery Reply with quote
barti
 


Member Since: 14 Nov 2013
Location: Warsaw
Posts: 16

Poland 2006 Discovery 3 TDV6 SE Manual Belize GreenDiscovery 3

I talked to LR garage. They told that this issue might be related not only to the clutch but also the XYZ sensor.
Actually it was not calibrated - so I did the calibration today(R,1,2,3,4,5,6) and currently I don't observe the revs idling.

Cheers
Bartek
  
Post #13092509th Jul 2014 8:59 pm
View user's profile Send private message View poster's gallery Reply with quote
Rand-lover
 


Member Since: 22 Aug 2013
Location: BRISBANE
Posts: 4

Australia 2005 Discovery 3 TDV6 SE Auto Unknown ColourDiscovery 3

I've had the same hesitant idle on 1st start in cold weather but in sunny Queensland Australia. From the previous post it seems this affects mostly manuals. Has anyone had the same occur with auto's?
  
Post #185711213th Sep 2017 10:10 am
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site