Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Maintenance & Mods (D3)

Smells of unburned diesel or oil at rear exhaust
Post Reply  Down to end
Page 1 of 1
mek
 


Member Since: 18 Mar 2015
Location: Zurich
Posts: 176

Switzerland 2006 Discovery 3 TDV6 Base 5 Seat Manual Aintree GreenDiscovery 3
Smells of unburned diesel or oil at rear exhaust

Hi,

My car smells. Specifically it smells of old diesel van. This is a problem because I need to take it for an emissions test and I feel like it wont pass it. Can you suggest how I can diagnose the issue?

I used my Bluetooth IID for the first time today and was able to read off the injector values which seem to be in tolerance. Other error codes shown below. Nothing relating to EGR valves (so far as I can tell) and these are not blanked.

Earlier in the year I replaced the intercooler for a stock land rover one and 2 of the 3 pipes I swapped over to 4 ply silicone. I have not changed the tiny one.... At that time I had a real loss of power which I don't seem to have this time. I first noticed this problem with the car last weekend when I did a 4 hour drive and it put out a bit of smoke when foot to the floor changing gears. It was night time so could not discern colour. Oil is just below the half way indicator but I have not been keeping an eye on it of late

I have read about turbo actuator and cleaning throttle body but not done anything with these yet- could these be a possible cause?

Thanks,


Andy




Click image to enlarge














  
Post #187231925th Oct 2017 6:29 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 1681

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

chuck "double strength" of the Millers additive in it and see if that clears it up ?

if you've not noticed power issues it could just be build up of $h1t !
  
Post #187233125th Oct 2017 6:55 pm
View user's profile Send private message View poster's gallery Reply with quote
mek
 


Member Since: 18 Mar 2015
Location: Zurich
Posts: 176

Switzerland 2006 Discovery 3 TDV6 Base 5 Seat Manual Aintree GreenDiscovery 3

I cleaned the MAP sensor, topped it up with premium diesel and then drove the car for a few hundred miles over a couple of days. Result is car has reduced smell and it passed it's Swiss emissions test with better results than 2 years ago.

It's slightly nerve-wracking watching the Swiss garage mechanic redlining your car 10 times over about 10 minutes to get 10 "max" data points for emissions. Thankfully the garage I went to was a 30 minute drive away so at least the engine was warm! I didn't get to see the procedure last time...
  
Post #18759105th Nov 2017 1:47 pm
View user's profile Send private message View poster's gallery Reply with quote
BrettKaz
 


Member Since: 11 Nov 2013
Location: Canberra
Posts: 153

Australia 2007 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

I would still check the silicon hose clamps... they have to be torqued quite tight since they are stiff and can slip off and cause the under-boost code which causes black smoke.
  
Post #18761376th Nov 2017 12:14 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site