Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Electrical] Suspension Height Failure
Post Reply  Down to end
Page 14 of 16 <123 ... 13 141516>
thanosgr
 


Member Since: 19 Aug 2016
Location: Athens
Posts: 7

Greece 

Hi Narpy

I guess you are familiar with the correct battery voltage for Disco 3 .I have 12.4 - 12.9 and 14.6 volts when the engine is running .lt seems strange to me.
Let me know your thoughts


Best Regards
  
Post #197671322nd Aug 2018 10:43 pm
View user's profile Send private message View poster's gallery Reply with quote
Wyatt
 


Member Since: 23 Dec 2017
Location: Australia
Posts: 5

Australia 2006 Discovery 3 4.0 V6 Petrol SE Auto Bonatti GreyDiscovery 3

Hi there, my 2006 Disco 3 is dropping around 30mm in the front over 3-4 days. If drivers door is left open it does not move. I have replaced the front valve block and cleaned the rear valve block. Could it be the dryer dissident breaking down? Any advice welcome.
 Hi there, my 2006 Disco 3 is dropping around 30mm in the front over 3-4 days. If drivers door is left open it does not move. I have replaced the front valve block and cleaned the rear valve block. Could it be the dryer dissident breaking down? Any advice welcome.  
Post #198263911th Sep 2018 9:42 pm
View user's profile Send private message View poster's gallery Reply with quote
tony gt
 


Member Since: 29 Jul 2018
Location: cardiff
Posts: 10

Wales 2008 Discovery 3 TDV6 Base 7 Seat Auto Unknown ColourDiscovery 3

Air suspension failure lights on,
I checked on the forum, thank god!
Soapy water test revealed the classic crack in the face of the air dryer next to the compressor. New compressor off flea bay, cost £45.00. Two hours work Very Happy later,,,,, no fault, the suspension is now fine!
Thanks so much to the contributors on the forum who have saved me hundreds of pounds at the stealers or else where.
 RR classic, dead in Ireland,
TD300, sold to a friend but totally restored,
TD5, gone but still going,
Ginetta G27 v8,
Porsche boxter,
low cost track car,
Disco 3 2008 
 
Post #198346814th Sep 2018 5:55 pm
View user's profile Send private message View poster's gallery Reply with quote
Danielle7
 


Member Since: 03 Nov 2018
Location: Canterbury Kent
Posts: 3

England 2007 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3
Suspension

Hi since my husband had the car reversed on ramps to do the handbrake actuator, it was in the air about 4 hours, anyway took off the ramps and now every time you start it it raises at the front to I presume off road and the rear stays at normal height? Drive a few miles and it levels out to normal height? Please help. He’s cleaned the sensors and checked they are in ok but wonders if he has knocked them while doing handbrake?
  
Post #19974653rd Nov 2018 10:57 am
View user's profile Send private message View poster's gallery Reply with quote
Globetrotter448
 


Member Since: 21 Mar 2017
Location: Londonderry NSW
Posts: 1791

Australia 2007 Discovery 3 4.0 V6 Petrol SE Auto Java BlackDiscovery 3

Height is determined by the height sensors, so the fronts are the problem, just might be sticky/mud etc stopping them working properly. There have been connector/broken wire problems with the sensors
  
Post #199927010th Nov 2018 10:15 am
View user's profile Send private message View poster's gallery Reply with quote
Danielle7
 


Member Since: 03 Nov 2018
Location: Canterbury Kent
Posts: 3

England 2007 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3
Sensors

Hi thanks, he gave the rear ones a clean and now the rear raises and the front stays standard height
  
Post #199927410th Nov 2018 10:31 am
View user's profile Send private message View poster's gallery Reply with quote
alexrose
 


Member Since: 23 May 2018
Location: Surrey
Posts: 28

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Alveston RedDiscovery 3

Just recently my 05 D3 HSE has been going into extended mode when I select access mode (I select access mode whenever I get out, otherwise wife and kids find it a bit of a jump!)
Selecting access mode again drops the vehicle, I was wondering if I might have crud on sensors or something like that?
  
Post #20340024th Mar 2019 11:53 pm
View user's profile Send private message View poster's gallery Reply with quote
Justjoe
 


Member Since: 16 Jul 2019
Location: Preston
Posts: 15

United Kingdom 2006 Discovery 3 TDV6 SE Auto Unknown ColourDiscovery 3

Hello, my d3 says suspension normal height only. Just wondering if theres anything i can check before i go get it plugged in?
Thanks
  
Post #206982020th Jul 2019 7:48 pm
View user's profile Send private message View poster's gallery Reply with quote
longbow
 


Member Since: 03 Oct 2011
Location: sussex
Posts: 7

United Kingdom 2008 Discovery 3 TDV6 GS Auto Stornoway GreyDiscovery 3

hi, my 58 d3 loses height on all four corners overnight, dash shows suspension fault and it still goes up when selected , took out fuse 26 as suggested on forum and all corners stayed up, can I assume that there are no leaks from reservoir to suspension airbag's? and if so what next, all help very much appreciated, thanks all. PS just went out and unlocked door didn't put key in ignition and car lost height, is that significant does it point to anything thanks again.
  
Post #20727651st Aug 2019 11:25 am
View user's profile Send private message View poster's gallery Reply with quote
Disco chap
 


Member Since: 28 Jul 2021
Location: Kent
Posts: 1

United Kingdom 

Hi I have a 2009 disco 3 about a month ago suspension light come on and said normal height only so could still drive it and then a week later it said slow rising so replaced compressor and relay 2 days ago and light still on and normal height only still and today wife come home and it looked like car was doing nose dive front was down and back was fully up took out Fuses and got it to level out and on the display screen from left wheel has dropped down on screen and red flashing light


Any ideas
Cheers. Nick
  
Post #224396728th Jul 2021 7:37 pm
View user's profile Send private message View poster's gallery Reply with quote
MikeO
 


Member Since: 15 Jan 2014
Location: The Cotswolds
Posts: 1384

Scotland 

Could be a height sensor but you really need a code reader to read fault codes and live values.
 2016 Skoda Octavia VRS Estate
<gone>2009 FF Vogue TDV8 Buckingham Blue</gone>
<gone>2015 BMW 520D SE (not my favourite car)</gone>
<gone>2009 D3 HSE Galway Green</gone 
 
Post #224396828th Jul 2021 7:48 pm
View user's profile Send private message View poster's gallery Reply with quote
Spook1138
 


Member Since: 26 Jul 2021
Location: Loughborough
Posts: 14

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3
SUSPENSION RIDE HEIGHT/SPEED ISSUE…

Hi all,

Very new here so please be gentle,

RRS 2006 2.7 - Front drivers side Ride Height Sensor replaced, successfully calibrated using IID tool, but if I go above 40 for longer than amount 30-45 seconds dash reads suspension fault, RED warning ‘suspension’ light, warning message 30MPH max speed and car lowers a to bumps!

If I park up switch engine off then on again fault goes away and car drives ok as long as under 40MPH.

Ironically, if I disconnect the new sensor everything appears to be ALL good other that after about 2 hours of driving the overall ride height becomes a little uneven, but this is resolved if I select off road height then normal height…..

I’d love to resolve this but I need a little pointing in the right direction…Ive purchased an IID fault reader so I’m all good to go…just need a LR knowledgable YODA like JEDI for educating this PADOWAN!…
  
Post #224643313th Aug 2021 5:19 pm
View user's profile Send private message View poster's gallery Reply with quote
Globetrotter448
 


Member Since: 21 Mar 2017
Location: Londonderry NSW
Posts: 1791

Australia 2007 Discovery 3 4.0 V6 Petrol SE Auto Java BlackDiscovery 3

You do know that there is a left and right side height sensors so check you have the correct one.
  
Post #224648914th Aug 2021 12:21 am
View user's profile Send private message View poster's gallery Reply with quote
Spook1138
 


Member Since: 26 Jul 2021
Location: Loughborough
Posts: 14

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3

Yeah an aware of each ‘corner’ having its own independent height sensor, like I said the ‘offending’ one was replaced and now I have this issue relating to going faster than 40mph… Crying or Very sad
  
Post #224649414th Aug 2021 7:32 am
View user's profile Send private message View poster's gallery Reply with quote
aja4x4
 


Member Since: 14 Apr 2019
Location: Westbury
Posts: 2462

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zambezi SilverDiscovery 3

Have you looked at what its saying on the 4x4 screen it will show you if you have a sensor issue and which one is faulty.
Although you have replaced a sensor you may also have a wiring fault
 Andrew

D3 2.7tdv6 2005
D4 3.0 SDV6 Commercial died and gone to LR heaven
D5 3.0 SDV6 HSE 
 
Post #224649814th Aug 2021 7:57 am
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 14 of 16 <123 ... 13 141516>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site