Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > My Discovery 3

Tow bar electrics
Post Reply  Down to end
Page 1 of 1
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3
Tow bar electrics

Bought a trailer to use since the disco already was wired up with a black, 7pin socket.
Got tail lights but no indicators. Bought a tail board thinking it was the trailer at fault but the same problem exists.

Made a test lamp up and it flashes twice. George going dead as if there's a bulb out. I then have to reset the ignition to get the indicator on the car working again - any ideas ? Desperate to get my trailer working
  
Post #184937720th Aug 2017 7:34 pm
View user's profile Send private message View poster's gallery Reply with quote
geoffsnook
 


Member Since: 13 Jun 2014
Location: south wales
Posts: 2461

Wales 

Does your trailer indicator flash on the dash board when you put the indicators flash Thumbs Up
 Discovery 3 se gone
Range rover sport supercharged here:) 
 
Post #184939020th Aug 2017 7:46 pm
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

No, no trailer symbol illuminated at all.
  
Post #184941020th Aug 2017 8:10 pm
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Just wondering what if a previous owner ran a trailer with LED's and fitted a bypass relay - how would this now affect a trailer with ordinary lights ?
  
Post #184945920th Aug 2017 9:51 pm
View user's profile Send private message View poster's gallery Reply with quote
geoffsnook
 


Member Since: 13 Jun 2014
Location: south wales
Posts: 2461

Wales 

you may need to have your ccf edited to let the car know it has trailer electrics fitted as you have no illuminated bits on your dash funny old things these cars Thumbs Up
 Discovery 3 se gone
Range rover sport supercharged here:) 
 
Post #184946120th Aug 2017 9:54 pm
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

tried that earlier tonight with my IID tool, didn't make any difference
  
Post #184947320th Aug 2017 11:07 pm
View user's profile Send private message View poster's gallery Reply with quote
geoffsnook
 


Member Since: 13 Jun 2014
Location: south wales
Posts: 2461

Wales 

You need to check the wiring at the sockets then and the earths in the rear panels but try undoing the socket first and see if there is a lose wire Thumbs Up
 Discovery 3 se gone
Range rover sport supercharged here:) 
 
Post #184950021st Aug 2017 7:00 am
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Thanks Geoffsnook, I'll try that later.
  
Post #184950521st Aug 2017 7:19 am
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Took the plug off and all seems good, I'm admitting defeat and have booked it into a towbar specialist.
Goes in on Wednesday, can't help thinking it's something silly.

Thanks,
Stephen.
  
Post #184960321st Aug 2017 11:05 am
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Car went into the towbar specialist and he couldn't fix it.
He put it next door to the Land Rover specialist and they couldn't find the fault - says he's never seen a fault like that on a Land Rover.
They tested it with a low wattage test bulb and worked fine.
So they hooked up led lights to try that - they worked but it shows a fault like a bulb out on the dash.

Said there must be a low voltage relay somewhere.

Anywhere sell low wattage indicator bulbs ??
  
Post #185043323rd Aug 2017 5:26 pm
View user's profile Send private message View poster's gallery Reply with quote
L319
 


Member Since: 14 Dec 2013
Location: Herefordshire
Posts: 1177

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

You can get 10 watt bulbs BA 15S . From your initial post , do I gather its not an original LR installation as you only mention one socket , black. Is that the case?
  
Post #185046223rd Aug 2017 6:43 pm
View user's profile Send private message View poster's gallery Reply with quote
Judderman
 


Member Since: 19 Mar 2016
Location: Highland
Posts: 41

Scotland 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

It was already fitted to the car when I bought it roughly 18mths ago. Yes single electrics. Don't know how original it is - it's wired through the offside side and has single fuses, rather than the nearside with the fuse block.
  
Post #185050023rd Aug 2017 7:51 pm
View user's profile Send private message View poster's gallery Reply with quote
L319
 


Member Since: 14 Dec 2013
Location: Herefordshire
Posts: 1177

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

In my opinion its certainly an aftermarket fix and not knowing where the wires are tapped into makes it difficult to determine the cause of your problems. There's probably a high resistance connection somewhere & I can only suggest to follow the wires from the socket back to where they are connected to the car wiring and make sure the connections are all sound. Of course you don't know whether it as ever worked correctly!
  
Post #185055523rd Aug 2017 10:03 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site