Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Mutliple faults lit up the dashboard
Post Reply  Down to end
Page 7 of 9 <123456789>
Gudge
 


Member Since: 01 Apr 2013
Location: Herefordshire
Posts: 39

United Kingdom 2007 Discovery 3 TDV6 GS Auto Zermatt SilverDiscovery 3

gabrul wrote:
Had all the problems related here several times:

- Special programs off
- suspension lowered
- park break fault
- HDC off

looked all the tail lights, no success. Sent to an independent specialist and the result was a ABS sensor fault.

the car is returning from the dealer today. let´s see if stays like that.



Brakelight switch fault causes these exact same symptoms
  
Post #12337539th Feb 2014 2:34 pm
View user's profile Send private message View poster's gallery Reply with quote
terryall
 


Member Since: 17 Jun 2011
Location: London
Posts: 770

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

As this is a regular subject I'll throw in my experience. Had all the usual pencil programmes off etc faults showing up on and off for considerable period but could not find cause. Even spent a day with site sponsor Geoff trying to solve mystery including changing compressor bought off thi forum and proved to be working OK. Still did not solve it so agreed it would have to go to main dealer. They is sister it was compressor and after much discussion about current one working they put new one on. Phone call next day to say it had not solved anything so new compressor of and old one back on. Dealer kept car for 5 days of tests and could not find cause BUT they took battery off ( which was only a week old) and when put back on no fault showing. They asked to keep car extra two days for tests and still could not find any fault so they admitted they are baffled but asked me to take car away and come back as soon as suspension fault show up. It did not. However, left car at Heathrow for 5 days until yesterday and when I got back and started her up suspension fault amber lights showed up. Recycled ignition nd all was well again. Tested battery when I got home and it registered a low charge so I'm wondering is there something that drains the battery when parked up as a low battery will cause amber light to come on.
Very odd as it is a brand new battery. So, if a main dealer camping find a fault after 7 days I have little chance doing it myself. They charged me £60 for the testing as they could not find the fault but must have spent hours doing so.
  
Post #125419517th Mar 2014 8:21 am
View user's profile Send private message View poster's gallery Reply with quote
terryall
 


Member Since: 17 Jun 2011
Location: London
Posts: 770

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

Some interesting predictive text in the above! Apologies......
  
Post #125419617th Mar 2014 8:24 am
View user's profile Send private message View poster's gallery Reply with quote
Phifross
 


Member Since: 02 Feb 2013
Location: Monrovia
Posts: 17

Nigeria 2005 Discovery 3 4.4 V8 HSE Lux Auto Java BlackDiscovery 3

Dear all,


I have seen that I didn't answer in this thread that my problem was solved...
It was simply the connection behind the intrument cluster who was loosed.
I pout somehting and since then (six months) everything is working perfectly without any message or error.

You can also read this post, it can help.

http://www.disco3.co.uk/forum/topic101021-15.html


Thanks to everyone !!!
  
Post #12648205th Apr 2014 12:15 am
View user's profile Send private message View poster's gallery Reply with quote
plumbob3261
 


Member Since: 21 Feb 2013
Location: staffs
Posts: 6

England 

Had the same problem last year which I posted on the forum I found the problem was the earth
tabs had come off completely above the rear axle.You have to get the spare wheel down you will
see them on the right side looking from the rear.Still have problem with amber parkbrake light
coming on as posted Big Cry
  
Post #12653486th Apr 2014 9:27 am
View user's profile Send private message View poster's gallery Reply with quote
Simon.pl
 


Member Since: 02 Dec 2010
Location: Warsaw
Posts: 222

Poland 2007 Discovery 3 TDV6 Base 5 Seat Auto Unknown ColourDiscovery 3

Just had similar problem. Maybe will be helpful for someone.

The dash looked like this:



In my case it was rear wheel speed sensor problem (code C1A92).

What I found out after searching through the loom it was this Censored wire.



Would not expect it in such place.. Rolling Eyes
 Wrapped Satin Yellow&Black; Lovells 2" Gas Legend Kit, OME hard springs. ATX 192 17" wheels with Cooper STT M/T tires. ProSpeed Roof Rack & Rear Ladder. Custom made underbody protection, front bumper, rock sliders, spare wheel and accessories mountings, drawer system. WARN 9,5XP Winch. Front and Rear Light Guards, Safari Snorkel. VIAIR X'treme Duty OBA, Traxide USI-160 system, Danhag GSM & IPCU modules, IID Tool BT, James Baroud roof tent and awnings, and air horn for fun Smile  
Post #127677729th Apr 2014 1:45 pm
View user's profile Send private message View poster's gallery Reply with quote
MELISCAT
 


Member Since: 17 Dec 2009
Location: Macclesfield, Cheshire
Posts: 101

United Kingdom 2008 Discovery 3 TDV6 SE Auto Zermatt SilverDiscovery 3
Christmas Tree Lights up Early

Oh well Sad I suppose it had to happen at sometime or another!
Driving along quite happy last Wednesday on my way to LR Dealership, when the car decided to turn on the "Christmas" Lights Early.
Usual error messages, pulled the car over and turned of the engine.
Car would not restart but all the lights and messages kept coming up on the dash.

Contacted my local LR dealership in Knutsford and they low-loaded the car into their workshops.
Due to the Bank Holiday they are not going to be able to look at it until later this week. Just hope it is not going to be a big bill as the D3 had to have a new auto box last year after it let go near Kidderminster leaving me broke. Big Cry

Will update as soon as I have some news
 Mike  
Post #128928026th May 2014 10:44 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
MELISCAT
 


Member Since: 17 Dec 2009
Location: Macclesfield, Cheshire
Posts: 101

United Kingdom 2008 Discovery 3 TDV6 SE Auto Zermatt SilverDiscovery 3

It has been nearly a week since my D3 failed.
The main dealer has had to call in assistance from the next level of Landrover Tech support as they can't understand the fault! They can't even get me a loan car until next Friday at they earliest. Very poor show.
At the moment it is a very expensive paper weight :blue:


Should have updated this yonks ago - fault eventually traced to a faulty handbrake module electronic failure, not mechanical, after the body control module was replaced. Original BCM replaced and the car has been running great for the last 12 months! Very Happy
 Mike 

Last edited by MELISCAT on 24th Nov 2015 9:24 pm. Edited 1 time in total 
Post #129102729th May 2014 8:59 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
MELISCAT
 


Member Since: 17 Dec 2009
Location: Macclesfield, Cheshire
Posts: 101

United Kingdom 2008 Discovery 3 TDV6 SE Auto Zermatt SilverDiscovery 3

Well they have diagnosed a faulty Body Control Module after nearly 2 weeks!
Unit has been fitted and programmed to the car, only partial success, they have found that the Parking Brake Module board is faulty. They are not sure if this was causing the original fault, but they are going to fit a new unit, having proved with a second hand board that the car will fire up fault free. If this cures the problem they are going to put the cars original Body Control Module back in and see if the car is fault free and starts up. They will then only charge for the faulty module, I hope it is only the parking brake module that has failed electronically as it should be cheaper!.
I am not quite on the edge of despair but am getting closer as time goes on Sad
 Mike  
Post #12957669th Jun 2014 4:58 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
MELISCAT
 


Member Since: 17 Dec 2009
Location: Macclesfield, Cheshire
Posts: 101

United Kingdom 2008 Discovery 3 TDV6 SE Auto Zermatt SilverDiscovery 3

For got to say that they are having to drop the long range tank to gain full access to the parking brake module ....not good!
 Mike  
Post #12957699th Jun 2014 4:59 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Martyc
 


Member Since: 28 Mar 2014
Location: Bucks
Posts: 10

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Ok so looks like our D3 has the same issue. I was told to check the connections behind the osf inner wheel arch and work my way back to the abs sensor as it could be a faulty wire.

Fingers crossed I find the fault over the next couple of days before I take it away for a few days.
  
Post #13199163rd Aug 2014 11:33 pm
View user's profile Send private message View poster's gallery Reply with quote
MELISCAT
 


Member Since: 17 Dec 2009
Location: Macclesfield, Cheshire
Posts: 101

United Kingdom 2008 Discovery 3 TDV6 SE Auto Zermatt SilverDiscovery 3
Multiple light fault fixed

I should have posted the final update on my D3's "Christmas Light" earlier.
It turned out to be a faulty circuit board in the Parking Brake module.
New module fitted and the car has behaved itself for the last 900 miles.
Bill not as big as I thought it might be, but it has taken up the cash for an overland trip this year
 Mike  
Post #13203584th Aug 2014 9:29 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
mcsimmo
 


Member Since: 08 Aug 2011
Location: North of the south
Posts: 1760

Scotland 

Oh the joys of D3 ownership......
 Man with no D3 anymore, but cant leave the forum....how sad.  
Post #13204035th Aug 2014 6:41 am
View user's profile Send private message View poster's gallery Reply with quote
Martyc
 


Member Since: 28 Mar 2014
Location: Bucks
Posts: 10

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Well got it fixed and it was a broken/ damaged wire located where the air pump is???
5hrs labour, £5 parts and as we are taking it away I had a concern the wheel bearing(s) were knackered and osf certainly was. Expensive day before we head off on leave Sad
[/url]
  
Post #13214397th Aug 2014 1:34 am
View user's profile Send private message View poster's gallery Reply with quote
chicco698
 


Member Since: 13 Dec 2014
Location: Rovereto
Posts: 1

Italy 2005 LR3 TDV6 HSE Auto Buckingham BlueLR3
Re: Mutliple faults lit up the dashboard

slrk1725 wrote:
Hi
after one week of happy D3 ownership the car broke down yesterday. I did an enginge spray/clean with the Kaercher power washer 4 hours earlier but was careful not to spray on any connections. When searching for fault I blowed everything with compressed air but no change in "error" behaviour.

Transmission fault
HDC fault
Electric Hand Brake fault
Reduced traction
Terrain response system unavailable
and so on...all types of warning lights on the dash - looking like a US christmas tree (no offense)

No gears will engage - the dash indicates a F where the number ususally shows up (in sport mode)

Anyway is there a standard check to do for major electrickery faults like this. Ordered a BAS remap/fault code reader from Pete last week hopefully it is in the mail today or tomorrow.

The car is TDV6 2007, HSE auto..... btw


Edit: bad manners - I forgot my name

thanks in advance

Fredrik
  
Post #138923913th Dec 2014 10:08 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 7 of 9 <123456789>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site